diff mbox series

[meta-python,1/2] python3-pyudev: provide native

Message ID 20231205145032.1116030-1-kai.kang@windriver.com
State Accepted
Headers show
Series [meta-python,1/2] python3-pyudev: provide native | expand

Commit Message

Kai Dec. 5, 2023, 2:50 p.m. UTC
From: Kai Kang <kai.kang@windriver.com>

Add 'native' to BBCLASSEXTEND to provides python3-pyudev-native which is
required by lvm2 when package config 'dbus' is enabled.

Signed-off-by: Kai Kang <kai.kang@windriver.com>
---
 meta-python/recipes-devtools/python/python3-pyudev_0.24.1.bb | 2 ++
 1 file changed, 2 insertions(+)

Comments

Yoann Congal Dec. 5, 2023, 3:39 p.m. UTC | #1
Hi,

Le 05/12/2023 à 15:50, Kai Kang a écrit :
> From: Kai Kang <kai.kang@windriver.com>
> 
> Add 'native' to BBCLASSEXTEND to provides python3-pyudev-native which is
> required by lvm2 when package config 'dbus' is enabled.
> 
> Signed-off-by: Kai Kang <kai.kang@windriver.com>
> ---
>  meta-python/recipes-devtools/python/python3-pyudev_0.24.1.bb | 2 ++
>  1 file changed, 2 insertions(+)
> 
> diff --git a/meta-python/recipes-devtools/python/python3-pyudev_0.24.1.bb b/meta-python/recipes-devtools/python/python3-pyudev_0.24.1.bb
> index 6fcf346bc..8bc3afdb5 100644
> --- a/meta-python/recipes-devtools/python/python3-pyudev_0.24.1.bb
> +++ b/meta-python/recipes-devtools/python/python3-pyudev_0.24.1.bb
> @@ -20,3 +20,5 @@ RDEPENDS:${PN} = "\
>      ${PYTHON_PN}-fcntl \
>      libudev \
>  "
> +
> +BBCLASSEXTEND = "native"
> 
> 

On my setup, this fails with:
 $ bitbake python3-pyudev-native
Loading cache: 100% |##########################################################################################################################################################| Time: 0:00:00
Loaded 4996 entries from dependency cache.
Parsing recipes: 100% |########################################################################################################################################################| Time: 0:00:59
Parsing of 3129 .bb files complete (98 cached, 3031 parsed). 4997 targets, 140 skipped, 0 masked, 0 errors.
NOTE: Resolving any missing task queue dependencies
ERROR: Nothing RPROVIDES 'libudev-native' (but virtual:native:/.../yocto/poky/meta-openembedded/meta-python/recipes-devtools/python/python3-pyudev_0.24.1.bb RDEPENDS on or otherwise requires it)
NOTE: Runtime target 'libudev-native' is unbuildable, removing...
Missing or unbuildable dependency chain was: ['libudev-native']
ERROR: Required build target 'python3-pyudev-native' has no buildable providers.
Missing or unbuildable dependency chain was: ['python3-pyudev-native', 'libudev-native']

FYI, the native support was removed precisely to avoid this error on the autobuilder. 
See:
https://git.openembedded.org/meta-openembedded/commit/?id=d4aa17dc436beb96a804860bc6d18cf72283709e

In this case, I suppose, we would need to either add -native support for libudev or somehow cut the dependency python3-pyudev->libudev.

Maybe this is something you have locally and not pushed yet?

Regards,
Kai Dec. 6, 2023, 1:37 a.m. UTC | #2
On 12/5/23 23:39, Yoann Congal wrote:
> Hi,
>
> Le 05/12/2023 à 15:50, Kai Kang a écrit :
>> From: Kai Kang <kai.kang@windriver.com>
>>
>> Add 'native' to BBCLASSEXTEND to provides python3-pyudev-native which is
>> required by lvm2 when package config 'dbus' is enabled.
>>
>> Signed-off-by: Kai Kang <kai.kang@windriver.com>
>> ---
>>   meta-python/recipes-devtools/python/python3-pyudev_0.24.1.bb | 2 ++
>>   1 file changed, 2 insertions(+)
>>
>> diff --git a/meta-python/recipes-devtools/python/python3-pyudev_0.24.1.bb b/meta-python/recipes-devtools/python/python3-pyudev_0.24.1.bb
>> index 6fcf346bc..8bc3afdb5 100644
>> --- a/meta-python/recipes-devtools/python/python3-pyudev_0.24.1.bb
>> +++ b/meta-python/recipes-devtools/python/python3-pyudev_0.24.1.bb
>> @@ -20,3 +20,5 @@ RDEPENDS:${PN} = "\
>>       ${PYTHON_PN}-fcntl \
>>       libudev \
>>   "
>> +
>> +BBCLASSEXTEND = "native"
>>
>>
> On my setup, this fails with:
>   $ bitbake python3-pyudev-native
> Loading cache: 100% |##########################################################################################################################################################| Time: 0:00:00
> Loaded 4996 entries from dependency cache.
> Parsing recipes: 100% |########################################################################################################################################################| Time: 0:00:59
> Parsing of 3129 .bb files complete (98 cached, 3031 parsed). 4997 targets, 140 skipped, 0 masked, 0 errors.
> NOTE: Resolving any missing task queue dependencies
> ERROR: Nothing RPROVIDES 'libudev-native' (but virtual:native:/.../yocto/poky/meta-openembedded/meta-python/recipes-devtools/python/python3-pyudev_0.24.1.bb RDEPENDS on or otherwise requires it)
> NOTE: Runtime target 'libudev-native' is unbuildable, removing...
> Missing or unbuildable dependency chain was: ['libudev-native']
> ERROR: Required build target 'python3-pyudev-native' has no buildable providers.
> Missing or unbuildable dependency chain was: ['python3-pyudev-native', 'libudev-native']
>
> FYI, the native support was removed precisely to avoid this error on the autobuilder.
> See:
> https://git.openembedded.org/meta-openembedded/commit/?id=d4aa17dc436beb96a804860bc6d18cf72283709e
>
> In this case, I suppose, we would need to either add -native support for libudev or somehow cut the dependency python3-pyudev->libudev.
>
> Maybe this is something you have locally and not pushed yet?

Hi Yoann,

I am using 'systemd' as init manager and it RPROVIDES libudev-native. I 
haven't finger out the reason, but I'll try to remove this dependency chain.

$ bitbake libudev-native -e >be
ERROR: Nothing PROVIDES 'libudev-native'. Close matches:
   libdnet-native
libev-native
   libuv-native
   systemd RPROVIDES libudev-native

Regards,
Kai

>
> Regards,
Khem Raj Dec. 13, 2023, 7:07 a.m. UTC | #3
On Tue, 05 Dec 2023 22:50:31 +0800, kai.kang@windriver.com wrote:
> Add 'native' to BBCLASSEXTEND to provides python3-pyudev-native which is
> required by lvm2 when package config 'dbus' is enabled.
> 
> 

Applied, thanks!

[1/2] python3-pyudev: provide native
      (no commit info)
[2/2] lvm2: 2.03.16 -> 2.03.22
      commit: 02f460c5e379b3b0980374b3f89d55bc195d03d3

Best regards,
Yoann Congal Dec. 13, 2023, 7:58 a.m. UTC | #4
Hi,

Le 13/12/2023 à 08:07, Khem Raj a écrit :
> On Tue, 05 Dec 2023 22:50:31 +0800, kai.kang@windriver.com wrote:
>> Add 'native' to BBCLASSEXTEND to provides python3-pyudev-native which is
>> required by lvm2 when package config 'dbus' is enabled.
>>
>>
> 
> Applied, thanks!
> 
> [1/2] python3-pyudev: provide native
>       (no commit info)
> [2/2] lvm2: 2.03.16 -> 2.03.22
>       commit: 02f460c5e379b3b0980374b3f89d55bc195d03d3
I just check on the git repo, this means that only the lvm2 patch was applied (but not the pyudev one)

Maybe this case (partial application of a patch series) could be made more explicit in your template answer?

Thanks!

> Best regards,
> 
> 
> 
> -=-=-=-=-=-=-=-=-=-=-=-
> Links: You receive all messages sent to this group.
> View/Reply Online (#107351): https://lists.openembedded.org/g/openembedded-devel/message/107351
> Mute This Topic: https://lists.openembedded.org/mt/102992734/4316185
> Group Owner: openembedded-devel+owner@lists.openembedded.org
> Unsubscribe: https://lists.openembedded.org/g/openembedded-devel/unsub [yoann.congal@smile.fr]
> -=-=-=-=-=-=-=-=-=-=-=-
>
Kai Dec. 13, 2023, 8:08 a.m. UTC | #5
On 12/13/23 15:58, Yoann Congal wrote:
> Hi,
>
> Le 13/12/2023 à 08:07, Khem Raj a écrit :
>> On Tue, 05 Dec 2023 22:50:31 +0800, kai.kang@windriver.com wrote:
>>> Add 'native' to BBCLASSEXTEND to provides python3-pyudev-native which is
>>> required by lvm2 when package config 'dbus' is enabled.
>>>
>>>
>> Applied, thanks!
>>
>> [1/2] python3-pyudev: provide native
>>        (no commit info)
>> [2/2] lvm2: 2.03.16 -> 2.03.22
>>        commit: 02f460c5e379b3b0980374b3f89d55bc195d03d3
> I just check on the git repo, this means that only the lvm2 patch was applied (but not the pyudev one)
>
> Maybe this case (partial application of a patch series) could be made more explicit in your template answer?

The v2 thread is also replied. I suppose it may be need to skip the 
revision thread before final version.

Regards,
Kai

>
> Thanks!
>
>> Best regards,
>>
>>
>>
>> -=-=-=-=-=-=-=-=-=-=-=-
>> Links: You receive all messages sent to this group.
>> View/Reply Online (#107351): https://lists.openembedded.org/g/openembedded-devel/message/107351
>> Mute This Topic: https://lists.openembedded.org/mt/102992734/4316185
>> Group Owner: openembedded-devel+owner@lists.openembedded.org
>> Unsubscribe: https://lists.openembedded.org/g/openembedded-devel/unsub [yoann.congal@smile.fr]
>> -=-=-=-=-=-=-=-=-=-=-=-
>>
diff mbox series

Patch

diff --git a/meta-python/recipes-devtools/python/python3-pyudev_0.24.1.bb b/meta-python/recipes-devtools/python/python3-pyudev_0.24.1.bb
index 6fcf346bc..8bc3afdb5 100644
--- a/meta-python/recipes-devtools/python/python3-pyudev_0.24.1.bb
+++ b/meta-python/recipes-devtools/python/python3-pyudev_0.24.1.bb
@@ -20,3 +20,5 @@  RDEPENDS:${PN} = "\
     ${PYTHON_PN}-fcntl \
     libudev \
 "
+
+BBCLASSEXTEND = "native"