diff mbox series

mesa-demos: Split *info diagnostic tools from the main package

Message ID 20231113125732.379010-1-zboszor@gmail.com
State New
Headers show
Series mesa-demos: Split *info diagnostic tools from the main package | expand

Commit Message

Böszörményi Zoltán Nov. 13, 2023, 12:57 p.m. UTC
This creates 3 new subpackages:
* glxinfo
* eglinfo
* esinfo (for es1_info and es2_info)

These diagnostic utilities are useful without the demos.

Signed-off-by: Zoltán Böszörményi <zboszor@gmail.com>
---
 meta/recipes-graphics/mesa/mesa-demos_8.5.0.bb | 8 ++++++++
 1 file changed, 8 insertions(+)

Comments

Alexander Kanavin Nov. 15, 2023, 12:14 p.m. UTC | #1
I think the package names should be prefixed with {PN}, so that
there's a link to where they come from in their names. It's a common
convention.

Alex

On Mon, 13 Nov 2023 at 13:57, Zoltan Boszormenyi <zboszor@gmail.com> wrote:
>
> This creates 3 new subpackages:
> * glxinfo
> * eglinfo
> * esinfo (for es1_info and es2_info)
>
> These diagnostic utilities are useful without the demos.
>
> Signed-off-by: Zoltán Böszörményi <zboszor@gmail.com>
> ---
>  meta/recipes-graphics/mesa/mesa-demos_8.5.0.bb | 8 ++++++++
>  1 file changed, 8 insertions(+)
>
> diff --git a/meta/recipes-graphics/mesa/mesa-demos_8.5.0.bb b/meta/recipes-graphics/mesa/mesa-demos_8.5.0.bb
> index 12f41d75a5..789e816f13 100644
> --- a/meta/recipes-graphics/mesa/mesa-demos_8.5.0.bb
> +++ b/meta/recipes-graphics/mesa/mesa-demos_8.5.0.bb
> @@ -41,3 +41,11 @@ do_install:append() {
>                 mv ${D}${bindir}/clear ${D}${bindir}/clear.mesa-demos
>         fi
>  }
> +
> +PACKAGES =+ "glxinfo eglinfo esinfo"
> +
> +FILES:glxinfo = "${bindir}/glxinfo"
> +FILES:eglinfo = "${bindir}/eglinfo"
> +FILES:esinfo = "${bindir}/es1_info ${bindir}/es2_info"
> +
> +RDEPENDS:${PN} += "glxinfo eglinfo esinfo"
> --
> 2.41.0
>
>
> -=-=-=-=-=-=-=-=-=-=-=-
> Links: You receive all messages sent to this group.
> View/Reply Online (#190467): https://lists.openembedded.org/g/openembedded-core/message/190467
> Mute This Topic: https://lists.openembedded.org/mt/102560466/1686489
> Group Owner: openembedded-core+owner@lists.openembedded.org
> Unsubscribe: https://lists.openembedded.org/g/openembedded-core/unsub [alex.kanavin@gmail.com]
> -=-=-=-=-=-=-=-=-=-=-=-
>
diff mbox series

Patch

diff --git a/meta/recipes-graphics/mesa/mesa-demos_8.5.0.bb b/meta/recipes-graphics/mesa/mesa-demos_8.5.0.bb
index 12f41d75a5..789e816f13 100644
--- a/meta/recipes-graphics/mesa/mesa-demos_8.5.0.bb
+++ b/meta/recipes-graphics/mesa/mesa-demos_8.5.0.bb
@@ -41,3 +41,11 @@  do_install:append() {
 		mv ${D}${bindir}/clear ${D}${bindir}/clear.mesa-demos
 	fi
 }
+
+PACKAGES =+ "glxinfo eglinfo esinfo"
+
+FILES:glxinfo = "${bindir}/glxinfo"
+FILES:eglinfo = "${bindir}/eglinfo"
+FILES:esinfo = "${bindir}/es1_info ${bindir}/es2_info"
+
+RDEPENDS:${PN} += "glxinfo eglinfo esinfo"