[03/14] concurrencykit: enable 32- and 64-bit Arm targets

Message ID 20220201163507.1320861-3-ross.burton@arm.com
State New
Headers show
Series [01/14] python3-jsonpath-rw: set correct license | expand

Commit Message

Ross Burton Feb. 1, 2022, 4:34 p.m. UTC
As per upstream, 32- and 64-bit Arm targets are supported.

Signed-off-by: Ross Burton <ross.burton@arm.com>
---
 meta-oe/recipes-devtools/concurrencykit/concurrencykit_git.bb | 2 +-
 1 file changed, 1 insertion(+), 1 deletion(-)

Comments

Khem Raj Feb. 2, 2022, 8:16 p.m. UTC | #1
On Tue, Feb 1, 2022 at 8:35 AM Ross Burton <ross@burtonini.com> wrote:
>
> As per upstream, 32- and 64-bit Arm targets are supported.
>
> Signed-off-by: Ross Burton <ross.burton@arm.com>
> ---
>  meta-oe/recipes-devtools/concurrencykit/concurrencykit_git.bb | 2 +-
>  1 file changed, 1 insertion(+), 1 deletion(-)
>
> diff --git a/meta-oe/recipes-devtools/concurrencykit/concurrencykit_git.bb b/meta-oe/recipes-devtools/concurrencykit/concurrencykit_git.bb
> index 8d04507b09..0018064119 100644
> --- a/meta-oe/recipes-devtools/concurrencykit/concurrencykit_git.bb
> +++ b/meta-oe/recipes-devtools/concurrencykit/concurrencykit_git.bb
> @@ -16,7 +16,7 @@ SRC_URI = "git://github.com/concurrencykit/ck.git;branch=master;protocol=https \
>
>  S = "${WORKDIR}/git"
>
> -COMPATIBLE_HOST = "(i.86|x86_64|powerpc|powerpc64).*-linux*"
> +COMPATIBLE_HOST = "(arm|aarch64|i.86|x86_64|powerpc|powerpc64).*-linux*"
>

this perhaps is fine with gcc but its failing on arm/clang see
https://errors.yoctoproject.org/Errors/Details/623894/

>  inherit autotools-brokensep
>
> --
> 2.25.1
>
>
> -=-=-=-=-=-=-=-=-=-=-=-
> Links: You receive all messages sent to this group.
> View/Reply Online (#95188): https://lists.openembedded.org/g/openembedded-devel/message/95188
> Mute This Topic: https://lists.openembedded.org/mt/88836819/1997914
> Group Owner: openembedded-devel+owner@lists.openembedded.org
> Unsubscribe: https://lists.openembedded.org/g/openembedded-devel/unsub [raj.khem@gmail.com]
> -=-=-=-=-=-=-=-=-=-=-=-
>
Khem Raj Feb. 3, 2022, 7:54 p.m. UTC | #2
On Wed, Feb 2, 2022 at 12:16 PM Khem Raj <raj.khem@gmail.com> wrote:
>
> On Tue, Feb 1, 2022 at 8:35 AM Ross Burton <ross@burtonini.com> wrote:
> >
> > As per upstream, 32- and 64-bit Arm targets are supported.
> >
> > Signed-off-by: Ross Burton <ross.burton@arm.com>
> > ---
> >  meta-oe/recipes-devtools/concurrencykit/concurrencykit_git.bb | 2 +-
> >  1 file changed, 1 insertion(+), 1 deletion(-)
> >
> > diff --git a/meta-oe/recipes-devtools/concurrencykit/concurrencykit_git.bb b/meta-oe/recipes-devtools/concurrencykit/concurrencykit_git.bb
> > index 8d04507b09..0018064119 100644
> > --- a/meta-oe/recipes-devtools/concurrencykit/concurrencykit_git.bb
> > +++ b/meta-oe/recipes-devtools/concurrencykit/concurrencykit_git.bb
> > @@ -16,7 +16,7 @@ SRC_URI = "git://github.com/concurrencykit/ck.git;branch=master;protocol=https \
> >
> >  S = "${WORKDIR}/git"
> >
> > -COMPATIBLE_HOST = "(i.86|x86_64|powerpc|powerpc64).*-linux*"
> > +COMPATIBLE_HOST = "(arm|aarch64|i.86|x86_64|powerpc|powerpc64).*-linux*"
> >
>
> this perhaps is fine with gcc but its failing on arm/clang see
> https://errors.yoctoproject.org/Errors/Details/623894/

I have fixed it by disabling internal asm for this recipe in clang and
accepted this into meta-oe
https://github.com/kraj/meta-clang/commit/a4434a00d7fbd212c45c3ecd43ccdc87847f9505

>
> >  inherit autotools-brokensep
> >
> > --
> > 2.25.1
> >
> >
> > -=-=-=-=-=-=-=-=-=-=-=-
> > Links: You receive all messages sent to this group.
> > View/Reply Online (#95188): https://lists.openembedded.org/g/openembedded-devel/message/95188
> > Mute This Topic: https://lists.openembedded.org/mt/88836819/1997914
> > Group Owner: openembedded-devel+owner@lists.openembedded.org
> > Unsubscribe: https://lists.openembedded.org/g/openembedded-devel/unsub [raj.khem@gmail.com]
> > -=-=-=-=-=-=-=-=-=-=-=-
> >

Patch

diff --git a/meta-oe/recipes-devtools/concurrencykit/concurrencykit_git.bb b/meta-oe/recipes-devtools/concurrencykit/concurrencykit_git.bb
index 8d04507b09..0018064119 100644
--- a/meta-oe/recipes-devtools/concurrencykit/concurrencykit_git.bb
+++ b/meta-oe/recipes-devtools/concurrencykit/concurrencykit_git.bb
@@ -16,7 +16,7 @@  SRC_URI = "git://github.com/concurrencykit/ck.git;branch=master;protocol=https \
 
 S = "${WORKDIR}/git"
 
-COMPATIBLE_HOST = "(i.86|x86_64|powerpc|powerpc64).*-linux*"
+COMPATIBLE_HOST = "(arm|aarch64|i.86|x86_64|powerpc|powerpc64).*-linux*"
 
 inherit autotools-brokensep