diff mbox series

[meta-python] python3-brotli: Update version 1.0.9 -> 1.1.0

Message ID 20230920163859.1241378-1-derek@asterius.io
State Under Review
Headers show
Series [meta-python] python3-brotli: Update version 1.0.9 -> 1.1.0 | expand

Commit Message

Derek Straka Sept. 20, 2023, 4:38 p.m. UTC
Removed override for package extension as it is now a tgz

Changelog
=========
Added
decoder: BrotliDecoderAttachDictionary
decoder: BrotliDecoderOnFinish callback behind BROTLI_REPORTING
decoder: BrotliDecoderSetMetadataCallbacks
encoder: BrotliEncoderPrepareDictionary,
BrotliEncoderDestroyPreparedDictionary,
BrotliEncoderAttachPreparedDictionary
decoder: BrotliEncoderOnFinish callback behind BROTLI_REPORTING
common: BrotliSharedDictionaryCreateInstance,
BrotliSharedDictionaryDestroyInstance,
BrotliSharedDictionaryAttach
CLI: --dictionary option
java: encoder wrapper: Parameters.mode
java: Brotli{Input|Output}Stream.attachDictionary
java: wrapper: partial byte array input
typescript: decoder (transpiled from Java)

Removed
build: BROTLI_BUILD_PORTABLE option
Fixed
java: JNI decoder failed sometimes on power of 2 payloads

Improved
java / js: smaller decoder footprint
decoder: faster decoding
encoder: faster encoding
encoder: smaller stack frames

Signed-off-by: Derek Straka <derek@asterius.io>
---
 .../{python3-brotli_1.0.9.bb => python3-brotli_1.1.0.bb}       | 3 +--
 1 file changed, 1 insertion(+), 2 deletions(-)
 rename meta-python/recipes-devtools/python/{python3-brotli_1.0.9.bb => python3-brotli_1.1.0.bb} (74%)
diff mbox series

Patch

diff --git a/meta-python/recipes-devtools/python/python3-brotli_1.0.9.bb b/meta-python/recipes-devtools/python/python3-brotli_1.1.0.bb
similarity index 74%
rename from meta-python/recipes-devtools/python/python3-brotli_1.0.9.bb
rename to meta-python/recipes-devtools/python/python3-brotli_1.1.0.bb
index 5dfac5823..0f639f33e 100644
--- a/meta-python/recipes-devtools/python/python3-brotli_1.0.9.bb
+++ b/meta-python/recipes-devtools/python/python3-brotli_1.1.0.bb
@@ -5,9 +5,8 @@  LICENSE = "MIT"
 LIC_FILES_CHKSUM = "file://LICENSE;md5=941ee9cd1609382f946352712a319b4b"
 
 PYPI_PACKAGE = "Brotli"
-PYPI_PACKAGE_EXT = "zip"
 
-SRC_URI[sha256sum] = "4d1b810aa0ed773f81dceda2cc7b403d01057458730e309856356d4ef4188438"
+SRC_URI[sha256sum] = "81de08ac11bcb85841e440c13611c00b67d3bf82698314928d0b676362546724"
 
 inherit pypi setuptools3