diff mbox series

[meta-python] python3-bitstring: upgrade 4.0.2 -> 4.1.0

Message ID 1692864680-2464-1-git-send-email-wangmy@fujitsu.com
State Under Review
Headers show
Series [meta-python] python3-bitstring: upgrade 4.0.2 -> 4.1.0 | expand

Commit Message

Mingyu Wang (Fujitsu) Aug. 24, 2023, 8:11 a.m. UTC
From: Wang Mingyu <wangmy@fujitsu.com>

Changelog:
===========
-Added two new floating point interpretations: float8_143 and float8_152.
-Auto initialistion from ints has been removed and now raises a TypeError.
-Explicitly specifying the 'auto' parameter is now disallowed rather than discouraged.
-Deleting, replacing or inserting into a bitstring resets the bit position to 0 if the
 bitstring's length has been changed.
-Only empty bitstring are now considered False in a boolean sense.
-Casting to bytes now behaves as expected, so that bytes(s) gives the same result as
 s.tobytes(). Previously it created a byte per bit.
-Pretty printing with the 'bytes' format now uses characters from the 'Latin Extended-A'
 unicode block for non-ASCII and unprintable characters instead of replacing them with '.'
-When using struct-like codes you can now use '=' instead of '@' to signify native-
 endianness. They behave identically, but the new '=' is now preferred.
-More fixes for LSB0 mode. There are now no known issues with this feature.

Signed-off-by: Wang Mingyu <wangmy@fujitsu.com>
---
 .../{python3-bitstring_4.0.2.bb => python3-bitstring_4.1.0.bb}  | 2 +-
 1 file changed, 1 insertion(+), 1 deletion(-)
 rename meta-python/recipes-devtools/python/{python3-bitstring_4.0.2.bb => python3-bitstring_4.1.0.bb} (83%)
diff mbox series

Patch

diff --git a/meta-python/recipes-devtools/python/python3-bitstring_4.0.2.bb b/meta-python/recipes-devtools/python/python3-bitstring_4.1.0.bb
similarity index 83%
rename from meta-python/recipes-devtools/python/python3-bitstring_4.0.2.bb
rename to meta-python/recipes-devtools/python/python3-bitstring_4.1.0.bb
index b2ad991f5e..8a70f60db5 100644
--- a/meta-python/recipes-devtools/python/python3-bitstring_4.0.2.bb
+++ b/meta-python/recipes-devtools/python/python3-bitstring_4.1.0.bb
@@ -3,7 +3,7 @@  HOMEPAGE = "https://github.com/scott-griffiths/bitstring"
 LICENSE = "MIT"
 LIC_FILES_CHKSUM = "file://LICENSE;md5=661f450e2c0aef39b4b15597333444a7"
 
-SRC_URI[sha256sum] = "a391db8828ac4485dd5ce72c80b27ebac3e7b989631359959e310cd9729723b2"
+SRC_URI[sha256sum] = "b1672fb31721dbb6c809e76a3a19ac76a608e1f8fcacce9349ae2b72b1917b20"
 
 PYPI_PACKAGE = "bitstring"