diff mbox series

linux-yocto-tiny/6.4: fix HID configuration warning

Message ID 20230809142410.3666541-1-bruce.ashfield@gmail.com
State Accepted, archived
Commit caa6df71a56ef56710c5c62f3e647322b42efd99
Headers show
Series linux-yocto-tiny/6.4: fix HID configuration warning | expand

Commit Message

Bruce Ashfield Aug. 9, 2023, 2:24 p.m. UTC
From: Bruce Ashfield <bruce.ashfield@gmail.com>

Integrating the following commit(s):

    88ed9ec4909 qemuarm(a15): fix HID warnings in -tiny

During the update to 6.4, qemuarm was missed when updating the HID
configuration to avoid the following warning:

   WARNING: linux-yocto-tiny-6.4.9+gitAUTOINC+8dc4f68eb8_72bad8cd75-r0
   do_kernel_configcheck: [kernel config]: specified values did not make it
   into the kernel's final configuration:

       [NOTE]: 'CONFIG_USB_HID' last val (y) and .config val (n) do not match
       [INFO]: CONFIG_USB_HID : n
       [INFO]: raw config text:

           config USB_HID
                   tristate "USB HID transport layer"
                   default y
                   select HID
                   depends on USB && INPUT && USB && HID_SUPPORT
                   help
                     Say Y here if you want to connect USB keyboards,
                     mice, joysticks, graphic tablets, or any other HID based devices
                     to your computer via USB, as well as Uninterruptible Power Supply
                     (UPS) and monitor control devices.

                     You can't use this driver and the HIDBP (Boot Protocol) keyboard
                     and mouse drivers at the same time. More information is available:
                     <file:Documentation/input/input.rst>.

                     If unsure, say Y.

                     To compile this driver as a module, choose M here: the
                     module will be called usbhid.

           Config 'USB_HID' has the following Direct dependencies (USB_HID=n):
                   USB(=y) && INPUT(=y) && HID_SUPPORT(=n)
           Parent dependencies are:
                USB [y] HID_SUPPORT [n] INPUT [y]
       [INFO]: config 'CONFIG_USB_HID' was set, but it wasn't assignable, check (parent) dependencies

Signed-off-by: Bruce Ashfield <bruce.ashfield@gmail.com>
---

Apply this to the end of all my current 6.4 -stable and config patches
to remove the qemuarm config audit warning.

Bruce

 meta/recipes-kernel/linux/linux-yocto-rt_6.4.bb   | 2 +-
 meta/recipes-kernel/linux/linux-yocto-tiny_6.4.bb | 2 +-
 meta/recipes-kernel/linux/linux-yocto_6.4.bb      | 2 +-
 3 files changed, 3 insertions(+), 3 deletions(-)
diff mbox series

Patch

diff --git a/meta/recipes-kernel/linux/linux-yocto-rt_6.4.bb b/meta/recipes-kernel/linux/linux-yocto-rt_6.4.bb
index 8cc39faf9c..2f051844d8 100644
--- a/meta/recipes-kernel/linux/linux-yocto-rt_6.4.bb
+++ b/meta/recipes-kernel/linux/linux-yocto-rt_6.4.bb
@@ -15,7 +15,7 @@  python () {
 }
 
 SRCREV_machine ?= "121d700ad4b877fab9238a92356ad32506ef70d5"
-SRCREV_meta ?= "8dc4f68eb852784a5bc82d30768ac3276c890754"
+SRCREV_meta ?= "88ed9ec49099d69f9546d21137191fd747d06ec4"
 
 SRC_URI = "git://git.yoctoproject.org/linux-yocto.git;branch=${KBRANCH};name=machine;protocol=https \
            git://git.yoctoproject.org/yocto-kernel-cache;type=kmeta;name=meta;branch=yocto-6.4;destsuffix=${KMETA};protocol=https"
diff --git a/meta/recipes-kernel/linux/linux-yocto-tiny_6.4.bb b/meta/recipes-kernel/linux/linux-yocto-tiny_6.4.bb
index 834d07be48..64dfb3a379 100644
--- a/meta/recipes-kernel/linux/linux-yocto-tiny_6.4.bb
+++ b/meta/recipes-kernel/linux/linux-yocto-tiny_6.4.bb
@@ -18,7 +18,7 @@  KMETA = "kernel-meta"
 KCONF_BSP_AUDIT_LEVEL = "2"
 
 SRCREV_machine ?= "72bad8cd7540f07ab54e08b83ad106dec0df123c"
-SRCREV_meta ?= "8dc4f68eb852784a5bc82d30768ac3276c890754"
+SRCREV_meta ?= "88ed9ec49099d69f9546d21137191fd747d06ec4"
 
 PV = "${LINUX_VERSION}+git${SRCPV}"
 
diff --git a/meta/recipes-kernel/linux/linux-yocto_6.4.bb b/meta/recipes-kernel/linux/linux-yocto_6.4.bb
index 4deb7bc537..4b853122b8 100644
--- a/meta/recipes-kernel/linux/linux-yocto_6.4.bb
+++ b/meta/recipes-kernel/linux/linux-yocto_6.4.bb
@@ -28,7 +28,7 @@  SRCREV_machine:qemux86 ?= "72bad8cd7540f07ab54e08b83ad106dec0df123c"
 SRCREV_machine:qemux86-64 ?= "72bad8cd7540f07ab54e08b83ad106dec0df123c"
 SRCREV_machine:qemumips64 ?= "47d7881e76d678cc9dc034f0acdd1bc416fa05bb"
 SRCREV_machine ?= "72bad8cd7540f07ab54e08b83ad106dec0df123c"
-SRCREV_meta ?= "8dc4f68eb852784a5bc82d30768ac3276c890754"
+SRCREV_meta ?= "88ed9ec49099d69f9546d21137191fd747d06ec4"
 
 # set your preferred provider of linux-yocto to 'linux-yocto-upstream', and you'll
 # get the <version>/base branch, which is pure upstream -stable, and the same