diff mbox series

[1/2] systemd-boot: enable verbose compilation

Message ID 20230808160828.3045524-1-jose.quaresma@foundries.io
State New
Headers show
Series [1/2] systemd-boot: enable verbose compilation | expand

Commit Message

Jose Quaresma Aug. 8, 2023, 4:08 p.m. UTC
Signed-off-by: Jose Quaresma <jose.quaresma@foundries.io>
---
 meta/recipes-core/systemd/systemd-boot_254.bb | 2 +-
 1 file changed, 1 insertion(+), 1 deletion(-)

Comments

Khem Raj Aug. 8, 2023, 5:05 p.m. UTC | #1
On Tue, Aug 8, 2023 at 9:08 AM Jose Quaresma <quaresma.jose@gmail.com> wrote:
>
> Signed-off-by: Jose Quaresma <jose.quaresma@foundries.io>
> ---
>  meta/recipes-core/systemd/systemd-boot_254.bb | 2 +-
>  1 file changed, 1 insertion(+), 1 deletion(-)
>
> diff --git a/meta/recipes-core/systemd/systemd-boot_254.bb b/meta/recipes-core/systemd/systemd-boot_254.bb
> index 5d69cf83ab..b91bbfe485 100644
> --- a/meta/recipes-core/systemd/systemd-boot_254.bb
> +++ b/meta/recipes-core/systemd/systemd-boot_254.bb
> @@ -53,7 +53,7 @@ COMPATIBLE_HOST = "(aarch64.*|arm.*|x86_64.*|i.86.*)-linux"
>  COMPATIBLE_HOST:x86-x32 = "null"
>
>  do_compile() {
> -       ninja systemd-boot
> +       ninja -v systemd-boot

I think this is only useful during debugging. So perhaps a comment to
enable it is better than enabling it always.

>  }
>
>  do_install() {
> --
> 2.34.1
>
>
> -=-=-=-=-=-=-=-=-=-=-=-
> Links: You receive all messages sent to this group.
> View/Reply Online (#185665): https://lists.openembedded.org/g/openembedded-core/message/185665
> Mute This Topic: https://lists.openembedded.org/mt/100625045/1997914
> Group Owner: openembedded-core+owner@lists.openembedded.org
> Unsubscribe: https://lists.openembedded.org/g/openembedded-core/unsub [raj.khem@gmail.com]
> -=-=-=-=-=-=-=-=-=-=-=-
>
Jose Quaresma Aug. 8, 2023, 11 p.m. UTC | #2
Khem Raj <raj.khem@gmail.com> escreveu no dia terça, 8/08/2023 à(s) 18:05:

> On Tue, Aug 8, 2023 at 9:08 AM Jose Quaresma <quaresma.jose@gmail.com>
> wrote:
> >
> > Signed-off-by: Jose Quaresma <jose.quaresma@foundries.io>
> > ---
> >  meta/recipes-core/systemd/systemd-boot_254.bb | 2 +-
> >  1 file changed, 1 insertion(+), 1 deletion(-)
> >
> > diff --git a/meta/recipes-core/systemd/systemd-boot_254.bb
> b/meta/recipes-core/systemd/systemd-boot_254.bb
> > index 5d69cf83ab..b91bbfe485 100644
> > --- a/meta/recipes-core/systemd/systemd-boot_254.bb
> > +++ b/meta/recipes-core/systemd/systemd-boot_254.bb
> > @@ -53,7 +53,7 @@ COMPATIBLE_HOST =
> "(aarch64.*|arm.*|x86_64.*|i.86.*)-linux"
> >  COMPATIBLE_HOST:x86-x32 = "null"
> >
> >  do_compile() {
> > -       ninja systemd-boot
> > +       ninja -v systemd-boot
>
> I think this is only useful during debugging. So perhaps a comment to
> enable it is better than enabling it always.
>

The meson bbclass also compile with verbose so in my opinion it is better
to do the same
and make it consistent with the main systemd recipe

meson_do_compile() {
    meson compile -v ${PARALLEL_MAKE}
}

Jose


> >  }
> >
> >  do_install() {
> > --
> > 2.34.1
> >
> >
> > -=-=-=-=-=-=-=-=-=-=-=-
> > Links: You receive all messages sent to this group.
> > View/Reply Online (#185665):
> https://lists.openembedded.org/g/openembedded-core/message/185665
> > Mute This Topic: https://lists.openembedded.org/mt/100625045/1997914
> > Group Owner: openembedded-core+owner@lists.openembedded.org
> > Unsubscribe: https://lists.openembedded.org/g/openembedded-core/unsub [
> raj.khem@gmail.com]
> > -=-=-=-=-=-=-=-=-=-=-=-
> >
>
Khem Raj Aug. 8, 2023, 11:06 p.m. UTC | #3
On Tue, Aug 8, 2023 at 4:00 PM Jose Quaresma <quaresma.jose@gmail.com>
wrote:

>
>
> Khem Raj <raj.khem@gmail.com> escreveu no dia terça, 8/08/2023 à(s) 18:05:
>
>> On Tue, Aug 8, 2023 at 9:08 AM Jose Quaresma <quaresma.jose@gmail.com>
>> wrote:
>> >
>> > Signed-off-by: Jose Quaresma <jose.quaresma@foundries.io>
>> > ---
>> >  meta/recipes-core/systemd/systemd-boot_254.bb | 2 +-
>> >  1 file changed, 1 insertion(+), 1 deletion(-)
>> >
>> > diff --git a/meta/recipes-core/systemd/systemd-boot_254.bb
>> b/meta/recipes-core/systemd/systemd-boot_254.bb
>> > index 5d69cf83ab..b91bbfe485 100644
>> > --- a/meta/recipes-core/systemd/systemd-boot_254.bb
>> > +++ b/meta/recipes-core/systemd/systemd-boot_254.bb
>> > @@ -53,7 +53,7 @@ COMPATIBLE_HOST =
>> "(aarch64.*|arm.*|x86_64.*|i.86.*)-linux"
>> >  COMPATIBLE_HOST:x86-x32 = "null"
>> >
>> >  do_compile() {
>> > -       ninja systemd-boot
>> > +       ninja -v systemd-boot
>>
>> I think this is only useful during debugging. So perhaps a comment to
>> enable it is better than enabling it always.
>>
>
> The meson bbclass also compile with verbose so in my opinion it is better
> to do the same
> and make it consistent with the main systemd recipe
>
> meson_do_compile() {
>     meson compile -v ${PARALLEL_MAKE}
> }
>

Ideally we only want the verbosity when something goes wrong and meson
ninja etc are good at that with their defaults perhaps that -v should be
turned off by default as well

>
>
> Jose
>
>
>> >  }
>> >
>> >  do_install() {
>> > --
>> > 2.34.1
>> >
>> >
>> > -=-=-=-=-=-=-=-=-=-=-=-
>> > Links: You receive all messages sent to this group.
>> > View/Reply Online (#185665):
>> https://lists.openembedded.org/g/openembedded-core/message/185665
>> > Mute This Topic: https://lists.openembedded.org/mt/100625045/1997914
>> > Group Owner: openembedded-core+owner@lists.openembedded.org
>> > Unsubscribe: https://lists.openembedded.org/g/openembedded-core/unsub [
>> raj.khem@gmail.com]
>> > -=-=-=-=-=-=-=-=-=-=-=-
>> >
>>
>
>
> --
> Best regards,
>
> José Quaresma
>
Alexander Kanavin Aug. 9, 2023, 6:47 a.m. UTC | #4
On Wed, 9 Aug 2023 at 01:06, Khem Raj <raj.khem@gmail.com> wrote:
>>> I think this is only useful during debugging. So perhaps a comment to
>>> enable it is better than enabling it always.
>>
>>
>> The meson bbclass also compile with verbose so in my opinion it is better to do the same
>> and make it consistent with the main systemd recipe
>>
>> meson_do_compile() {
>>     meson compile -v ${PARALLEL_MAKE}
>> }
>
>
> Ideally we only want the verbosity when something goes wrong and meson ninja etc are good at that with their defaults perhaps that -v should be turned off by default as well

Absolutely not. As someone who spends a lot of time fixing build and
runtime failures across all of oe-core I beg to differ. I want
verbosity all the time, everywhere. I also do not want to spend a
second figuring out how to switch it on (it's different everywhere
too), or to run another build just to get the verbose logs out of it.

Alex
Mikko Rapeli Aug. 9, 2023, 9:24 a.m. UTC | #5
Hi,

On Wed, Aug 09, 2023 at 08:47:05AM +0200, Alexander Kanavin wrote:
> On Wed, 9 Aug 2023 at 01:06, Khem Raj <raj.khem@gmail.com> wrote:
> >>> I think this is only useful during debugging. So perhaps a comment to
> >>> enable it is better than enabling it always.
> >>
> >>
> >> The meson bbclass also compile with verbose so in my opinion it is better to do the same
> >> and make it consistent with the main systemd recipe
> >>
> >> meson_do_compile() {
> >>     meson compile -v ${PARALLEL_MAKE}
> >> }
> >
> >
> > Ideally we only want the verbosity when something goes wrong and meson ninja etc are good at that with their defaults perhaps that -v should be turned off by default as well
> 
> Absolutely not. As someone who spends a lot of time fixing build and
> runtime failures across all of oe-core I beg to differ. I want
> verbosity all the time, everywhere. I also do not want to spend a
> second figuring out how to switch it on (it's different everywhere
> too), or to run another build just to get the verbose logs out of it.

I prefer verbose-by-default too. It is really annoying to investigate
build race conditions in various CI environments without enough details in
logs. Had to trigger a lot test builds because of this in the past.
Same goes for testing. I know logging infra can be abused and on the limit too,
but I don't think bitbake task log sizes increase that much compared to
other stuff remaining in build tmp directories after builds.

Cheers,

-Mikko
Ross Burton Aug. 9, 2023, 2:49 p.m. UTC | #6
On 9 Aug 2023, at 07:47, Alexander Kanavin via lists.openembedded.org <alex.kanavin=gmail.com@lists.openembedded.org> wrote:
>> Ideally we only want the verbosity when something goes wrong and meson ninja etc are good at that with their defaults perhaps that -v should be turned off by default as well
> 
> Absolutely not. As someone who spends a lot of time fixing build and
> runtime failures across all of oe-core I beg to differ. I want
> verbosity all the time, everywhere. I also do not want to spend a
> second figuring out how to switch it on (it's different everywhere
> too), or to run another build just to get the verbose logs out of it.

Agreed with Alex.

Unless Ninja is clever enough to emit the full log for _every_ build step that was involved in the failure, I definitely always want verbose logs.

For what it’s worth this made me look at the recipe to see why it has to define do_compile, and I ended up extending meson.bbclass making this patch redundant.

Ross
Jose Quaresma Aug. 9, 2023, 3:04 p.m. UTC | #7
Ross Burton <Ross.Burton@arm.com> escreveu no dia quarta, 9/08/2023 à(s)
15:49:

> On 9 Aug 2023, at 07:47, Alexander Kanavin via lists.openembedded.org
> <alex.kanavin=gmail.com@lists.openembedded.org> wrote:
> >> Ideally we only want the verbosity when something goes wrong and meson
> ninja etc are good at that with their defaults perhaps that -v should be
> turned off by default as well
> >
> > Absolutely not. As someone who spends a lot of time fixing build and
> > runtime failures across all of oe-core I beg to differ. I want
> > verbosity all the time, everywhere. I also do not want to spend a
> > second figuring out how to switch it on (it's different everywhere
> > too), or to run another build just to get the verbose logs out of it.
>
> Agreed with Alex.
>
> Unless Ninja is clever enough to emit the full log for _every_ build step
> that was involved in the failure, I definitely always want verbose logs.
>
> For what it’s worth this made me look at the recipe to see why it has to
> define do_compile, and I ended up extending meson.bbclass making this patch
> redundant.
>
> Ross


I also prefer to have the verbose enabled everywhere so the bitbake logs
have more details when debug is needed.
The Ross patch includes everything we need, thanks for looking at that.
Please drop this one.

Jose
Khem Raj Aug. 9, 2023, 4:03 p.m. UTC | #8
On Wed, Aug 9, 2023 at 7:49 AM Ross Burton <Ross.Burton@arm.com> wrote:
>
> On 9 Aug 2023, at 07:47, Alexander Kanavin via lists.openembedded.org <alex.kanavin=gmail.com@lists.openembedded.org> wrote:
> >> Ideally we only want the verbosity when something goes wrong and meson ninja etc are good at that with their defaults perhaps that -v should be turned off by default as well
> >
> > Absolutely not. As someone who spends a lot of time fixing build and
> > runtime failures across all of oe-core I beg to differ. I want
> > verbosity all the time, everywhere. I also do not want to spend a
> > second figuring out how to switch it on (it's different everywhere
> > too), or to run another build just to get the verbose logs out of it.
>
> Agreed with Alex.
>
> Unless Ninja is clever enough to emit the full log for _every_ build step that was involved in the failure, I definitely always want verbose logs.

I found Ninja defaults are good for debugging build failures, I deal
with this on large projects like chromium and clang often, Most of the
time I want to get to the error quickly
and have command to reproduce the one compile failure or other steps
and they are emitted in full while succeeding steps are curtailed and
most of the time that is what
one needs to solve build issues. verbose logs for such large projects
are huge, need space and time to generate them, I understand the view
of people who fix
build issues on daily bases, Most of the time builds succeed so its
important to keep that also in consideration. Perhaps it could be a
global option which could be
default verbose and opted-out if build modes chose to do so.

>
> For what it’s worth this made me look at the recipe to see why it has to define do_compile, and I ended up extending meson.bbclass making this patch redundant.

Thats good.

>
> Ross
diff mbox series

Patch

diff --git a/meta/recipes-core/systemd/systemd-boot_254.bb b/meta/recipes-core/systemd/systemd-boot_254.bb
index 5d69cf83ab..b91bbfe485 100644
--- a/meta/recipes-core/systemd/systemd-boot_254.bb
+++ b/meta/recipes-core/systemd/systemd-boot_254.bb
@@ -53,7 +53,7 @@  COMPATIBLE_HOST = "(aarch64.*|arm.*|x86_64.*|i.86.*)-linux"
 COMPATIBLE_HOST:x86-x32 = "null"
 
 do_compile() {
-	ninja systemd-boot
+	ninja -v systemd-boot
 }
 
 do_install() {