diff mbox series

python3-argh: upgrade 0.26.2 -> 0.28.1

Message ID 20230709082032.1754360-1-ticotimo@gmail.com
State Under Review
Headers show
Series python3-argh: upgrade 0.26.2 -> 0.28.1 | expand

Commit Message

Tim Orling July 9, 2023, 8:20 a.m. UTC
* Switch inherit from setuptools3 to python_flit_core
* Correct SUMMARY
* Add DESCRIPTION
* Add python3-argcomplete to RDEPENDS (found with poky/scripts/pythondeps)

https://github.com/neithere/argh/blob/v0.28.1/CHANGES

License-Update: use COPYING.LESSER, change to LGPL-3.0-or-later

NOTE: Includes COPYING which is GPL-3.0 but README clearly states LGPL-3.0-or-later
https://github.com/neithere/argh/blob/v0.28.1/README.rst#licensing

Signed-off-by: Tim Orling <ticotimo@gmail.com>
---
 .../python/python3-argh_0.26.2.bb             | 14 ----------
 .../python/python3-argh_0.28.1.bb             | 26 +++++++++++++++++++
 2 files changed, 26 insertions(+), 14 deletions(-)
 delete mode 100644 meta-python/recipes-devtools/python/python3-argh_0.26.2.bb
 create mode 100644 meta-python/recipes-devtools/python/python3-argh_0.28.1.bb
diff mbox series

Patch

diff --git a/meta-python/recipes-devtools/python/python3-argh_0.26.2.bb b/meta-python/recipes-devtools/python/python3-argh_0.26.2.bb
deleted file mode 100644
index c02e31a9a..000000000
--- a/meta-python/recipes-devtools/python/python3-argh_0.26.2.bb
+++ /dev/null
@@ -1,14 +0,0 @@ 
-SUMMARY = "Pattern matching and various utilities for file systems paths."
-
-LICENSE = "LGPL-2.0-only"
-LIC_FILES_CHKSUM = "file://PKG-INFO;beginline=8;endline=8;md5=cede70b648dcc81baf5b431d38905bad"
-
-SRC_URI[sha256sum] = "e9535b8c84dc9571a48999094fda7f33e63c3f1b74f3e5f3ac0105a58405bb65"
-
-inherit pypi setuptools3
-
-RDEPENDS:${PN} += " \
-    ${PYTHON_PN}-logging \
-"
-
-BBCLASSEXTEND = "native nativesdk"
diff --git a/meta-python/recipes-devtools/python/python3-argh_0.28.1.bb b/meta-python/recipes-devtools/python/python3-argh_0.28.1.bb
new file mode 100644
index 000000000..2b1cb3ed8
--- /dev/null
+++ b/meta-python/recipes-devtools/python/python3-argh_0.28.1.bb
@@ -0,0 +1,26 @@ 
+SUMMARY = "An unobtrusive argparse wrapper with natural syntax"
+DESCRIPTION = "Building a command-line interface? Found yourself uttering \
+'argh!' while struggling with the API of argparse? Don't like the complexity \
+but need the power? \
+\
+Everything should be made as simple as possible, but no simpler. \
+\
+—Albert Einstein (probably) \
+\
+Argh is a smart wrapper for argparse. Argparse is a very powerful \
+tool; Argh just makes it easy to use."
+
+LICENSE = "LGPL-3.0-or-later"
+LIC_FILES_CHKSUM = "file://COPYING.LESSER;md5=3000208d539ec061b899bce1d9ce9404 \
+                    file://README.rst;beginline=261;endline=275;md5=a8bf3475df7e0d575a53d04c83d5e090"
+
+SRC_URI[sha256sum] = "b2093086f0e809a3ecc24b64a2145309ee8f56d034936cd59e57c558a357329d"
+
+inherit pypi python_flit_core
+
+RDEPENDS:${PN} += " \
+    python3-argcomplete \
+    python3-logging \
+"
+
+BBCLASSEXTEND = "native nativesdk"