[meta-python] python3-diskcache: Upgrade 5.3.0 -> 5.4.0

Message ID 20220107125820.3216630-1-leon.anavi@konsulko.com
State New
Headers show
Series [meta-python] python3-diskcache: Upgrade 5.3.0 -> 5.4.0 | expand

Commit Message

Leon Anavi Jan. 7, 2022, 12:58 p.m. UTC
Upgrade to release 5.4.0:

- Run isort
- Remove unused imports
- Update tests for Django 3.2

Signed-off-by: Leon Anavi <leon.anavi@konsulko.com>
---
 ...diskcache_5.3.0.bb => python3-diskcache_5.4.0.bb} | 12 +++++++++++-
 1 file changed, 11 insertions(+), 1 deletion(-)
 rename meta-python/recipes-devtools/python/{python3-diskcache_5.3.0.bb => python3-diskcache_5.4.0.bb} (50%)

Patch

diff --git a/meta-python/recipes-devtools/python/python3-diskcache_5.3.0.bb b/meta-python/recipes-devtools/python/python3-diskcache_5.4.0.bb
similarity index 50%
rename from meta-python/recipes-devtools/python/python3-diskcache_5.3.0.bb
rename to meta-python/recipes-devtools/python/python3-diskcache_5.4.0.bb
index 55829bd1e..84d42e572 100644
--- a/meta-python/recipes-devtools/python/python3-diskcache_5.3.0.bb
+++ b/meta-python/recipes-devtools/python/python3-diskcache_5.4.0.bb
@@ -3,10 +3,20 @@  HOMEPAGE = "http://www.grantjenks.com/docs/diskcache/"
 LICENSE = "Apache-2.0"
 LIC_FILES_CHKSUM = "file://LICENSE;md5=c60ef82f0f40155453f6d5f2c94b6e8e"
 
-SRC_URI[sha256sum] = "3f1fa30b29fdff26cfddcb3ee7d61376903f82c769ea2907a2b82a5bfb8abbe2"
+SRC_URI[sha256sum] = "8879eb8c9b4a2509a5e633d2008634fb2b0b35c2b36192d89655dbde02419644"
 
 PYPI_PACKAGE = "diskcache"
 
 inherit pypi setuptools3
 
+RDEPENDS:${PN} = "\
+    ${PYTHON_PN}-json \
+    ${PYTHON_PN}-pickle \
+    ${PYTHON_PN}-sqlite3 \
+    ${PYTHON_PN}-core \
+    ${PYTHON_PN}-io \
+    ${PYTHON_PN}-compression \
+    ${PYTHON_PN}-threading \
+"
+
 CLEANBROKEN = "1"