diff mbox series

[1/2] ptest-runner: add non-root ptest user for tests to run as

Message ID 20230227131303.3104010-1-ross.burton@arm.com
State Accepted, archived
Commit d58cf08421e0f89840820370dd3c5b6e153efcbb
Headers show
Series [1/2] ptest-runner: add non-root ptest user for tests to run as | expand

Commit Message

Ross Burton Feb. 27, 2023, 1:13 p.m. UTC
Some tests really don't want to be run as root, either because they
expect to get "permission denied" errors occasionally, or have explicit
checks.

Instead of numerous recipes re-inventing user creation in run-ptest,
create a user in the ptest-runner recipe that they can all use.

Signed-off-by: Ross Burton <ross.burton@arm.com>
---
 meta/recipes-support/ptest-runner/ptest-runner_2.4.2.bb | 5 +++++
 1 file changed, 5 insertions(+)
diff mbox series

Patch

diff --git a/meta/recipes-support/ptest-runner/ptest-runner_2.4.2.bb b/meta/recipes-support/ptest-runner/ptest-runner_2.4.2.bb
index 5a1d3299930..ee13e28c7df 100644
--- a/meta/recipes-support/ptest-runner/ptest-runner_2.4.2.bb
+++ b/meta/recipes-support/ptest-runner/ptest-runner_2.4.2.bb
@@ -32,3 +32,8 @@  RDEPENDS:${PN}:append:libc-glibc = " libgcc"
 
 # pstree is called by ptest-runner-collect-system-data
 RDEPENDS:${PN}:append = " pstree"
+
+# Create a non-root user that test suites can use easily
+inherit useradd
+USERADD_PACKAGES = "${PN}"
+USERADD_PARAM:${PN} = "--system --no-create-home --home / --user-group ptest"