diff mbox series

[meta-python] python3-icu: upgrade 2.8.1 -> 2.10.2

Message ID 1675843963-11324-2-git-send-email-wangmy@fujitsu.com
State Under Review
Headers show
Series [meta-python] python3-icu: upgrade 2.8.1 -> 2.10.2 | expand

Commit Message

Mingyu Wang (Fujitsu) Feb. 8, 2023, 8:12 a.m. UTC
From: Wang Mingyu <wangmy@fujitsu.com>

0001-Fix-host-contamination-of-include-files.patch
updated for 2.10.2

Changelog:
==========
  - fixed bug in logic computing max_char for PyUnicode_New()
  - fixed build issues with ICU < 72
  - fixed bug with building on MacOS when pkg-config is present
  - added link to note about building everything from sources
  - added wrapper for u_cleanup/u_init sequence as ResourceBundle.resetICU()
  - added wrapper for TimeZone.getRegion()
  - added support for ICU 72.1
  - added wrapper for UnicodeSetIterator::skipToStrings()
  - added wrapper for DisplayOptions, DisplayOptions::Builder and related enums
  - added wrapper for FormattedNumber::getNounClass()
  - added wrapper for NumberFormatter.displayOptions()
  - added support for ICU 71.1
  - added wrappers for UMeasurePrefix, MeasureUnit.withPrefix()|getPrefix()
  - added UNumberRoundingPriority, FractionPrecision.withSignificantDigits()
  - added UNumberTrailingZeroDisplay, Precision.trailingZeroDisplay()

Signed-off-by: Wang Mingyu <wangmy@fujitsu.com>
---
 ...01-Fix-host-contamination-of-include-files.patch | 13 ++++++++-----
 .../{python3-icu_2.8.1.bb => python3-icu_2.10.2.bb} |  2 +-
 2 files changed, 9 insertions(+), 6 deletions(-)
 rename meta-python/recipes-devtools/python/{python3-icu_2.8.1.bb => python3-icu_2.10.2.bb} (83%)
diff mbox series

Patch

diff --git a/meta-python/recipes-devtools/python/python3-icu/0001-Fix-host-contamination-of-include-files.patch b/meta-python/recipes-devtools/python/python3-icu/0001-Fix-host-contamination-of-include-files.patch
index 36485d56c..7bb5ee58c 100644
--- a/meta-python/recipes-devtools/python/python3-icu/0001-Fix-host-contamination-of-include-files.patch
+++ b/meta-python/recipes-devtools/python/python3-icu/0001-Fix-host-contamination-of-include-files.patch
@@ -10,25 +10,25 @@  Also, don't use icu-config
 Upstream-Status: Inappropriate [OE specific]
 Signed-off-by: Armin Kuster <akuster808@gmail.com>
 Signed-off-by: Khem Raj <raj.khem@gmail.com>
-
+Signed-off-by: Wang Mingyu <wangmy@fujitsu.com>
 ---
  setup.py | 3 +--
  1 file changed, 1 insertion(+), 2 deletions(-)
 
 diff --git a/setup.py b/setup.py
-index d308b80..56e9c74 100644
+index 176c9ab..0a10268 100644
 --- a/setup.py
 +++ b/setup.py
-@@ -81,7 +81,7 @@ Building PyICU %s for ICU %s (max ICU major version supported: %s)
+@@ -68,7 +68,7 @@ elif platform.startswith('freebsd'):
  
  CONFIGURE_WITH_ICU_CONFIG = {
-     'darwin': True,
+     'darwin': False,
 -    'linux': True,
 +    'linux': False,
      'freebsd': False, # not tested
      'win32': False,   # no icu-config
      'sunos5': False,  # not tested
-@@ -273,7 +273,6 @@ setup(name="PyICU",
+@@ -277,7 +277,6 @@ setup(name="PyICU",
        ext_modules=[Extension('icu._icu_',
                               [filename for filename in sorted(os.listdir(os.curdir))
                                if filename.endswith('.cpp')],
@@ -36,3 +36,6 @@  index d308b80..56e9c74 100644
                               extra_compile_args=_cflags,
                               extra_link_args=_lflags,
                               libraries=_libraries)],
+-- 
+2.34.1
+
diff --git a/meta-python/recipes-devtools/python/python3-icu_2.8.1.bb b/meta-python/recipes-devtools/python/python3-icu_2.10.2.bb
similarity index 83%
rename from meta-python/recipes-devtools/python/python3-icu_2.8.1.bb
rename to meta-python/recipes-devtools/python/python3-icu_2.10.2.bb
index 027ef129e..cbcc2f87b 100644
--- a/meta-python/recipes-devtools/python/python3-icu_2.8.1.bb
+++ b/meta-python/recipes-devtools/python/python3-icu_2.10.2.bb
@@ -8,7 +8,7 @@  LIC_FILES_CHKSUM = "file://LICENSE;md5=0724597863f1581ab01429e0423e779f"
 DEPENDS += "icu"
 
 PYPI_PACKAGE = "PyICU"
-SRC_URI[sha256sum] = "f0b9549a87f87ba7c413f13679d137271e0b37f1f39b0109ace38257d4d148d6"
+SRC_URI[sha256sum] = "0c3309eea7fab6857507ace62403515b60fe096cbfb4f90d14f55ff75c5441c1"
 
 SRC_URI += "file://0001-Fix-host-contamination-of-include-files.patch"