diff mbox series

[meta-oe] pgpool2: Added a new recipe.

Message ID 1673241556-6067-1-git-send-email-leimaohui@fujitsu.com
State Under Review
Headers show
Series [meta-oe] pgpool2: Added a new recipe. | expand

Commit Message

Maohui Lei (Fujitsu) Jan. 9, 2023, 5:19 a.m. UTC
Pgpool-II is a middleware that works between PostgreSQL servers and a PostgreSQL database client. It is distributed under a license similar to BSD and MIT. It provides the  following features.

Signed-off-by: Lei Maohui <leimaohui@fujitsu.com>
---
 .../recipes-support/pgpool2/pgpool2/pgpool.service | 17 ++++++++
 .../pgpool2/pgpool2/pgpool.sysconfig               |  7 ++++
 meta-oe/recipes-support/pgpool2/pgpool2_4.4.1.bb   | 46 ++++++++++++++++++++++
 3 files changed, 70 insertions(+)
 create mode 100644 meta-oe/recipes-support/pgpool2/pgpool2/pgpool.service
 create mode 100644 meta-oe/recipes-support/pgpool2/pgpool2/pgpool.sysconfig
 create mode 100644 meta-oe/recipes-support/pgpool2/pgpool2_4.4.1.bb

Comments

Khem Raj Jan. 9, 2023, 4:56 p.m. UTC | #1
fails to build on qemuarm/glibc and other various combinations with
same error as

https://errors.yoctoproject.org/Errors/Details/687226/

On Sun, Jan 8, 2023 at 9:19 PM leimaohui <leimaohui@fujitsu.com> wrote:
>
> Pgpool-II is a middleware that works between PostgreSQL servers and a PostgreSQL database client. It is distributed under a license similar to BSD and MIT. It provides the  following features.
>
> Signed-off-by: Lei Maohui <leimaohui@fujitsu.com>
> ---
>  .../recipes-support/pgpool2/pgpool2/pgpool.service | 17 ++++++++
>  .../pgpool2/pgpool2/pgpool.sysconfig               |  7 ++++
>  meta-oe/recipes-support/pgpool2/pgpool2_4.4.1.bb   | 46 ++++++++++++++++++++++
>  3 files changed, 70 insertions(+)
>  create mode 100644 meta-oe/recipes-support/pgpool2/pgpool2/pgpool.service
>  create mode 100644 meta-oe/recipes-support/pgpool2/pgpool2/pgpool.sysconfig
>  create mode 100644 meta-oe/recipes-support/pgpool2/pgpool2_4.4.1.bb
>
> diff --git a/meta-oe/recipes-support/pgpool2/pgpool2/pgpool.service b/meta-oe/recipes-support/pgpool2/pgpool2/pgpool.service
> new file mode 100644
> index 0000000..bf2d323
> --- /dev/null
> +++ b/meta-oe/recipes-support/pgpool2/pgpool2/pgpool.service
> @@ -0,0 +1,17 @@
> +[Unit]
> +Description=Pgpool-II
> +After=syslog.target network.target
> +
> +[Service]
> +
> +User=postgres
> +Group=postgres
> +
> +EnvironmentFile=-/etc/sysconfig/pgpool
> +
> +ExecStart=/usr/bin/pgpool -f /etc/pgpool-II/pgpool.conf $OPTS
> +ExecStop=/usr/bin/pgpool -f /etc/pgpool-II/pgpool.conf $STOP_OPTS stop
> +ExecReload=/usr/bin/pgpool -f /etc/pgpool-II/pgpool.conf reload
> +
> +[Install]
> +WantedBy=multi-user.target
> diff --git a/meta-oe/recipes-support/pgpool2/pgpool2/pgpool.sysconfig b/meta-oe/recipes-support/pgpool2/pgpool2/pgpool.sysconfig
> new file mode 100644
> index 0000000..ea13089
> --- /dev/null
> +++ b/meta-oe/recipes-support/pgpool2/pgpool2/pgpool.sysconfig
> @@ -0,0 +1,7 @@
> +# Options for pgpool
> +
> +# -n: don't run in daemon mode. does not detach control tty
> +# -d: debug mode. lots of debug information will be printed
> +
> +#OPTS=" -d -n"
> +OPTS=" -n"
> diff --git a/meta-oe/recipes-support/pgpool2/pgpool2_4.4.1.bb b/meta-oe/recipes-support/pgpool2/pgpool2_4.4.1.bb
> new file mode 100644
> index 0000000..52e0192
> --- /dev/null
> +++ b/meta-oe/recipes-support/pgpool2/pgpool2_4.4.1.bb
> @@ -0,0 +1,46 @@
> +SUMMARY = "a language independent connection pool server for PostgreSQL."
> +
> +DESCRIPTION = "Pgpool-II is a middleware that works between PostgreSQL \
> +               servers and a PostgreSQL database client. It is distributed \
> +               under a license similar to BSD and MIT. It provides the \
> +               following features."
> +
> +HOMEPAGE = "http://pgpool.net"
> +
> +LICENSE = "BSD-2-Clause"
> +LIC_FILES_CHKSUM = "file://COPYING;md5=e4b38de086d73e0521de0bbdbaa4a1a9"
> +
> +SRC_URI = "http://www.pgpool.net/mediawiki/images/pgpool-II-${PV}.tar.gz \
> +          file://pgpool.sysconfig \
> +          file://pgpool.service \
> +           "
> +SRC_URI[sha256sum] = "4b379bbba8e178128a1cee4a5bd1ae116dedb3da6121b728c18f0f54c881f328"
> +
> +S = "${WORKDIR}/pgpool-II-${PV}"
> +
> +inherit autotools systemd
> +
> +SYSTEMD_SERVICE:${PN} = "pgpool.service"
> +
> +PACKAGECONFIG ??= " openssl libmemcached postgresql \
> +    ${@bb.utils.filter('DISTRO_FEATURES', 'pam', d)} \
> +    "
> +PACKAGECONFIG[pam] = "--with-pam,--without-pam,libpam,"
> +PACKAGECONFIG[openssl] = "--with-openssl,--without-openssl,openssl"
> +PACKAGECONFIG[libmemcached] = "--with-memcached=${STAGING_INCDIR}/libmemcachedutil-1.0,--without-memcached,libmemcached"
> +PACKAGECONFIG[postgresql] = "--with-pgsql-includedir=${STAGING_INCDIR}/postgresql --with-pgsql=${bindir} ,,postgresql"
> +
> +EXTRA_OECONF += "-disable-static \
> +               "
> +B = "${S}"
> +CFLAGS:append = " -fcommon "
> +
> +FILES:${PN} += "${datadir}/pgpool-II/ "
> +
> +do_install:append() {
> +    install -d ${D}${sysconfdir}/pgpool-II
> +    install -D -m 0644 ${WORKDIR}/pgpool.sysconfig  ${D}${sysconfdir}/pgpool-II/pgpool.conf
> +    install -D -m 0644 ${S}/src/sample/pcp.conf.sample ${D}${sysconfdir}/pgpool-II/pcp.conf
> +    install -D -m 0644 ${S}/src/sample/pool_hba.conf.sample ${D}${sysconfdir}/pgpool-II/pool_hba.conf
> +    install -Dm 0644 ${WORKDIR}/pgpool.service ${D}${systemd_system_unitdir}/pgpool.service
> +}
> --
> 1.8.3.1
>
>
> -=-=-=-=-=-=-=-=-=-=-=-
> Links: You receive all messages sent to this group.
> View/Reply Online (#100478): https://lists.openembedded.org/g/openembedded-devel/message/100478
> Mute This Topic: https://lists.openembedded.org/mt/96146690/1997914
> Group Owner: openembedded-devel+owner@lists.openembedded.org
> Unsubscribe: https://lists.openembedded.org/g/openembedded-devel/unsub [raj.khem@gmail.com]
> -=-=-=-=-=-=-=-=-=-=-=-
>
Khem Raj Jan. 9, 2023, 4:58 p.m. UTC | #2
also see the dependency problems

https://autobuilder.yoctoproject.org/typhoon/#/builders/88/builds/2339

On Mon, Jan 9, 2023 at 8:56 AM Khem Raj <raj.khem@gmail.com> wrote:
>
> fails to build on qemuarm/glibc and other various combinations with
> same error as
>
> https://errors.yoctoproject.org/Errors/Details/687226/
>
> On Sun, Jan 8, 2023 at 9:19 PM leimaohui <leimaohui@fujitsu.com> wrote:
> >
> > Pgpool-II is a middleware that works between PostgreSQL servers and a PostgreSQL database client. It is distributed under a license similar to BSD and MIT. It provides the  following features.
> >
> > Signed-off-by: Lei Maohui <leimaohui@fujitsu.com>
> > ---
> >  .../recipes-support/pgpool2/pgpool2/pgpool.service | 17 ++++++++
> >  .../pgpool2/pgpool2/pgpool.sysconfig               |  7 ++++
> >  meta-oe/recipes-support/pgpool2/pgpool2_4.4.1.bb   | 46 ++++++++++++++++++++++
> >  3 files changed, 70 insertions(+)
> >  create mode 100644 meta-oe/recipes-support/pgpool2/pgpool2/pgpool.service
> >  create mode 100644 meta-oe/recipes-support/pgpool2/pgpool2/pgpool.sysconfig
> >  create mode 100644 meta-oe/recipes-support/pgpool2/pgpool2_4.4.1.bb
> >
> > diff --git a/meta-oe/recipes-support/pgpool2/pgpool2/pgpool.service b/meta-oe/recipes-support/pgpool2/pgpool2/pgpool.service
> > new file mode 100644
> > index 0000000..bf2d323
> > --- /dev/null
> > +++ b/meta-oe/recipes-support/pgpool2/pgpool2/pgpool.service
> > @@ -0,0 +1,17 @@
> > +[Unit]
> > +Description=Pgpool-II
> > +After=syslog.target network.target
> > +
> > +[Service]
> > +
> > +User=postgres
> > +Group=postgres
> > +
> > +EnvironmentFile=-/etc/sysconfig/pgpool
> > +
> > +ExecStart=/usr/bin/pgpool -f /etc/pgpool-II/pgpool.conf $OPTS
> > +ExecStop=/usr/bin/pgpool -f /etc/pgpool-II/pgpool.conf $STOP_OPTS stop
> > +ExecReload=/usr/bin/pgpool -f /etc/pgpool-II/pgpool.conf reload
> > +
> > +[Install]
> > +WantedBy=multi-user.target
> > diff --git a/meta-oe/recipes-support/pgpool2/pgpool2/pgpool.sysconfig b/meta-oe/recipes-support/pgpool2/pgpool2/pgpool.sysconfig
> > new file mode 100644
> > index 0000000..ea13089
> > --- /dev/null
> > +++ b/meta-oe/recipes-support/pgpool2/pgpool2/pgpool.sysconfig
> > @@ -0,0 +1,7 @@
> > +# Options for pgpool
> > +
> > +# -n: don't run in daemon mode. does not detach control tty
> > +# -d: debug mode. lots of debug information will be printed
> > +
> > +#OPTS=" -d -n"
> > +OPTS=" -n"
> > diff --git a/meta-oe/recipes-support/pgpool2/pgpool2_4.4.1.bb b/meta-oe/recipes-support/pgpool2/pgpool2_4.4.1.bb
> > new file mode 100644
> > index 0000000..52e0192
> > --- /dev/null
> > +++ b/meta-oe/recipes-support/pgpool2/pgpool2_4.4.1.bb
> > @@ -0,0 +1,46 @@
> > +SUMMARY = "a language independent connection pool server for PostgreSQL."
> > +
> > +DESCRIPTION = "Pgpool-II is a middleware that works between PostgreSQL \
> > +               servers and a PostgreSQL database client. It is distributed \
> > +               under a license similar to BSD and MIT. It provides the \
> > +               following features."
> > +
> > +HOMEPAGE = "http://pgpool.net"
> > +
> > +LICENSE = "BSD-2-Clause"
> > +LIC_FILES_CHKSUM = "file://COPYING;md5=e4b38de086d73e0521de0bbdbaa4a1a9"
> > +
> > +SRC_URI = "http://www.pgpool.net/mediawiki/images/pgpool-II-${PV}.tar.gz \
> > +          file://pgpool.sysconfig \
> > +          file://pgpool.service \
> > +           "
> > +SRC_URI[sha256sum] = "4b379bbba8e178128a1cee4a5bd1ae116dedb3da6121b728c18f0f54c881f328"
> > +
> > +S = "${WORKDIR}/pgpool-II-${PV}"
> > +
> > +inherit autotools systemd
> > +
> > +SYSTEMD_SERVICE:${PN} = "pgpool.service"
> > +
> > +PACKAGECONFIG ??= " openssl libmemcached postgresql \
> > +    ${@bb.utils.filter('DISTRO_FEATURES', 'pam', d)} \
> > +    "
> > +PACKAGECONFIG[pam] = "--with-pam,--without-pam,libpam,"
> > +PACKAGECONFIG[openssl] = "--with-openssl,--without-openssl,openssl"
> > +PACKAGECONFIG[libmemcached] = "--with-memcached=${STAGING_INCDIR}/libmemcachedutil-1.0,--without-memcached,libmemcached"
> > +PACKAGECONFIG[postgresql] = "--with-pgsql-includedir=${STAGING_INCDIR}/postgresql --with-pgsql=${bindir} ,,postgresql"
> > +
> > +EXTRA_OECONF += "-disable-static \
> > +               "
> > +B = "${S}"
> > +CFLAGS:append = " -fcommon "
> > +
> > +FILES:${PN} += "${datadir}/pgpool-II/ "
> > +
> > +do_install:append() {
> > +    install -d ${D}${sysconfdir}/pgpool-II
> > +    install -D -m 0644 ${WORKDIR}/pgpool.sysconfig  ${D}${sysconfdir}/pgpool-II/pgpool.conf
> > +    install -D -m 0644 ${S}/src/sample/pcp.conf.sample ${D}${sysconfdir}/pgpool-II/pcp.conf
> > +    install -D -m 0644 ${S}/src/sample/pool_hba.conf.sample ${D}${sysconfdir}/pgpool-II/pool_hba.conf
> > +    install -Dm 0644 ${WORKDIR}/pgpool.service ${D}${systemd_system_unitdir}/pgpool.service
> > +}
> > --
> > 1.8.3.1
> >
> >
> > -=-=-=-=-=-=-=-=-=-=-=-
> > Links: You receive all messages sent to this group.
> > View/Reply Online (#100478): https://lists.openembedded.org/g/openembedded-devel/message/100478
> > Mute This Topic: https://lists.openembedded.org/mt/96146690/1997914
> > Group Owner: openembedded-devel+owner@lists.openembedded.org
> > Unsubscribe: https://lists.openembedded.org/g/openembedded-devel/unsub [raj.khem@gmail.com]
> > -=-=-=-=-=-=-=-=-=-=-=-
> >
Maohui Lei (Fujitsu) Jan. 11, 2023, 8:09 a.m. UTC | #3
Hi, 

> https://autobuilder.yoctoproject.org/typhoon/#/builders/88/builds/2339

I'm sorry I can't reproduce the dependency problems:

stdio: ERROR: Nothing PROVIDES 'libmemcached' (but /home/pokybuild/yocto-worker/meta-oe/build/meta-openembedded/meta-oe/recipes-support/pgpool2/pgpool2_4.4.1.bb DEPENDS on or otherwise requires it)
stdio: ERROR: Required build target 'meta-world-pkgdata' has no buildable providers.
stdio: ERROR: Nothing PROVIDES 'libmemcached' (but /home/pokybuild/yocto-worker/meta-oe/build/meta-openembedded/meta-oe/recipes-support/pgpool2/pgpool2_4.4.1.bb DEPENDS on or otherwise requires it)
stdio: ERROR: Required build target 'meta-world-pkgdata' has no buildable providers.
stdio: ERROR: Nothing PROVIDES 'libmemcached' (but /home/pokybuild/yocto-worker/meta-oe/build/meta-openembedded/meta-oe/recipes-support/pgpool2/pgpool2_4.4.1.bb DEPENDS on or otherwise requires it)
stdio: ERROR: Required build target 'meta-world-pkgdata' has no buildable providers.


And I found it strange that the recipe of 'libmemcached' was in meta-networking:recipes-support/libmemcached/libmemcached_1.0.18.bb. 
Why did this error occur?


Best regards
Lei


> -----Original Message-----
> From: Khem Raj <raj.khem@gmail.com>
> Sent: Tuesday, January 10, 2023 12:59 AM
> To: Lei, Maohui <leimaohui@fujitsu.com>
> Cc: openembedded-devel@lists.openembedded.org
> Subject: Re: [oe] [meta-oe][PATCH] pgpool2: Added a new recipe.
> 
> also see the dependency problems
> 
> https://autobuilder.yoctoproject.org/typhoon/#/builders/88/builds/2339
> 
> On Mon, Jan 9, 2023 at 8:56 AM Khem Raj <raj.khem@gmail.com> wrote:
> >
> > fails to build on qemuarm/glibc and other various combinations with
> > same error as
> >
> > https://errors.yoctoproject.org/Errors/Details/687226/
> >
> > On Sun, Jan 8, 2023 at 9:19 PM leimaohui <leimaohui@fujitsu.com> wrote:
> > >
> > > Pgpool-II is a middleware that works between PostgreSQL servers and a
> PostgreSQL database client. It is distributed under a license similar to BSD and MIT.
> It provides the  following features.
> > >
> > > Signed-off-by: Lei Maohui <leimaohui@fujitsu.com>
> > > ---
> > >  .../recipes-support/pgpool2/pgpool2/pgpool.service | 17 ++++++++
> > >  .../pgpool2/pgpool2/pgpool.sysconfig               |  7 ++++
> > >  meta-oe/recipes-support/pgpool2/pgpool2_4.4.1.bb   | 46
> ++++++++++++++++++++++
> > >  3 files changed, 70 insertions(+)
> > >  create mode 100644
> > > meta-oe/recipes-support/pgpool2/pgpool2/pgpool.service
> > >  create mode 100644
> > > meta-oe/recipes-support/pgpool2/pgpool2/pgpool.sysconfig
> > >  create mode 100644 meta-oe/recipes-support/pgpool2/pgpool2_4.4.1.bb
> > >
> > > diff --git a/meta-oe/recipes-support/pgpool2/pgpool2/pgpool.service
> > > b/meta-oe/recipes-support/pgpool2/pgpool2/pgpool.service
> > > new file mode 100644
> > > index 0000000..bf2d323
> > > --- /dev/null
> > > +++ b/meta-oe/recipes-support/pgpool2/pgpool2/pgpool.service
> > > @@ -0,0 +1,17 @@
> > > +[Unit]
> > > +Description=Pgpool-II
> > > +After=syslog.target network.target
> > > +
> > > +[Service]
> > > +
> > > +User=postgres
> > > +Group=postgres
> > > +
> > > +EnvironmentFile=-/etc/sysconfig/pgpool
> > > +
> > > +ExecStart=/usr/bin/pgpool -f /etc/pgpool-II/pgpool.conf $OPTS
> > > +ExecStop=/usr/bin/pgpool -f /etc/pgpool-II/pgpool.conf $STOP_OPTS
> > > +stop ExecReload=/usr/bin/pgpool -f /etc/pgpool-II/pgpool.conf
> > > +reload
> > > +
> > > +[Install]
> > > +WantedBy=multi-user.target
> > > diff --git
> > > a/meta-oe/recipes-support/pgpool2/pgpool2/pgpool.sysconfig
> > > b/meta-oe/recipes-support/pgpool2/pgpool2/pgpool.sysconfig
> > > new file mode 100644
> > > index 0000000..ea13089
> > > --- /dev/null
> > > +++ b/meta-oe/recipes-support/pgpool2/pgpool2/pgpool.sysconfig
> > > @@ -0,0 +1,7 @@
> > > +# Options for pgpool
> > > +
> > > +# -n: don't run in daemon mode. does not detach control tty # -d:
> > > +debug mode. lots of debug information will be printed
> > > +
> > > +#OPTS=" -d -n"
> > > +OPTS=" -n"
> > > diff --git a/meta-oe/recipes-support/pgpool2/pgpool2_4.4.1.bb
> > > b/meta-oe/recipes-support/pgpool2/pgpool2_4.4.1.bb
> > > new file mode 100644
> > > index 0000000..52e0192
> > > --- /dev/null
> > > +++ b/meta-oe/recipes-support/pgpool2/pgpool2_4.4.1.bb
> > > @@ -0,0 +1,46 @@
> > > +SUMMARY = "a language independent connection pool server for
> PostgreSQL."
> > > +
> > > +DESCRIPTION = "Pgpool-II is a middleware that works between PostgreSQL \
> > > +               servers and a PostgreSQL database client. It is distributed \
> > > +               under a license similar to BSD and MIT. It provides the \
> > > +               following features."
> > > +
> > > +HOMEPAGE = "http://pgpool.net"
> > > +
> > > +LICENSE = "BSD-2-Clause"
> > > +LIC_FILES_CHKSUM =
> "file://COPYING;md5=e4b38de086d73e0521de0bbdbaa4a1a9"
> > > +
> > > +SRC_URI = "http://www.pgpool.net/mediawiki/images/pgpool-II-${PV}.tar.gz
> \
> > > +          file://pgpool.sysconfig \
> > > +          file://pgpool.service \
> > > +           "
> > > +SRC_URI[sha256sum] =
> "4b379bbba8e178128a1cee4a5bd1ae116dedb3da6121b728c18f0f54c881f328
> "
> > > +
> > > +S = "${WORKDIR}/pgpool-II-${PV}"
> > > +
> > > +inherit autotools systemd
> > > +
> > > +SYSTEMD_SERVICE:${PN} = "pgpool.service"
> > > +
> > > +PACKAGECONFIG ??= " openssl libmemcached postgresql \
> > > +    ${@bb.utils.filter('DISTRO_FEATURES', 'pam', d)} \
> > > +    "
> > > +PACKAGECONFIG[pam] = "--with-pam,--without-pam,libpam,"
> > > +PACKAGECONFIG[openssl] = "--with-openssl,--without-openssl,openssl"
> > > +PACKAGECONFIG[libmemcached] =
> "--with-memcached=${STAGING_INCDIR}/libmemcachedutil-1.0,--without-memc
> ached,libmemcached"
> > > +PACKAGECONFIG[postgresql] =
> "--with-pgsql-includedir=${STAGING_INCDIR}/postgresql
> --with-pgsql=${bindir} ,,postgresql"
> > > +
> > > +EXTRA_OECONF += "-disable-static \
> > > +               "
> > > +B = "${S}"
> > > +CFLAGS:append = " -fcommon "
> > > +
> > > +FILES:${PN} += "${datadir}/pgpool-II/ "
> > > +
> > > +do_install:append() {
> > > +    install -d ${D}${sysconfdir}/pgpool-II
> > > +    install -D -m 0644 ${WORKDIR}/pgpool.sysconfig
> ${D}${sysconfdir}/pgpool-II/pgpool.conf
> > > +    install -D -m 0644 ${S}/src/sample/pcp.conf.sample
> ${D}${sysconfdir}/pgpool-II/pcp.conf
> > > +    install -D -m 0644 ${S}/src/sample/pool_hba.conf.sample
> ${D}${sysconfdir}/pgpool-II/pool_hba.conf
> > > +    install -Dm 0644 ${WORKDIR}/pgpool.service
> > > +${D}${systemd_system_unitdir}/pgpool.service
> > > +}
> > > --
> > > 1.8.3.1
> > >
> > >
> > > -=-=-=-=-=-=-=-=-=-=-=-
> > > Links: You receive all messages sent to this group.
> > > View/Reply Online (#100478):
> > > https://lists.openembedded.org/g/openembedded-devel/message/100478
> > > Mute This Topic: https://lists.openembedded.org/mt/96146690/1997914
> > > Group Owner: openembedded-devel+owner@lists.openembedded.org
> > > Unsubscribe:
> > > https://lists.openembedded.org/g/openembedded-devel/unsub
> > > [raj.khem@gmail.com]
> > > -=-=-=-=-=-=-=-=-=-=-=-
> > >
diff mbox series

Patch

diff --git a/meta-oe/recipes-support/pgpool2/pgpool2/pgpool.service b/meta-oe/recipes-support/pgpool2/pgpool2/pgpool.service
new file mode 100644
index 0000000..bf2d323
--- /dev/null
+++ b/meta-oe/recipes-support/pgpool2/pgpool2/pgpool.service
@@ -0,0 +1,17 @@ 
+[Unit]
+Description=Pgpool-II
+After=syslog.target network.target
+
+[Service]
+
+User=postgres
+Group=postgres
+
+EnvironmentFile=-/etc/sysconfig/pgpool
+
+ExecStart=/usr/bin/pgpool -f /etc/pgpool-II/pgpool.conf $OPTS
+ExecStop=/usr/bin/pgpool -f /etc/pgpool-II/pgpool.conf $STOP_OPTS stop
+ExecReload=/usr/bin/pgpool -f /etc/pgpool-II/pgpool.conf reload
+
+[Install]
+WantedBy=multi-user.target
diff --git a/meta-oe/recipes-support/pgpool2/pgpool2/pgpool.sysconfig b/meta-oe/recipes-support/pgpool2/pgpool2/pgpool.sysconfig
new file mode 100644
index 0000000..ea13089
--- /dev/null
+++ b/meta-oe/recipes-support/pgpool2/pgpool2/pgpool.sysconfig
@@ -0,0 +1,7 @@ 
+# Options for pgpool
+
+# -n: don't run in daemon mode. does not detach control tty
+# -d: debug mode. lots of debug information will be printed
+
+#OPTS=" -d -n"
+OPTS=" -n"
diff --git a/meta-oe/recipes-support/pgpool2/pgpool2_4.4.1.bb b/meta-oe/recipes-support/pgpool2/pgpool2_4.4.1.bb
new file mode 100644
index 0000000..52e0192
--- /dev/null
+++ b/meta-oe/recipes-support/pgpool2/pgpool2_4.4.1.bb
@@ -0,0 +1,46 @@ 
+SUMMARY = "a language independent connection pool server for PostgreSQL."
+
+DESCRIPTION = "Pgpool-II is a middleware that works between PostgreSQL \
+               servers and a PostgreSQL database client. It is distributed \
+               under a license similar to BSD and MIT. It provides the \
+               following features."
+
+HOMEPAGE = "http://pgpool.net"
+
+LICENSE = "BSD-2-Clause"
+LIC_FILES_CHKSUM = "file://COPYING;md5=e4b38de086d73e0521de0bbdbaa4a1a9"
+
+SRC_URI = "http://www.pgpool.net/mediawiki/images/pgpool-II-${PV}.tar.gz \
+	   file://pgpool.sysconfig \
+	   file://pgpool.service \
+           "
+SRC_URI[sha256sum] = "4b379bbba8e178128a1cee4a5bd1ae116dedb3da6121b728c18f0f54c881f328"
+
+S = "${WORKDIR}/pgpool-II-${PV}"
+
+inherit autotools systemd
+
+SYSTEMD_SERVICE:${PN} = "pgpool.service"
+
+PACKAGECONFIG ??= " openssl libmemcached postgresql \
+    ${@bb.utils.filter('DISTRO_FEATURES', 'pam', d)} \
+    "
+PACKAGECONFIG[pam] = "--with-pam,--without-pam,libpam,"
+PACKAGECONFIG[openssl] = "--with-openssl,--without-openssl,openssl"
+PACKAGECONFIG[libmemcached] = "--with-memcached=${STAGING_INCDIR}/libmemcachedutil-1.0,--without-memcached,libmemcached"
+PACKAGECONFIG[postgresql] = "--with-pgsql-includedir=${STAGING_INCDIR}/postgresql --with-pgsql=${bindir} ,,postgresql"
+
+EXTRA_OECONF += "-disable-static \
+		"
+B = "${S}"
+CFLAGS:append = " -fcommon "
+
+FILES:${PN} += "${datadir}/pgpool-II/ "
+
+do_install:append() {
+    install -d ${D}${sysconfdir}/pgpool-II
+    install -D -m 0644 ${WORKDIR}/pgpool.sysconfig  ${D}${sysconfdir}/pgpool-II/pgpool.conf
+    install -D -m 0644 ${S}/src/sample/pcp.conf.sample ${D}${sysconfdir}/pgpool-II/pcp.conf
+    install -D -m 0644 ${S}/src/sample/pool_hba.conf.sample ${D}${sysconfdir}/pgpool-II/pool_hba.conf
+    install -Dm 0644 ${WORKDIR}/pgpool.service ${D}${systemd_system_unitdir}/pgpool.service
+}