diff mbox series

[08/10] python3-cython: Use PACKAGE_PREPROCESS_FUNCS instead of PACKAGEBUILDPKGD

Message ID 20230104154714.1168535-8-richard.purdie@linuxfoundation.org
State New
Headers show
Series [01/10] package: Move fixup_perms function to bb function library | expand

Commit Message

Richard Purdie Jan. 4, 2023, 3:47 p.m. UTC
The recipe can use the more commonly used PACKAGE_PREPROCESS_FUNCS instead
of PACKAGEBUILDPKGD which is likely to be removed soon, there should be
no change in behaviour.

Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
---
 meta/recipes-devtools/python/python3-cython_0.29.32.bb | 2 +-
 1 file changed, 1 insertion(+), 1 deletion(-)
diff mbox series

Patch

diff --git a/meta/recipes-devtools/python/python3-cython_0.29.32.bb b/meta/recipes-devtools/python/python3-cython_0.29.32.bb
index 8fed1cf94d0..1c4853e14af 100644
--- a/meta/recipes-devtools/python/python3-cython_0.29.32.bb
+++ b/meta/recipes-devtools/python/python3-cython_0.29.32.bb
@@ -17,7 +17,7 @@  do_install:append() {
     mv ${D}${bindir}/cygdb ${D}${bindir}/cygdb3
 }
 
-PACKAGEBUILDPKGD += "cython_fix_sources"
+PACKAGE_PREPROCESS_FUNCS += "cython_fix_sources"
 
 cython_fix_sources () {
 	for f in ${PKGD}/usr/src/debug/${PN}/${EXTENDPE}${PV}-${PR}/Cython/Compiler/FlowControl.c \