diff mbox series

[v4,09/11] cargo: Override crossbeam-utils with 0.8.14

Message ID 20221225215921.12868-10-alex.kiernan@gmail.com
State New
Headers show
Series Add rust runtime tests | expand

Commit Message

Alex Kiernan Dec. 25, 2022, 9:59 p.m. UTC
Use cargo patching to replace crossbeam-utils with the semver compatible
0.8.14 rather than trying to patch our local changes. This corrects the
ppc/mips builds.

Signed-off-by: Alex Kiernan <alex.kiernan@gmail.com>
---

Changes in v4:
- Add crossbeam atomics fixes for ppc/mips

 meta/recipes-devtools/cargo/cargo_1.66.0.bb | 7 +++++++
 1 file changed, 7 insertions(+)
diff mbox series

Patch

diff --git a/meta/recipes-devtools/cargo/cargo_1.66.0.bb b/meta/recipes-devtools/cargo/cargo_1.66.0.bb
index fe8049b68c9b..909651b9efdd 100644
--- a/meta/recipes-devtools/cargo/cargo_1.66.0.bb
+++ b/meta/recipes-devtools/cargo/cargo_1.66.0.bb
@@ -14,6 +14,13 @@  LIC_FILES_CHKSUM = " \
 require recipes-devtools/rust/rust-source.inc
 require recipes-devtools/rust/rust-snapshot.inc
 
+# Reuse the path override capability we have to patch in a later version
+# of crossbeam-utils which has the vendor misdetection fixes
+# (https://github.com/crossbeam-rs/crossbeam/pull/922). This should be
+# removed once the upstream source merges the change to include it.
+SRC_URI:append:class-target = " crate://crates.io/crossbeam-utils/0.8.14"
+EXTRA_OECARGO_PATHS:class-target = "${CARGO_HOME}/bitbake/crossbeam-utils-0.8.14"
+
 S = "${RUSTSRC}/src/tools/cargo"
 CARGO_VENDORING_DIRECTORY = "${RUSTSRC}/vendor"
 EXCLUDE_FROM_WORLD = "1"