diff mbox series

[2/2] proj: avoid leaking host path in libproj

Message ID 20221207112730.264291-2-peron.clem@gmail.com
State Under Review
Headers show
Series [1/2] proj: add a packageconfig to build as a static library | expand

Commit Message

Clément Péron Dec. 7, 2022, 11:27 a.m. UTC
When compiling libproj for a SDK, the proj-targets.cmake generated
contains the host path in the INTERFACE_LINK_LIBRARIES.

This path comes from the sqlite3 libraries that gives the full path
to the sqlite3 library at build time.

Force the libproj to link with "sqlite3" instead of a full path.

Signed-off-by: Clément Péron <peron.clem@gmail.com>
---
 meta-oe/recipes-navigation/proj/proj_9.1.0.bb | 2 +-
 1 file changed, 1 insertion(+), 1 deletion(-)
diff mbox series

Patch

diff --git a/meta-oe/recipes-navigation/proj/proj_9.1.0.bb b/meta-oe/recipes-navigation/proj/proj_9.1.0.bb
index 818c87bf0..218f08396 100644
--- a/meta-oe/recipes-navigation/proj/proj_9.1.0.bb
+++ b/meta-oe/recipes-navigation/proj/proj_9.1.0.bb
@@ -10,7 +10,7 @@  SRC_URI[sha256sum] = "81b2239b94cad0886222cde4f53cb49d34905aad2a1317244a0c30a553
 
 inherit cmake lib_package
 
-EXTRA_OECMAKE = "-DBUILD_TESTING=OFF"
+EXTRA_OECMAKE = "-DBUILD_TESTING=OFF -DSQLITE3_LIBRARY:STRING=sqlite3"
 
 FILES:${PN} += "${datadir}/proj"