diff mbox series

[meta-python] python3-geomet: upgrade 0.3.0 -> 1.0.0

Message ID 1670066295-24879-3-git-send-email-wangmy@fujitsu.com
State Under Review
Headers show
Series [meta-python] python3-geomet: upgrade 0.3.0 -> 1.0.0 | expand

Commit Message

Mingyu Wang (Fujitsu) Dec. 3, 2022, 11:18 a.m. UTC
From: Wang Mingyu <wangmy@fujitsu.com>

Changelog:
==========
 Fix bug in _round_and_pad with exponential coordinate values (#73)
 Use assertNotEqual instead of assertNotEquals in tests, for Python 3.11 compatibility (#77)
 Add support for Python 3.8, 3.9, and 3.10 (#79, #84)
 Drop support for end-of-life Python versions 2.7, 3.4, 3.5, and 3.6 (#84)
 Fix structure of coordinate values in GeoJSON to EsriJSON conversion (#82)
 Update README with to add History and Limitations sections, and to expand on functionality (#86)

Signed-off-by: Wang Mingyu <wangmy@fujitsu.com>
---
 .../{python3-geomet_0.3.0.bb => python3-geomet_1.0.0.bb}     | 5 ++---
 1 file changed, 2 insertions(+), 3 deletions(-)
 rename meta-python/recipes-devtools/python/{python3-geomet_0.3.0.bb => python3-geomet_1.0.0.bb} (89%)
diff mbox series

Patch

diff --git a/meta-python/recipes-devtools/python/python3-geomet_0.3.0.bb b/meta-python/recipes-devtools/python/python3-geomet_1.0.0.bb
similarity index 89%
rename from meta-python/recipes-devtools/python/python3-geomet_0.3.0.bb
rename to meta-python/recipes-devtools/python/python3-geomet_1.0.0.bb
index 8e907462a..84356cf6f 100644
--- a/meta-python/recipes-devtools/python/python3-geomet_0.3.0.bb
+++ b/meta-python/recipes-devtools/python/python3-geomet_1.0.0.bb
@@ -9,9 +9,8 @@  SRCNAME = "geomet"
 SRC_URI[sha256sum] = "cb52411978ee01ff104ab48f108d7333b14423ae7a15a65fee25b7d29bda2e1b"
 
 S = "${WORKDIR}/git"
-SRC_URI = "git://github.com/geomet/geomet.git;protocol=https;branch=release-${PV} \
-           "
-SRCREV = "73ec5ec96cca32f2e2461d3964fc3d4ab80248f9"
+SRC_URI = "git://github.com/geomet/geomet.git;protocol=https;branch=master"
+SRCREV = "7fff4438510c30e592db858b2d519eddb5837a6c"
 
 inherit setuptools3
 PIP_INSTALL_PACKAGE = "geomet"