diff mbox series

python3-yappi: upgrade 1.3.6 -> 1.4.0, python 3.11 compatible

Message ID 20221128223233.951207-1-geoffhp@gmail.com
State Under Review
Headers show
Series python3-yappi: upgrade 1.3.6 -> 1.4.0, python 3.11 compatible | expand

Commit Message

Geoff Parker Nov. 28, 2022, 10:32 p.m. UTC
From: Geoff Parker <geoffrey.parker@arthrex.com>

Update to 1.4.0 for python 3.11 compatibilty

Add patch to add upstream commit added after the release of 1.4.0
tarball. Adds python 3.11 to setup.py

Update 0001-Fix-imports-for-ptest.patch for patch fuzz and
removed hunk already in 1.4.0.

Signed-off-by: Geoff Parker <geoffrey.parker@arthrex.com>
---
 .../0001-Fix-imports-for-ptests.patch         | 16 ++-----------
 .../0002-add-3.11-to-the-setup.patch          | 24 +++++++++++++++++++
 ...-yappi_1.3.6.bb => python3-yappi_1.4.0.bb} |  4 ++--
 3 files changed, 28 insertions(+), 16 deletions(-)
 create mode 100644 meta-python/recipes-devtools/python/python3-yappi/0002-add-3.11-to-the-setup.patch
 rename meta-python/recipes-devtools/python/{python3-yappi_1.3.6.bb => python3-yappi_1.4.0.bb} (81%)
diff mbox series

Patch

diff --git a/meta-python/recipes-devtools/python/python3-yappi/0001-Fix-imports-for-ptests.patch b/meta-python/recipes-devtools/python/python3-yappi/0001-Fix-imports-for-ptests.patch
index fa58897e6..274f6f527 100644
--- a/meta-python/recipes-devtools/python/python3-yappi/0001-Fix-imports-for-ptests.patch
+++ b/meta-python/recipes-devtools/python/python3-yappi/0001-Fix-imports-for-ptests.patch
@@ -8,10 +8,9 @@  Signed-off-by: Trevor Gamblin <trevor.gamblin@windriver.com>
  tests/test_asyncio.py              | 2 +-
  tests/test_asyncio_context_vars.py | 2 +-
  tests/test_functionality.py        | 2 +-
- tests/test_gevent.py               | 2 +-
  tests/test_hooks.py                | 2 +-
  tests/test_tags.py                 | 2 +-
- 6 files changed, 6 insertions(+), 6 deletions(-)
+ 5 files changed, 6 insertions(+), 6 deletions(-)
 
 --- a/tests/test_asyncio.py
 +++ b/tests/test_asyncio.py
@@ -23,7 +22,7 @@  Signed-off-by: Trevor Gamblin <trevor.gamblin@windriver.com>
 +from .utils import YappiUnitTestCase, find_stat_by_name, burn_cpu, burn_io
  
  
- @asyncio.coroutine
+ async def async_sleep(sec):
 --- a/tests/test_asyncio_context_vars.py
 +++ b/tests/test_asyncio_context_vars.py
 @@ -5,7 +5,7 @@ import contextvars
@@ -3870,17 +3869,6 @@  Signed-off-by: Trevor Gamblin <trevor.gamblin@windriver.com>
 +    #     import sys;sys.argv = ['', 'BasicUsage.test_run_as_script']
 +    #     import sys;sys.argv = ['', 'MultithreadedScenarios.test_subsequent_profile']
 +    unittest.main()
---- a/tests/test_gevent.py
-+++ b/tests/test_gevent.py
-@@ -4,7 +4,7 @@ import yappi
- import gevent
- from gevent.event import Event
- import threading
--from utils import (
-+from .utils import (
-     YappiUnitTestCase, find_stat_by_name, burn_cpu, burn_io,
-     burn_io_gevent
- )
 --- a/tests/test_hooks.py
 +++ b/tests/test_hooks.py
 @@ -5,7 +5,7 @@ import unittest
diff --git a/meta-python/recipes-devtools/python/python3-yappi/0002-add-3.11-to-the-setup.patch b/meta-python/recipes-devtools/python/python3-yappi/0002-add-3.11-to-the-setup.patch
new file mode 100644
index 000000000..a9bf612db
--- /dev/null
+++ b/meta-python/recipes-devtools/python/python3-yappi/0002-add-3.11-to-the-setup.patch
@@ -0,0 +1,24 @@ 
+From 38afdacf526410f970afc58e147c7377c6c7112c Mon Sep 17 00:00:00 2001
+From: =?UTF-8?q?S=C3=BCmer=20Cip?= <sumer.cip@platform.sh>
+Date: Fri, 25 Nov 2022 15:58:03 +0300
+Subject: [PATCH 2/2] add 3.11 to the setup
+
+---
+ setup.py | 1 +
+ 1 file changed, 1 insertion(+)
+
+diff --git a/setup.py b/setup.py
+index d006787..96e2a66 100644
+--- a/setup.py
++++ b/setup.py
+@@ -56,6 +56,7 @@ CLASSIFIERS = [
+     'Programming Language :: Python :: 3.8',
+     'Programming Language :: Python :: 3.9',
+     'Programming Language :: Python :: 3.10',
++    'Programming Language :: Python :: 3.11',
+     'Programming Language :: Python :: Implementation :: CPython',
+     'Operating System :: OS Independent',
+     'Topic :: Software Development :: Libraries',
+-- 
+2.30.2
+
diff --git a/meta-python/recipes-devtools/python/python3-yappi_1.3.6.bb b/meta-python/recipes-devtools/python/python3-yappi_1.4.0.bb
similarity index 81%
rename from meta-python/recipes-devtools/python/python3-yappi_1.3.6.bb
rename to meta-python/recipes-devtools/python/python3-yappi_1.4.0.bb
index 526af346b..71e74e86f 100644
--- a/meta-python/recipes-devtools/python/python3-yappi_1.3.6.bb
+++ b/meta-python/recipes-devtools/python/python3-yappi_1.4.0.bb
@@ -4,11 +4,12 @@  HOMEPAGE = "https://github.com/sumerc/yappi"
 LICENSE = "MIT"
 LIC_FILES_CHKSUM = "file://LICENSE;md5=71c208c9a4fd864385eb69ad4caa3bee"
 
-SRC_URI[sha256sum] = "0a73c608a2603570a020a32d4369ba744012bc5267f37e5bd8026fb491abba56"
+SRC_URI[sha256sum] = "504b5d8fc7433736cb5e257991d2e7f2946019174f1faec7b2fe947881a17fc0"
 
 SRC_URI += " \
     file://run-ptest \
     file://0001-Fix-imports-for-ptests.patch \
+    file://0002-add-3.11-to-the-setup.patch \
 "
 
 inherit pypi setuptools3 ptest
@@ -33,4 +34,3 @@  do_install_ptest() {
     cp -f ${S}/yappi/yappi.py ${D}/${PTEST_PATH}/
 }
 
-SKIP_RECIPE[python3-yappi] ?= "Not compatible with py3.11; needs a new release"