diff mbox series

musl: Update to latest on tip of trunk

Message ID 20221128191804.51591-1-raj.khem@gmail.com
State Accepted, archived
Commit 3b27f6356a3bf0138da0c3dcd87aa8e4a93ae56b
Headers show
Series musl: Update to latest on tip of trunk | expand

Commit Message

Khem Raj Nov. 28, 2022, 7:18 p.m. UTC
Brings following changes

* 8f925945 fix return value of gethostby{name[2],addr} with no result but no error
* 63402be2 clean up dns_parse_callback
* 0a7b4323 dns response handling: don't treat too many addresses as an error
* 41603c77 dns response handling: ignore presence of wrong-type RRs
* cf76df0e fix missing synchronization of pthread TSD keys with MT-fork
* 5ff3eea9 fgets: avoid arithmetic overflow when n==INT_MIN is passed
* d8f35e29 fix AS-safety of close when aio is in use and fd map is expanded
* 26c76a90 fix use of uninitialized dummy_fut in aio_suspend
* aebd6a36 fix potential deadlock between multithreaded fork and aio
* d64148a8 fix potential unsynchronized access to killlock state at thread exit
* 36b72cd6 fix potential deadlock in dlerror buffer handling at thread exit
* 833a4691 configure: disable TBAA optimization because most compilers are buggy
* e6e82132 disable MADV_FREE usage in mallocng
* 25e6fee2 remove LFS64 programming interfaces (macro-only) from _GNU_SOURCE
* 246f1c81 remove LFS64 symbol aliases; replace with dynamic linker remapping
* dec8f0a4 dns query core: detect udp truncation at recv time
* 8c408937 getaddrinfo dns lookup: use larger answer buffer to handle long CNAMEs
* 759bf785 arpa/nameser.h: update RR types list
* 51d4669f dns: implement tcp fallback in __res_msend query core
* e2e95176 res_send: use a temp buffer if caller's buffer is under 512 bytes
* c87d75f2 adapt res_msend DNS query core for working with multiple sockets
* 85050ac5 getaddrinfo: add EAI_NODATA error code to distinguish NODATA vs NxDomain

Signed-off-by: Khem Raj <raj.khem@gmail.com>
---
 meta/recipes-core/musl/musl_git.bb | 2 +-
 1 file changed, 1 insertion(+), 1 deletion(-)

Comments

Alexandre Belloni Nov. 30, 2022, 2:48 p.m. UTC | #1
Hello,

This broke a few recipes:

https://autobuilder.yoctoproject.org/typhoon/#/builders/64/builds/6247/steps/12/logs/stdio

I guess this is dues to the LFS64 changes

On 28/11/2022 11:18:04-0800, Khem Raj wrote:
> Brings following changes
> 
> * 8f925945 fix return value of gethostby{name[2],addr} with no result but no error
> * 63402be2 clean up dns_parse_callback
> * 0a7b4323 dns response handling: don't treat too many addresses as an error
> * 41603c77 dns response handling: ignore presence of wrong-type RRs
> * cf76df0e fix missing synchronization of pthread TSD keys with MT-fork
> * 5ff3eea9 fgets: avoid arithmetic overflow when n==INT_MIN is passed
> * d8f35e29 fix AS-safety of close when aio is in use and fd map is expanded
> * 26c76a90 fix use of uninitialized dummy_fut in aio_suspend
> * aebd6a36 fix potential deadlock between multithreaded fork and aio
> * d64148a8 fix potential unsynchronized access to killlock state at thread exit
> * 36b72cd6 fix potential deadlock in dlerror buffer handling at thread exit
> * 833a4691 configure: disable TBAA optimization because most compilers are buggy
> * e6e82132 disable MADV_FREE usage in mallocng
> * 25e6fee2 remove LFS64 programming interfaces (macro-only) from _GNU_SOURCE
> * 246f1c81 remove LFS64 symbol aliases; replace with dynamic linker remapping
> * dec8f0a4 dns query core: detect udp truncation at recv time
> * 8c408937 getaddrinfo dns lookup: use larger answer buffer to handle long CNAMEs
> * 759bf785 arpa/nameser.h: update RR types list
> * 51d4669f dns: implement tcp fallback in __res_msend query core
> * e2e95176 res_send: use a temp buffer if caller's buffer is under 512 bytes
> * c87d75f2 adapt res_msend DNS query core for working with multiple sockets
> * 85050ac5 getaddrinfo: add EAI_NODATA error code to distinguish NODATA vs NxDomain
> 
> Signed-off-by: Khem Raj <raj.khem@gmail.com>
> ---
>  meta/recipes-core/musl/musl_git.bb | 2 +-
>  1 file changed, 1 insertion(+), 1 deletion(-)
> 
> diff --git a/meta/recipes-core/musl/musl_git.bb b/meta/recipes-core/musl/musl_git.bb
> index a72d87ea6f..29abd17771 100644
> --- a/meta/recipes-core/musl/musl_git.bb
> +++ b/meta/recipes-core/musl/musl_git.bb
> @@ -4,7 +4,7 @@
>  require musl.inc
>  inherit linuxloader
>  
> -SRCREV = "dc9285ad1dc19349c407072cc48ba70dab86de45"
> +SRCREV = "8f9259450aa43a6fd539e428e61e2961b725fbae"
>  
>  BASEVER = "1.2.3"
>  
> -- 
> 2.38.1
> 

> 
> -=-=-=-=-=-=-=-=-=-=-=-
> Links: You receive all messages sent to this group.
> View/Reply Online (#173942): https://lists.openembedded.org/g/openembedded-core/message/173942
> Mute This Topic: https://lists.openembedded.org/mt/95318179/3617179
> Group Owner: openembedded-core+owner@lists.openembedded.org
> Unsubscribe: https://lists.openembedded.org/g/openembedded-core/unsub [alexandre.belloni@bootlin.com]
> -=-=-=-=-=-=-=-=-=-=-=-
>
Khem Raj Nov. 30, 2022, 4:09 p.m. UTC | #2
On Wed, Nov 30, 2022 at 6:48 AM Alexandre Belloni
<alexandre.belloni@bootlin.com> wrote:
>
> Hello,
>
> This broke a few recipes:
>
> https://autobuilder.yoctoproject.org/typhoon/#/builders/64/builds/6247/steps/12/logs/stdio
>
> I guess this is dues to the LFS64 changes

yes indeed. I have some WIP on yoe/mut branch. Lets wait for some time
until fixing these packages.

>
> On 28/11/2022 11:18:04-0800, Khem Raj wrote:
> > Brings following changes
> >
> > * 8f925945 fix return value of gethostby{name[2],addr} with no result but no error
> > * 63402be2 clean up dns_parse_callback
> > * 0a7b4323 dns response handling: don't treat too many addresses as an error
> > * 41603c77 dns response handling: ignore presence of wrong-type RRs
> > * cf76df0e fix missing synchronization of pthread TSD keys with MT-fork
> > * 5ff3eea9 fgets: avoid arithmetic overflow when n==INT_MIN is passed
> > * d8f35e29 fix AS-safety of close when aio is in use and fd map is expanded
> > * 26c76a90 fix use of uninitialized dummy_fut in aio_suspend
> > * aebd6a36 fix potential deadlock between multithreaded fork and aio
> > * d64148a8 fix potential unsynchronized access to killlock state at thread exit
> > * 36b72cd6 fix potential deadlock in dlerror buffer handling at thread exit
> > * 833a4691 configure: disable TBAA optimization because most compilers are buggy
> > * e6e82132 disable MADV_FREE usage in mallocng
> > * 25e6fee2 remove LFS64 programming interfaces (macro-only) from _GNU_SOURCE
> > * 246f1c81 remove LFS64 symbol aliases; replace with dynamic linker remapping
> > * dec8f0a4 dns query core: detect udp truncation at recv time
> > * 8c408937 getaddrinfo dns lookup: use larger answer buffer to handle long CNAMEs
> > * 759bf785 arpa/nameser.h: update RR types list
> > * 51d4669f dns: implement tcp fallback in __res_msend query core
> > * e2e95176 res_send: use a temp buffer if caller's buffer is under 512 bytes
> > * c87d75f2 adapt res_msend DNS query core for working with multiple sockets
> > * 85050ac5 getaddrinfo: add EAI_NODATA error code to distinguish NODATA vs NxDomain
> >
> > Signed-off-by: Khem Raj <raj.khem@gmail.com>
> > ---
> >  meta/recipes-core/musl/musl_git.bb | 2 +-
> >  1 file changed, 1 insertion(+), 1 deletion(-)
> >
> > diff --git a/meta/recipes-core/musl/musl_git.bb b/meta/recipes-core/musl/musl_git.bb
> > index a72d87ea6f..29abd17771 100644
> > --- a/meta/recipes-core/musl/musl_git.bb
> > +++ b/meta/recipes-core/musl/musl_git.bb
> > @@ -4,7 +4,7 @@
> >  require musl.inc
> >  inherit linuxloader
> >
> > -SRCREV = "dc9285ad1dc19349c407072cc48ba70dab86de45"
> > +SRCREV = "8f9259450aa43a6fd539e428e61e2961b725fbae"
> >
> >  BASEVER = "1.2.3"
> >
> > --
> > 2.38.1
> >
>
> >
> > -=-=-=-=-=-=-=-=-=-=-=-
> > Links: You receive all messages sent to this group.
> > View/Reply Online (#173942): https://lists.openembedded.org/g/openembedded-core/message/173942
> > Mute This Topic: https://lists.openembedded.org/mt/95318179/3617179
> > Group Owner: openembedded-core+owner@lists.openembedded.org
> > Unsubscribe: https://lists.openembedded.org/g/openembedded-core/unsub [alexandre.belloni@bootlin.com]
> > -=-=-=-=-=-=-=-=-=-=-=-
> >
>
>
> --
> Alexandre Belloni, co-owner and COO, Bootlin
> Embedded Linux and Kernel engineering
> https://bootlin.com
diff mbox series

Patch

diff --git a/meta/recipes-core/musl/musl_git.bb b/meta/recipes-core/musl/musl_git.bb
index a72d87ea6f..29abd17771 100644
--- a/meta/recipes-core/musl/musl_git.bb
+++ b/meta/recipes-core/musl/musl_git.bb
@@ -4,7 +4,7 @@ 
 require musl.inc
 inherit linuxloader
 
-SRCREV = "dc9285ad1dc19349c407072cc48ba70dab86de45"
+SRCREV = "8f9259450aa43a6fd539e428e61e2961b725fbae"
 
 BASEVER = "1.2.3"