diff mbox series

python3: add PACKAGECONFIG[editline]

Message ID 20220913123910.3428647-1-ecordonnier@snap.com
State Accepted, archived
Commit 33c1dc903a0908dc9796ddf03a90f1e23e5d1405
Headers show
Series python3: add PACKAGECONFIG[editline] | expand

Commit Message

Etienne Cordonnier Sept. 13, 2022, 12:39 p.m. UTC
editline is a BSD alternative for readline which is GPLv3.

Signed-off-by: Etienne Cordonnier <ecordonnier@snap.com>
---
 meta/recipes-devtools/python/python3_3.10.6.bb | 1 +
 1 file changed, 1 insertion(+)

Comments

Quentin Schulz Sept. 13, 2022, 12:53 p.m. UTC | #1
Hi Etienne,

On 9/13/22 14:39, Etienne Cordonnier via lists.openembedded.org wrote:
> editline is a BSD alternative for readline which is GPLv3.
> 
> Signed-off-by: Etienne Cordonnier <ecordonnier@snap.com>
> ---
>   meta/recipes-devtools/python/python3_3.10.6.bb | 1 +
>   1 file changed, 1 insertion(+)
> 
> diff --git a/meta/recipes-devtools/python/python3_3.10.6.bb b/meta/recipes-devtools/python/python3_3.10.6.bb
> index 1b28728732..6c4ef5c7d1 100644
> --- a/meta/recipes-devtools/python/python3_3.10.6.bb
> +++ b/meta/recipes-devtools/python/python3_3.10.6.bb
> @@ -105,6 +105,7 @@ PACKAGECONFIG:class-target ??= "readline gdbm ${@bb.utils.filter('DISTRO_FEATURE
>   PACKAGECONFIG:class-native ??= "readline gdbm"
>   PACKAGECONFIG:class-nativesdk ??= "readline gdbm"
>   PACKAGECONFIG[readline] = ",,readline"
> +PACKAGECONFIG[editline] = "--with-readline=editline,,libedit"

Is libedit supposed to replace readline entirely in python3? If so, I'm 
wondering if it'd make sense to make readline and editline 
PACKAGECONFIG's packageconfig-conflicts-for-f1 the other so that we 
cannot have both configs enabled at the same time?

C.f. last entry in 
https://docs.yoctoproject.org/ref-manual/variables.html#term-PACKAGECONFIG

Cheers,
Quentin

>   # Use profile guided optimisation by running PyBench inside qemu-user
>   PACKAGECONFIG[pgo] = "--enable-optimizations,,qemu-native"
>   PACKAGECONFIG[tk] = ",,tk"
> 
> 
> 
> -=-=-=-=-=-=-=-=-=-=-=-
> Links: You receive all messages sent to this group.
> View/Reply Online (#170576): https://urldefense.proofpoint.com/v2/url?u=https-3A__lists.openembedded.org_g_openembedded-2Dcore_message_170576&d=DwIFaQ&c=_sEr5x9kUWhuk4_nFwjJtA&r=LYjLexDn7rXIzVmkNPvw5ymA1XTSqHGq8yBP6m6qZZ4njZguQhZhkI_-172IIy1t&m=QwQT1E3jSDJ2g0NTR_v12IuTnVPJslfFNt7_11W1SfSnn-87qis_5jjFlcsp3W6V&s=BmvM79DREWtojYRC-ufOj7AZ5khUIuwoZ_cL1VgAGu0&e=
> Mute This Topic: https://urldefense.proofpoint.com/v2/url?u=https-3A__lists.openembedded.org_mt_93654164_6293953&d=DwIFaQ&c=_sEr5x9kUWhuk4_nFwjJtA&r=LYjLexDn7rXIzVmkNPvw5ymA1XTSqHGq8yBP6m6qZZ4njZguQhZhkI_-172IIy1t&m=QwQT1E3jSDJ2g0NTR_v12IuTnVPJslfFNt7_11W1SfSnn-87qis_5jjFlcsp3W6V&s=QhIFYKrLZ1FS_BL-tsQvUEZtL5Fm4CrGs9aP-ihyae0&e=
> Group Owner: openembedded-core+owner@lists.openembedded.org
> Unsubscribe: https://urldefense.proofpoint.com/v2/url?u=https-3A__lists.openembedded.org_g_openembedded-2Dcore_unsub&d=DwIFaQ&c=_sEr5x9kUWhuk4_nFwjJtA&r=LYjLexDn7rXIzVmkNPvw5ymA1XTSqHGq8yBP6m6qZZ4njZguQhZhkI_-172IIy1t&m=QwQT1E3jSDJ2g0NTR_v12IuTnVPJslfFNt7_11W1SfSnn-87qis_5jjFlcsp3W6V&s=UVe3axFwAeEISx3bG_8YcrRRpZaV4V3DxhtIETyZjz4&e=   [quentin.schulz@theobroma-systems.com]
> -=-=-=-=-=-=-=-=-=-=-=-
>
Etienne Cordonnier Sept. 13, 2022, 2:58 p.m. UTC | #2
Hi Quentin,

yes, editline is replacing readline in python3, even though editline may
have slightly less functionality than readline. I'll edit the patch to add
a conflict between editline and readline.

Thanks,
Etienne

On Tue, Sep 13, 2022 at 2:53 PM Quentin Schulz <
quentin.schulz@theobroma-systems.com> wrote:

> Hi Etienne,
>
> On 9/13/22 14:39, Etienne Cordonnier via lists.openembedded.org wrote:
> > editline is a BSD alternative for readline which is GPLv3.
> >
> > Signed-off-by: Etienne Cordonnier <ecordonnier@snap.com>
> > ---
> >   meta/recipes-devtools/python/python3_3.10.6.bb | 1 +
> >   1 file changed, 1 insertion(+)
> >
> > diff --git a/meta/recipes-devtools/python/python3_3.10.6.bb
> b/meta/recipes-devtools/python/python3_3.10.6.bb
> > index 1b28728732..6c4ef5c7d1 100644
> > --- a/meta/recipes-devtools/python/python3_3.10.6.bb
> > +++ b/meta/recipes-devtools/python/python3_3.10.6.bb
> > @@ -105,6 +105,7 @@ PACKAGECONFIG:class-target ??= "readline gdbm
> ${@bb.utils.filter('DISTRO_FEATURE
> >   PACKAGECONFIG:class-native ??= "readline gdbm"
> >   PACKAGECONFIG:class-nativesdk ??= "readline gdbm"
> >   PACKAGECONFIG[readline] = ",,readline"
> > +PACKAGECONFIG[editline] = "--with-readline=editline,,libedit"
>
> Is libedit supposed to replace readline entirely in python3? If so, I'm
> wondering if it'd make sense to make readline and editline
> PACKAGECONFIG's packageconfig-conflicts-for-f1 the other so that we
> cannot have both configs enabled at the same time?
>
> C.f. last entry in
>
> https://urldefense.proofpoint.com/v2/url?u=https-3A__docs.yoctoproject.org_ref-2Dmanual_variables.html-23term-2DPACKAGECONFIG&d=DwICaQ&c=ncDTmphkJTvjIDPh0hpF_4vCHvabgGkICC2epckfdiw&r=AhkbNonVuMIGRfPx_Qj9TsyDLWdbBqarUzFxz3aALck&m=BI7ofOMnjkh-6dMCoBr-4L0qc7YYUHte9BK2ektyAy1jXC5OrzARmRie0aBAbBBB&s=1TEeBYT7HqMmOf5tqLzvd2rnYTyFAx8GHJy2vewKbMA&e=
>
>
> Cheers,
> Quentin
>
> >   # Use profile guided optimisation by running PyBench inside qemu-user
> >   PACKAGECONFIG[pgo] = "--enable-optimizations,,qemu-native"
> >   PACKAGECONFIG[tk] = ",,tk"
> >
> >
> >
> > -=-=-=-=-=-=-=-=-=-=-=-
> > Links: You receive all messages sent to this group.
> > View/Reply Online (#170576):
> https://urldefense.proofpoint.com/v2/url?u=https-3A__lists.openembedded.org_g_openembedded-2Dcore_message_170576&d=DwIFaQ&c=_sEr5x9kUWhuk4_nFwjJtA&r=LYjLexDn7rXIzVmkNPvw5ymA1XTSqHGq8yBP6m6qZZ4njZguQhZhkI_-172IIy1t&m=QwQT1E3jSDJ2g0NTR_v12IuTnVPJslfFNt7_11W1SfSnn-87qis_5jjFlcsp3W6V&s=BmvM79DREWtojYRC-ufOj7AZ5khUIuwoZ_cL1VgAGu0&e=
> > Mute This Topic:
> https://urldefense.proofpoint.com/v2/url?u=https-3A__lists.openembedded.org_mt_93654164_6293953&d=DwIFaQ&c=_sEr5x9kUWhuk4_nFwjJtA&r=LYjLexDn7rXIzVmkNPvw5ymA1XTSqHGq8yBP6m6qZZ4njZguQhZhkI_-172IIy1t&m=QwQT1E3jSDJ2g0NTR_v12IuTnVPJslfFNt7_11W1SfSnn-87qis_5jjFlcsp3W6V&s=QhIFYKrLZ1FS_BL-tsQvUEZtL5Fm4CrGs9aP-ihyae0&e=
> > Group Owner: openembedded-core+owner@lists.openembedded.org
> > Unsubscribe:
> https://urldefense.proofpoint.com/v2/url?u=https-3A__lists.openembedded.org_g_openembedded-2Dcore_unsub&d=DwIFaQ&c=_sEr5x9kUWhuk4_nFwjJtA&r=LYjLexDn7rXIzVmkNPvw5ymA1XTSqHGq8yBP6m6qZZ4njZguQhZhkI_-172IIy1t&m=QwQT1E3jSDJ2g0NTR_v12IuTnVPJslfFNt7_11W1SfSnn-87qis_5jjFlcsp3W6V&s=UVe3axFwAeEISx3bG_8YcrRRpZaV4V3DxhtIETyZjz4&e=
>  [quentin.schulz@theobroma-systems.com]
> > -=-=-=-=-=-=-=-=-=-=-=-
> >
>
diff mbox series

Patch

diff --git a/meta/recipes-devtools/python/python3_3.10.6.bb b/meta/recipes-devtools/python/python3_3.10.6.bb
index 1b28728732..6c4ef5c7d1 100644
--- a/meta/recipes-devtools/python/python3_3.10.6.bb
+++ b/meta/recipes-devtools/python/python3_3.10.6.bb
@@ -105,6 +105,7 @@  PACKAGECONFIG:class-target ??= "readline gdbm ${@bb.utils.filter('DISTRO_FEATURE
 PACKAGECONFIG:class-native ??= "readline gdbm"
 PACKAGECONFIG:class-nativesdk ??= "readline gdbm"
 PACKAGECONFIG[readline] = ",,readline"
+PACKAGECONFIG[editline] = "--with-readline=editline,,libedit"
 # Use profile guided optimisation by running PyBench inside qemu-user
 PACKAGECONFIG[pgo] = "--enable-optimizations,,qemu-native"
 PACKAGECONFIG[tk] = ",,tk"