diff mbox series

[meta-python,2/2] python3-pyzmq: fixed oelint-adv warnings

Message ID 20220724143327.43832-2-jan.vermaete@gmail.com
State Under Review
Headers show
Series [meta-python,1/2] python3-pyzmq: added ptest | expand

Commit Message

Jan Vermaete July 24, 2022, 2:33 p.m. UTC
Signed-off-by: Jan Vermaete <jan.vermaete@gmail.com>
---
 .../python/python3-pyzmq_23.2.0.bb            | 47 ++++++++++---------
 1 file changed, 24 insertions(+), 23 deletions(-)
diff mbox series

Patch

diff --git a/meta-python/recipes-devtools/python/python3-pyzmq_23.2.0.bb b/meta-python/recipes-devtools/python/python3-pyzmq_23.2.0.bb
index 3471265e4..003f35d91 100644
--- a/meta-python/recipes-devtools/python/python3-pyzmq_23.2.0.bb
+++ b/meta-python/recipes-devtools/python/python3-pyzmq_23.2.0.bb
@@ -2,24 +2,36 @@  SUMMARY = "PyZMQ: Python bindings for ZMQ"
 DESCRIPTION = "This package contains Python bindings for ZeroMQ. ZMQ is a lightweight and fast messaging implementation."
 HOMEPAGE = "http://zeromq.org/bindings:python"
 LICENSE = "BSD-3-Clause & LGPL-3.0-only"
-LIC_FILES_CHKSUM = "file://COPYING.BSD;md5=11c65680f637c3df7f58bbc8d133e96e \
-                    file://COPYING.LESSER;md5=12c592fa0bcfff3fb0977b066e9cb69e"
-DEPENDS = "zeromq python3-packaging-native"
+LIC_FILES_CHKSUM = "\
+    file://COPYING.BSD;md5=11c65680f637c3df7f58bbc8d133e96e \
+    file://COPYING.LESSER;md5=12c592fa0bcfff3fb0977b066e9cb69e \
+"
+
+DEPENDS = "python3-packaging-native zeromq"
 
-SRC_URI += "file://club-rpath-out.patch"
+SRC_URI:append = " \
+    file://club-rpath-out.patch \
+    file://run-ptest \
+"
 SRC_URI[sha256sum] = "a51f12a8719aad9dcfb55d456022f16b90abc8dde7d3ca93ce3120b40e3fa169"
 
 inherit pypi pkgconfig python_setuptools_build_meta ptest
 
-SRC_URI += " \
-	file://run-ptest \
+PACKAGES =+ "\
+    ${PN}-test \
 "
 
-DEPENDS += "python3-packaging-native"
+FILES:${PN}-test += "\
+    ${libdir}/${PYTHON_DIR}/site-packages/*/tests \
+"
+
+RDEPENDS:${PN} += "\
+        ${PYTHON_PN}-json \
+        ${PYTHON_PN}-multiprocessing \
+"
 
-RDEPENDS:${PN} += " \
-	${PYTHON_PN}-multiprocessing \
-	${PYTHON_PN}-json \
+RDEPENDS:${PN}-ptest += "\
+        ${PN}-test \
 "
 
 do_compile:prepend() {
@@ -31,18 +43,7 @@  do_compile:prepend() {
     echo no_libzmq_extension = True >> ${S}/setup.cfg
 }
 
-RDEPENDS:${PN}-ptest += " \
-	${PN}-test \
-"
-
-PACKAGES =+ "\
-    ${PN}-test \
-"
-
-FILES:${PN}-test = " \
-    ${libdir}/${PYTHON_DIR}/site-packages/*/tests \
-"
 do_install_ptest() {
-	install -d ${D}${PTEST_PATH}/tests
-	cp -rf ${S}/zmq/tests/* ${D}${PTEST_PATH}/tests/
+        install -d ${D}${PTEST_PATH}/tests
+        cp -rf ${S}/zmq/tests/* ${D}${PTEST_PATH}/tests/
 }