diff mbox series

[kirkstone] harfbuzz: Fix conditional

Message ID 20220718083204.6069-1-wentao.zhang@windriver.com
State New, archived
Headers show
Series [kirkstone] harfbuzz: Fix conditional | expand

Commit Message

Wentao Zhang July 18, 2022, 8:32 a.m. UTC
From: Wentao Zhang <wzhang4@ala-lpd-susbld2.wrs.com>

Backport patch from
https://github.com/harfbuzz/harfbuzz/commit/e421613e8f825508afa9a0b54d33085557c37441

Signed-off-by: Wentao Zhang <wzhang4@ala-lpd-susbld2.wrs.com>
---
 .../harfbuzz/harfbuzz/Fix-conditional.patch   | 27 +++++++++++++++++++
 .../harfbuzz/harfbuzz_4.0.1.bb                |  3 ++-
 2 files changed, 29 insertions(+), 1 deletion(-)
 create mode 100644 meta/recipes-graphics/harfbuzz/harfbuzz/Fix-conditional.patch
diff mbox series

Patch

diff --git a/meta/recipes-graphics/harfbuzz/harfbuzz/Fix-conditional.patch b/meta/recipes-graphics/harfbuzz/harfbuzz/Fix-conditional.patch
new file mode 100644
index 0000000000..ed2b606c00
--- /dev/null
+++ b/meta/recipes-graphics/harfbuzz/harfbuzz/Fix-conditional.patch
@@ -0,0 +1,27 @@ 
+From e421613e8f825508afa9a0b54d33085557c37441 Mon Sep 17 00:00:00 2001
+From: Behdad Esfahbod <behdad@behdad.org>
+Date: Wed, 1 Jun 2022 09:07:57 -0600
+Subject: [PATCH] [sbix] Fix conditional
+
+Upstream-Status: Backport [https://github.com/harfbuzz/harfbuzz/commit/e421613e8f825508afa9a0b54d33085557c37441]
+Signed-off-by: Wentao Zhang<Wentao.Zhang@windriver.com>
+---
+ src/hb-ot-color-sbix-table.hh | 2 +-
+ 1 file changed, 1 insertion(+), 1 deletion(-)
+
+diff --git a/src/hb-ot-color-sbix-table.hh b/src/hb-ot-color-sbix-table.hh
+index 6efae43cd..d0e2235fb 100644
+--- a/src/hb-ot-color-sbix-table.hh
++++ b/src/hb-ot-color-sbix-table.hh
+@@ -298,7 +298,7 @@ struct sbix
+ 
+       const PNGHeader &png = *blob->as<PNGHeader>();
+ 
+-      if (png.IHDR.height >= 65536 | png.IHDR.width >= 65536)
++      if (png.IHDR.height >= 65536 || png.IHDR.width >= 65536)
+       {
+ 	hb_blob_destroy (blob);
+ 	return false;
+-- 
+2.34.1
+
diff --git a/meta/recipes-graphics/harfbuzz/harfbuzz_4.0.1.bb b/meta/recipes-graphics/harfbuzz/harfbuzz_4.0.1.bb
index 81518a53ea..54ac194eae 100644
--- a/meta/recipes-graphics/harfbuzz/harfbuzz_4.0.1.bb
+++ b/meta/recipes-graphics/harfbuzz/harfbuzz_4.0.1.bb
@@ -12,7 +12,8 @@  UPSTREAM_CHECK_URI = "https://github.com/${BPN}/${BPN}/releases"
 UPSTREAM_CHECK_REGEX = "harfbuzz-(?P<pver>\d+(\.\d+)+).tar"
 
 SRC_URI = "https://github.com/${BPN}/${BPN}/releases/download/${PV}/${BPN}-${PV}.tar.xz\
-           file://CVE-2022-33068.patch"
+           file://CVE-2022-33068.patch\
+	   file://Fix-conditional.patch"
 SRC_URI[sha256sum] = "98f68777272db6cd7a3d5152bac75083cd52a26176d87bc04c8b3929d33bce49"
 
 inherit meson pkgconfig lib_package gtk-doc gobject-introspection