diff mbox series

[meta-python,07/30] python3-bitstring: upgrade 4.1.4 -> 4.2.1

Message ID 20240502144829.241208-7-wangmy@fujitsu.com
State Accepted
Headers show
Series [meta-networking,01/30] fping: upgrade 5.1 -> 5.2 | expand

Commit Message

Mingyu Wang (Fujitsu) May 2, 2024, 2:48 p.m. UTC
From: Wang Mingyu <wangmy@fujitsu.com>

License-UPdate:
 format of LICENSE updated to "ASCII text, with CRLF line terminators"

Changelog:
==========
- Module crashes on import with 32-bit Python.
- Lists of integers not converted to bytes when using the bytes constructor.
- Empty comma separated tokens not handled correctly.
- Crash on import when docstrings not present due to optimize flag.
- Dropped support for Python 3.7. Minimum version is now 3.8.
- For tokens that use a non-numeric length, a ':' is now compulsory rather than
  recommended. For example use 'uint:foo' instead of 'uintfoo'.
- The previous e4m3float and e5m2float formats have become the slightly modified
  p4binary8 and p3binary8 formats.
- Some parameters are now enforced as positional only, such as auto in constructors.

Signed-off-by: Wang Mingyu <wangmy@fujitsu.com>
---
 ...{python3-bitstring_4.1.4.bb => python3-bitstring_4.2.1.bb} | 4 ++--
 1 file changed, 2 insertions(+), 2 deletions(-)
 rename meta-python/recipes-devtools/python/{python3-bitstring_4.1.4.bb => python3-bitstring_4.2.1.bb} (68%)
diff mbox series

Patch

diff --git a/meta-python/recipes-devtools/python/python3-bitstring_4.1.4.bb b/meta-python/recipes-devtools/python/python3-bitstring_4.2.1.bb
similarity index 68%
rename from meta-python/recipes-devtools/python/python3-bitstring_4.1.4.bb
rename to meta-python/recipes-devtools/python/python3-bitstring_4.2.1.bb
index 0777b6cff..8485e2e8f 100644
--- a/meta-python/recipes-devtools/python/python3-bitstring_4.1.4.bb
+++ b/meta-python/recipes-devtools/python/python3-bitstring_4.2.1.bb
@@ -1,9 +1,9 @@ 
 SUMMARY = "Simple construction, analysis and modification of binary data."
 HOMEPAGE = "https://github.com/scott-griffiths/bitstring"
 LICENSE = "MIT"
-LIC_FILES_CHKSUM = "file://LICENSE;md5=661f450e2c0aef39b4b15597333444a7"
+LIC_FILES_CHKSUM = "file://LICENSE;md5=f7f2fd3f1cd52b5ccd39d76fb3568d3f"
 
-SRC_URI[sha256sum] = "94f3f1c45383ebe8fd4a359424ffeb75c2f290760ae8fcac421b44f89ac85213"
+SRC_URI[sha256sum] = "8abb5a661588c764bacf1a23d64c7bb57517d2841e3e6f54fb8c057119e0540d"
 
 PYPI_PACKAGE = "bitstring"