diff mbox series

[meta-oe,25/30] qcbor: upgrade 1.2 -> 1.3

Message ID 20240502144829.241208-25-wangmy@fujitsu.com
State Accepted
Headers show
Series [meta-networking,01/30] fping: upgrade 5.1 -> 5.2 | expand

Commit Message

Mingyu Wang (Fujitsu) May 2, 2024, 2:48 p.m. UTC
From: Wang Mingyu <wangmy@fujitsu.com>

License-Update: Update the LICENSE file from README.md to LICENSE

Changelog:
==========
- Floating-point conversion between half, single and double-precision for
  subnormal values and NaN payloads is completed. These are relatively obscure
  unused parts of IEEE754 floats.
- QCBOREncode_GetErrorState() can now be called after QCBOREncode_Finish() and
  it will always return the correct error.
- User-defined error codes are now supported. The error state can be set with
  the new function QCBORDecode_SetError().
- Fixed a rare condition where QCBORDecode_ VGetNext() would not set the
  Item.uDataType to QCBOR_TYPE_NONE on error.
- Function naming changed to better avoid name collision. This includes internal
  functions. This is to compensate for C not having name spaces like C++.
- Documentation correctly describes mixing of traversal cursor used by GetNext
  with fetch by label in entered maps
- Some increase in test coverage
- A bunch of "TODO:" items were addressed. Most result in no change to the code,
  just changes to documentation and test coverage.

Signed-off-by: Wang Mingyu <wangmy@fujitsu.com>
---
 .../recipes-extended/qcbor/{qcbor_git.bb => qcbor_1.3.bb}   | 6 ++----
 1 file changed, 2 insertions(+), 4 deletions(-)
 rename meta-oe/recipes-extended/qcbor/{qcbor_git.bb => qcbor_1.3.bb} (79%)
diff mbox series

Patch

diff --git a/meta-oe/recipes-extended/qcbor/qcbor_git.bb b/meta-oe/recipes-extended/qcbor/qcbor_1.3.bb
similarity index 79%
rename from meta-oe/recipes-extended/qcbor/qcbor_git.bb
rename to meta-oe/recipes-extended/qcbor/qcbor_1.3.bb
index a87454fa9..f90e814f7 100644
--- a/meta-oe/recipes-extended/qcbor/qcbor_git.bb
+++ b/meta-oe/recipes-extended/qcbor/qcbor_1.3.bb
@@ -6,13 +6,11 @@  DESCRIPTION = " \
 HOMEPAGE = "https://github.com/laurencelundblade/QCBOR"
 
 LICENSE = "BSD-3-Clause"
-LIC_FILES_CHKSUM = "file://README.md;beginline=442;endline=463;md5=b55643261d6d221dac2b7a395105af62"
+LIC_FILES_CHKSUM = "file://LICENSE;md5=498c298542365dfcfe29948c72a5849b"
 
 SRC_URI = "git://github.com/laurencelundblade/QCBOR;protocol=https;branch=master"
 
-SRCREV = "44754f738c6534a4304a83d4c6e97b3d3193d887"
-
-PV = "1.2+git"
+SRCREV = "1eba85dbbe78fc1938f8aba2112ba1b228caed30"
 
 S = "${WORKDIR}/git"