[meta-oe,2/2] python3-pytest-xdist: add 2.5.0

Message ID 20220215194931.1716-2-jsbronder@cold-front.org
State New
Headers show
Series [meta-oe,1/2] python3-pytest-forked: add 1.4.0 | expand

Commit Message

Justin Bronder Feb. 15, 2022, 7:49 p.m. UTC
Adding a pytest plugin that enables distributed testing and loop-on-failing modes.

Signed-off-by: Justin Bronder <jsbronder@cold-front.org>
---
 .../python/python3-pytest-xdist_2.5.0.bb        | 17 +++++++++++++++++
 1 file changed, 17 insertions(+)
 create mode 100644 meta-python/recipes-devtools/python/python3-pytest-xdist_2.5.0.bb

Patch

diff --git a/meta-python/recipes-devtools/python/python3-pytest-xdist_2.5.0.bb b/meta-python/recipes-devtools/python/python3-pytest-xdist_2.5.0.bb
new file mode 100644
index 0000000000..a10ac8cc49
--- /dev/null
+++ b/meta-python/recipes-devtools/python/python3-pytest-xdist_2.5.0.bb
@@ -0,0 +1,17 @@ 
+SUMMARY = "pytest xdist plugin for distributed testing and loop-on-failing modes"
+HOMEPAGE = "https://github.com/pytest-dev/pytest-xdist"
+LICENSE = "MIT"
+LIC_FILES_CHKSUM = "file://LICENSE;md5=772fcdaca14b378878d05c7d857e6c3e"
+
+SRC_URI[sha256sum] = "4580deca3ff04ddb2ac53eba39d76cb5dd5edeac050cb6fbc768b0dd712b4edf"
+
+inherit pypi setuptools3
+
+DEPENDS += "python3-setuptools-scm-native"
+
+# Note that the dependency on pytest-forked is scheduled to be dropped in 3.0
+RDEPENDS:${PN} += " \
+    python3-execnet \
+    python3-pytest \
+    python3-pytest-forked \
+"