[meta-oe,1/2] python3-pytest-forked: add 1.4.0

Message ID 20220215194931.1716-1-jsbronder@cold-front.org
State New
Headers show
Series [meta-oe,1/2] python3-pytest-forked: add 1.4.0 | expand

Commit Message

Justin Bronder Feb. 15, 2022, 7:49 p.m. UTC
Adding as a dependency of python3-pytest-xdist (which allows parallel
execution of pytest test cases).

Signed-off-by: Justin Bronder <jsbronder@cold-front.org>
---
 .../python/python3-pytest-forked_1.4.0.bb         | 15 +++++++++++++++
 1 file changed, 15 insertions(+)
 create mode 100644 meta-python/recipes-devtools/python/python3-pytest-forked_1.4.0.bb

Patch

diff --git a/meta-python/recipes-devtools/python/python3-pytest-forked_1.4.0.bb b/meta-python/recipes-devtools/python/python3-pytest-forked_1.4.0.bb
new file mode 100644
index 0000000000..c6f352bc61
--- /dev/null
+++ b/meta-python/recipes-devtools/python/python3-pytest-forked_1.4.0.bb
@@ -0,0 +1,15 @@ 
+SUMMARY = "run tests in isolated forked subprocesses"
+HOMEPAGE = "https://github.com/pytest-dev/pytest-forked"
+LICENSE = "MIT"
+LIC_FILES_CHKSUM = "file://LICENSE;md5=772fcdaca14b378878d05c7d857e6c3e"
+
+SRC_URI[sha256sum] = "8b67587c8f98cbbadfdd804539ed5455b6ed03802203485dd2f53c1422d7440e"
+
+inherit pypi setuptools3
+
+DEPENDS += "python3-setuptools-scm-native"
+
+RDEPENDS:${PN} += " \
+    python3-py \
+    python3-pytest \
+"