diff mbox series

[5/5] python3-sphinxcontrib-serializinghtml: 1.1.5 -> 1.1.9

Message ID d7cde0f2fe2b261016393b111d11219c6c5099fe.1700670471.git.tim.orling@konsulko.com
State Accepted, archived
Commit 38e035e1165a7d58a7de8b129b3f9e4a9faa275f
Headers show
Series [1/5] python3-sphinxcontrib-applehelp: 1.0.4 -> 1.0.7 | expand

Commit Message

Tim Orling Nov. 22, 2023, 4:37 p.m. UTC
* Upstream download filename changed from sphinxcontrib-serializinghtml*
  to sphinxcontrib_serializinghtml*
* build-backend is now flit (inherit python_flit_core)

Release 1.1.9 (2023-08-20)
==========================

* Serialise context["script_files"] and context["css_files"] as their filenames
  on Sphinx 7.2.0.

  Release 1.1.8 (2023-08-14)
  ==========================

  * Use ``os.PathLike`` over ``pathlib.Path``

  Release 1.1.7 (2023-08-09)
  ==========================

  * Fix tests for Sphinx 7.1 and below

  Release 1.1.6 (2023-08-07)
  ==========================

  * Drop support for Python 3.5, 3.6, 3.7, and 3.8
  * Raise minimum required Sphinx version to 5.0

https://github.com/sphinx-doc/sphinxcontrib-serializinghtml/compare/1.1.5...1.1.9

Signed-off-by: Tim Orling <tim.orling@konsulko.com>
---
 ...5.bb => python3-sphinxcontrib-serializinghtml_1.1.9.bb} | 7 +++++--
 1 file changed, 5 insertions(+), 2 deletions(-)
 rename meta/recipes-devtools/python/{python3-sphinxcontrib-serializinghtml_1.1.5.bb => python3-sphinxcontrib-serializinghtml_1.1.9.bb} (57%)
diff mbox series

Patch

diff --git a/meta/recipes-devtools/python/python3-sphinxcontrib-serializinghtml_1.1.5.bb b/meta/recipes-devtools/python/python3-sphinxcontrib-serializinghtml_1.1.9.bb
similarity index 57%
rename from meta/recipes-devtools/python/python3-sphinxcontrib-serializinghtml_1.1.5.bb
rename to meta/recipes-devtools/python/python3-sphinxcontrib-serializinghtml_1.1.9.bb
index 7fa6d8aeb7a..fbf0c3c9b28 100644
--- a/meta/recipes-devtools/python/python3-sphinxcontrib-serializinghtml_1.1.5.bb
+++ b/meta/recipes-devtools/python/python3-sphinxcontrib-serializinghtml_1.1.9.bb
@@ -3,10 +3,13 @@  HOMEPAGE = "https://www.sphinx-doc.org"
 LICENSE = "BSD-2-Clause"
 LIC_FILES_CHKSUM = "file://LICENSE;md5=32a84ac5cd3bbd10c4d479233ad588b6"
 
-SRC_URI[sha256sum] = "aa5f6de5dfdf809ef505c4895e51ef5c9eac17d0f287933eb49ec495280b6952"
+SRC_URI[sha256sum] = "0c64ff898339e1fac29abd2bf5f11078f3ec413cfe9c046d3120d7ca65530b54"
 
 PYPI_PACKAGE = "sphinxcontrib-serializinghtml"
 
-inherit pypi setuptools3
+inherit pypi python_flit_core
+
+PYPI_ARCHIVE_NAME = "sphinxcontrib_serializinghtml-${PV}.${PYPI_PACKAGE_EXT}"
+S = "${WORKDIR}/sphinxcontrib_serializinghtml-${PV}"
 
 BBCLASSEXTEND = "native nativesdk"