diff mbox series

[2/5] python3-sphinxcontrib-devhelp: 1.0.2 -> 1.0.5

Message ID 235901b0deab3e7a47475bcad3efd095774b8a3c.1700670471.git.tim.orling@konsulko.com
State Accepted, archived
Commit 2dfca75f697faafa84e896a2aae67071b8401ce6
Headers show
Series [1/5] python3-sphinxcontrib-applehelp: 1.0.4 -> 1.0.7 | expand

Commit Message

Tim Orling Nov. 22, 2023, 4:37 p.m. UTC
* Upstream download filename changed from sphinxcontrib-devhelp*
  to sphinxcontrib_devhelp*
* build-backend is now flit (inherit python_flit_core)

Release 1.0.5 (2023-08-14)
==========================

* Use ``os.PathLike`` over ``pathlib.Path``

Release 1.0.4 (2023-08-09)
==========================

* Fix tests for Sphinx 7.1 and below

Release 1.0.3 (2023-08-07)
=========================

* Drop support for Python 3.5, 3.6, 3.7, and 3.8
* Raise minimum required Sphinx version to 5.0

https://github.com/sphinx-doc/sphinxcontrib-devhelp/compare/1.0.2...1.0.5

Signed-off-by: Tim Orling <tim.orling@konsulko.com>
---
 ...elp_1.0.2.bb => python3-sphinxcontrib-devhelp_1.0.5.bb} | 7 +++++--
 1 file changed, 5 insertions(+), 2 deletions(-)
 rename meta/recipes-devtools/python/{python3-sphinxcontrib-devhelp_1.0.2.bb => python3-sphinxcontrib-devhelp_1.0.5.bb} (56%)
diff mbox series

Patch

diff --git a/meta/recipes-devtools/python/python3-sphinxcontrib-devhelp_1.0.2.bb b/meta/recipes-devtools/python/python3-sphinxcontrib-devhelp_1.0.5.bb
similarity index 56%
rename from meta/recipes-devtools/python/python3-sphinxcontrib-devhelp_1.0.2.bb
rename to meta/recipes-devtools/python/python3-sphinxcontrib-devhelp_1.0.5.bb
index 0d034366e7a..47934bd6f53 100644
--- a/meta/recipes-devtools/python/python3-sphinxcontrib-devhelp_1.0.2.bb
+++ b/meta/recipes-devtools/python/python3-sphinxcontrib-devhelp_1.0.5.bb
@@ -3,10 +3,13 @@  HOMEPAGE = "https://www.sphinx-doc.org"
 LICENSE = "BSD-2-Clause"
 LIC_FILES_CHKSUM = "file://LICENSE;md5=fd30d9972a142c857a80c9f312e92b93"
 
-SRC_URI[sha256sum] = "ff7f1afa7b9642e7060379360a67e9c41e8f3121f2ce9164266f61b9f4b338e4"
+SRC_URI[sha256sum] = "63b41e0d38207ca40ebbeabcf4d8e51f76c03e78cd61abe118cf4435c73d4212"
 
 PYPI_PACKAGE = "sphinxcontrib-devhelp"
 
-inherit pypi setuptools3
+inherit pypi python_flit_core
+
+PYPI_ARCHIVE_NAME = "sphinxcontrib_devhelp-${PV}.${PYPI_PACKAGE_EXT}"
+S = "${WORKDIR}/sphinxcontrib_devhelp-${PV}"
 
 BBCLASSEXTEND = "native nativesdk"