diff mbox series

[2/4] zip: remove unnecessary LARGE_FILE_SUPPORT CLFAGS

Message ID 20230619043556.3432048-2-Qi.Chen@windriver.com
State Accepted, archived
Commit 601f45bc4e6c563ebf16e724d56519a128815034
Headers show
Series [1/4] zip: fix configure check by using _Static_assert | expand

Commit Message

ChenQi June 19, 2023, 4:35 a.m. UTC
From: Chen Qi <Qi.Chen@windriver.com>

As the zip's configure has been updated to use compile-time
check, it now can do the check correctly, thus no need to
pass LARGE_FILE_SUPPORT to CFLAGS.

Signed-off-by: Chen Qi <Qi.Chen@windriver.com>
---
 meta/recipes-extended/zip/zip_3.0.bb | 3 ---
 1 file changed, 3 deletions(-)
diff mbox series

Patch

diff --git a/meta/recipes-extended/zip/zip_3.0.bb b/meta/recipes-extended/zip/zip_3.0.bb
index 802877285f..82153131b4 100644
--- a/meta/recipes-extended/zip/zip_3.0.bb
+++ b/meta/recipes-extended/zip/zip_3.0.bb
@@ -32,9 +32,6 @@  CVE_CHECK_IGNORE += "CVE-2018-13410"
 # Not for zip but for smart contract implementation for it
 CVE_CHECK_IGNORE += "CVE-2018-13684"
 
-# Enable largefile support
-CFLAGS += "-DLARGE_FILE_SUPPORT"
-
 # zip.inc sets CFLAGS, but what Makefile actually uses is
 # CFLAGS_NOOPT.  It will also force -O3 optimization, overriding
 # whatever we set.