[06/61] libnl: upgrade 3.5.0 -> 3.6.0

Message ID 20220505050544.651895-6-alex@linutronix.de
State Accepted, archived
Commit 09bdeeabf03b6ca1c5410dc7573571554cf172ce
Headers show
Series [01/61] sato: work around missing icons in adwaita 42.0 | expand

Commit Message

Alexander Kanavin May 5, 2022, 5:04 a.m. UTC
Signed-off-by: Alexander Kanavin <alex@linutronix.de>
---
 ...97f8982544c4fcb403893bae6701230d5165.patch | 48 +++++++++++++++++++
 .../libnl/{libnl_3.5.0.bb => libnl_3.6.0.bb}  |  7 ++-
 2 files changed, 53 insertions(+), 2 deletions(-)
 create mode 100644 meta/recipes-support/libnl/files/fa7f97f8982544c4fcb403893bae6701230d5165.patch
 rename meta/recipes-support/libnl/{libnl_3.5.0.bb => libnl_3.6.0.bb} (90%)

Patch

diff --git a/meta/recipes-support/libnl/files/fa7f97f8982544c4fcb403893bae6701230d5165.patch b/meta/recipes-support/libnl/files/fa7f97f8982544c4fcb403893bae6701230d5165.patch
new file mode 100644
index 0000000000..02662c939e
--- /dev/null
+++ b/meta/recipes-support/libnl/files/fa7f97f8982544c4fcb403893bae6701230d5165.patch
@@ -0,0 +1,48 @@ 
+From fa7f97f8982544c4fcb403893bae6701230d5165 Mon Sep 17 00:00:00 2001
+From: Thomas Haller <thaller@redhat.com>
+Date: Fri, 15 Apr 2022 13:29:49 +0200
+Subject: [PATCH] build: avoid building check-direct with --disable-static
+
+"check-direct" needs to statically link with the libraries, because
+it wants to test internal ABI, which is hidden in the share libraries.
+When configuring with "--disable-static", static libs are not build
+and the test tool cannot be build.
+
+Just skip the test in that case.
+
+https://github.com/thom311/libnl/issues/306
+Upstream-Status: Backport [https://github.com/thom311/libnl/commit/fa7f97f8982544c4fcb403893bae6701230d5165]
+Signed-off-by: Alexander Kanavin <alex@linutronix.de>
+---
+ Makefile.am  | 2 ++
+ configure.ac | 2 ++
+ 2 files changed, 4 insertions(+)
+
+diff --git a/Makefile.am b/Makefile.am
+index a6bcf553..2f5e0dfc 100644
+--- a/Makefile.am
++++ b/Makefile.am
+@@ -984,8 +984,10 @@ tests_check_all_LDADD = \
+ 	$(NULL)
+ 
+ if WITH_CHECK
++if ENABLE_STATIC
+ check_programs += tests/check-direct
+ endif
++endif
+ 
+ tests_check_direct_SOURCES = \
+ 	tests/check-direct.c \
+diff --git a/configure.ac b/configure.ac
+index 1f9ad0eb..0fd1cc0f 100644
+--- a/configure.ac
++++ b/configure.ac
+@@ -107,6 +107,8 @@ else
+     AC_CHECK_LIB([pthread], [pthread_mutex_lock], [], AC_MSG_ERROR([libpthread is required]))
+ fi
+ 
++AM_CONDITIONAL([ENABLE_STATIC], [test "$enable_static" != "no"])
++
+ AC_ARG_ENABLE([debug],
+ 	AS_HELP_STRING([--disable-debug], [Do not include debugging statements]),
+ 	[enable_debug="$enableval"], [enable_debug="yes"])
diff --git a/meta/recipes-support/libnl/libnl_3.5.0.bb b/meta/recipes-support/libnl/libnl_3.6.0.bb
similarity index 90%
rename from meta/recipes-support/libnl/libnl_3.5.0.bb
rename to meta/recipes-support/libnl/libnl_3.6.0.bb
index 41d7a9aed8..af3aa41040 100644
--- a/meta/recipes-support/libnl/libnl_3.5.0.bb
+++ b/meta/recipes-support/libnl/libnl_3.6.0.bb
@@ -18,10 +18,10 @@  SRC_URI = " \
            https://github.com/thom311/${BPN}/releases/download/${BPN}${@d.getVar('PV').replace('.','_')}/${BP}.tar.gz \
            file://enable-serial-tests.patch \
            file://run-ptest \
+           file://fa7f97f8982544c4fcb403893bae6701230d5165.patch \
           "
 
-SRC_URI[md5sum] = "74ba57b1b1d6f9f92268aa8141d8e8e4"
-SRC_URI[sha256sum] = "352133ec9545da76f77e70ccb48c9d7e5324d67f6474744647a7ed382b5e05fa"
+SRC_URI[sha256sum] = "532155fd011e5a805bd67121b87a01c757e2bb24112ac17e69cb86013b970009"
 
 
 UPSTREAM_CHECK_URI = "https://github.com/thom311/${BPN}/releases"
@@ -54,6 +54,7 @@  RREPLACES:${PN}-genl = "libnl-genl2"
 RCONFLICTS:${PN}-genl = "libnl-genl2"
 
 RDEPENDS:${PN}-ptest += "libcheck"
+RRECOMMENDS:${PN}-ptest += "kernel-module-dummy kernel-module-bonding"
 DEPENDS += "${@bb.utils.contains('PTEST_ENABLED', '1', 'libcheck', '', d)}"
 
 # make sure the tests don't link against wrong so file
@@ -70,6 +71,8 @@  do_install_ptest(){
     # upstream are not running these tests in their CI pipeline
     # issue opened https://github.com/thom311/libnl/issues/270
     install -m 0755 tests/.libs/* ${D}${PTEST_PATH}/
+    # contains build paths
+    rm ${D}${PTEST_PATH}/*.la
 }
 
 BBCLASSEXTEND = "native nativesdk"