[49/61] pciutils: update 3.7.0 -> 3.8.0

Message ID 20220505050544.651895-49-alex@linutronix.de
State Accepted, archived
Commit 8b35bad89eafd51d49438725e781450d7907d0f2
Headers show
Series [01/61] sato: work around missing icons in adwaita 42.0 | expand

Commit Message

Alexander Kanavin May 5, 2022, 5:05 a.m. UTC
Rebase configure.patch

Drop symlink creation; make install already does it.

Signed-off-by: Alexander Kanavin <alex@linutronix.de>
---
 .../pciutils/pciutils/configure.patch         | 46 +++++++++++--------
 .../{pciutils_3.7.0.bb => pciutils_3.8.0.bb}  |  3 +-
 2 files changed, 29 insertions(+), 20 deletions(-)
 rename meta/recipes-bsp/pciutils/{pciutils_3.7.0.bb => pciutils_3.8.0.bb} (93%)

Patch

diff --git a/meta/recipes-bsp/pciutils/pciutils/configure.patch b/meta/recipes-bsp/pciutils/pciutils/configure.patch
index e444c13975..cf55b94808 100644
--- a/meta/recipes-bsp/pciutils/pciutils/configure.patch
+++ b/meta/recipes-bsp/pciutils/pciutils/configure.patch
@@ -1,9 +1,14 @@ 
+From 502c01e180d9085fcbeaf2fb46239999c4f335d2 Mon Sep 17 00:00:00 2001
+From: Richard Purdie <rpurdie@linux.intel.com>
+Date: Wed, 31 Dec 2008 17:20:38 +0000
+Subject: [PATCH] pciutils: Upgarde 2.2.4 -> 3.0.3
+
 This patch:
 * ensures we link correctly
 * allows us to optionally pass target information to configure rather than using uname
 * select linux as the platform in most cases we care about
 
-This is a merge of various tweaks to allow us to build pciutils including 
+This is a merge of various tweaks to allow us to build pciutils including
 work from:
 
 7/30/2010 - Qing He <qing.he@intel.com>
@@ -13,23 +18,28 @@  Ionut Radu <ionutx.radu@intel.com>
 
 Upstream-Status: Inappropriate [embedded specific]
 
-Index: pciutils-3.5.6/Makefile
-===================================================================
---- pciutils-3.5.6.orig/Makefile
-+++ pciutils-3.5.6/Makefile
-@@ -96,7 +96,7 @@ example: example.o lib/$(PCILIB)
+---
+ Makefile      |  2 +-
+ lib/configure | 14 ++++++++++----
+ 2 files changed, 11 insertions(+), 5 deletions(-)
+
+diff --git a/Makefile b/Makefile
+index 9319bb4..78a2d54 100644
+--- a/Makefile
++++ b/Makefile
+@@ -108,7 +108,7 @@ example$(EXEEXT): example.o lib/$(PCILIB)
  example.o: example.c $(PCIINC)
  
- %: %.o
+ %$(EXEEXT): %.o
 -	$(CC) $(LDFLAGS) $(TARGET_ARCH) $^ $(LDLIBS) -o $@
 +	$(CC) $(LDFLAGS) $(TARGET_ARCH) $^ $(LIB_LDLIBS) $(LDLIBS) -o $@
  
  %.8 %.7 %.5: %.man
- 	M=`echo $(DATE) | sed 's/-01-/-January-/;s/-02-/-February-/;s/-03-/-March-/;s/-04-/-April-/;s/-05-/-May-/;s/-06-/-June-/;s/-07-/-July-/;s/-08-/-August-/;s/-09-/-September-/;s/-10-/-October-/;s/-11-/-November-/;s/-12-/-December-/;s/\(.*\)-\(.*\)-\(.*\)/\3 \2 \1/'` ; sed <$< >$@ "s/@TODAY@/$$M/;s/@VERSION@/pciutils-$(VERSION)/;s#@IDSDIR@#$(IDSDIR)#"
-Index: pciutils-3.5.6/lib/configure
-===================================================================
---- pciutils-3.5.6.orig/lib/configure
-+++ pciutils-3.5.6/lib/configure
+ 	M=`echo $(DATE) | sed 's/-01-/-January-/;s/-02-/-February-/;s/-03-/-March-/;s/-04-/-April-/;s/-05-/-May-/;s/-06-/-June-/;s/-07-/-July-/;s/-08-/-August-/;s/-09-/-September-/;s/-10-/-October-/;s/-11-/-November-/;s/-12-/-December-/;s/\(.*\)-\(.*\)-\(.*\)/\3 \2 \1/'` ; sed <$< >$@ "s/@TODAY@/$$M/;s/@VERSION@/pciutils-$(VERSION)/;s#@IDSDIR@#$(IDSDIR)#;s#@PCI_IDS@#$(PCI_IDS)#"
+diff --git a/lib/configure b/lib/configure
+index 45a416a..1afdaa6 100755
+--- a/lib/configure
++++ b/lib/configure
 @@ -9,6 +9,10 @@ echo_n() {
  	printf '%s' "$*"
  }
@@ -38,7 +48,7 @@  Index: pciutils-3.5.6/lib/configure
 +IDSDIR=$2
 +DNS=yes
 +
- if [ -z "$VERSION" -o -z "$IDSDIR" ] ; then
+ if [ -z "$VERSION" ] ; then
  	echo >&2 "Please run the configure script from the top-level Makefile"
  	exit 1
 @@ -16,8 +20,8 @@ fi
@@ -56,12 +66,12 @@  Index: pciutils-3.5.6/lib/configure
  		proc=`/usr/sbin/lsdev -C -c processor -S available -F name | head -1`
  		cpu=`/usr/sbin/lsattr -F value -l $proc -a type | sed 's/_.*//'`
  	else
--		cpu=`uname -m | sed 's/^i.86$/i386/;s/^sun4u$/sparc64/;s/^i86pc$/i386/;s/^BePC$/i386/;s/^BeMac$/powerpc/;s/^BeBox$/powerpc/'`
-+		cpu=${4:-`uname -m | sed 's/^i.86$/i386/;s/^sun4u$/sparc64/;s/^i86pc$/i386/;s/^BePC$/i386/;s/^BeMac$/powerpc/;s/^BeBox$/powerpc/'`}
+-		cpu=`uname -m | sed 's/^i.86-AT386/i386/;s/^i.86$/i386/;s/^sun4u$/sparc64/;s/^i86pc$/i386/;s/^BePC$/i386/;s/^BeMac$/powerpc/;s/^BeBox$/powerpc/'`
++		cpu=${4:-`uname -m | sed 's/^i.86-AT386/i386/;s/^i.86$/i386/;s/^sun4u$/sparc64/;s/^i86pc$/i386/;s/^BePC$/i386/;s/^BeMac$/powerpc/;s/^BeBox$/powerpc/'`}
  	fi
- 	if [ "$sys" = "GNU/kFreeBSD" -o "$sys" = "DragonFly" ]
+ 	if [ "$sys" = "DragonFly" ]
  	then
-@@ -35,7 +39,7 @@ if [ -z "$HOST" ] ; then
+@@ -43,7 +47,7 @@ if [ -z "$HOST" ] ; then
  	then
  		sys=cygwin
  	fi
@@ -70,7 +80,7 @@  Index: pciutils-3.5.6/lib/configure
  fi
  [ -n "$RELEASE" ] && rel="${RELEASE}"
  # CAVEAT: tr on Solaris is a bit weird and the extra [] is otherwise harmless.
-@@ -44,6 +48,8 @@ cpu=`echo $host | sed 's/^\([^-]*\)-\([^-]*\)-\(.*\)$/\1/'`
+@@ -52,6 +56,8 @@ cpu=`echo $host | sed 's/^\([^-]*\)-\([^-]*\)-\(.*\)$/\1/'`
  sys=`echo $host | sed 's/^\([^-]*\)-\([^-]*\)-\(.*\)$/\3/'`
  echo " $host $rel $cpu $sys"
  
diff --git a/meta/recipes-bsp/pciutils/pciutils_3.7.0.bb b/meta/recipes-bsp/pciutils/pciutils_3.8.0.bb
similarity index 93%
rename from meta/recipes-bsp/pciutils/pciutils_3.7.0.bb
rename to meta/recipes-bsp/pciutils/pciutils_3.8.0.bb
index 7d1740f665..8455b286a8 100644
--- a/meta/recipes-bsp/pciutils/pciutils_3.7.0.bb
+++ b/meta/recipes-bsp/pciutils/pciutils_3.8.0.bb
@@ -11,7 +11,7 @@  DEPENDS = "zlib kmod"
 SRC_URI = "${KERNELORG_MIRROR}/software/utils/pciutils/pciutils-${PV}.tar.xz \
            file://configure.patch"
 
-SRC_URI[sha256sum] = "9d40b97be8b6a2cdf96aead5a61881d1f7e4e0da9544a9bac4fba1ae9dcd40eb"
+SRC_URI[sha256sum] = "91edbd0429a84705c9ad156d4ff38ccc724d41ea54c4c5b88e38e996f8a34f05"
 
 inherit multilib_header pkgconfig
 
@@ -46,7 +46,6 @@  do_install () {
 	oe_runmake DESTDIR=${D} install install-lib
 
 	install -d ${D}${bindir}
-	ln -s ../sbin/lspci ${D}${bindir}/lspci
 
 	oe_multilib_header pci/config.h
 }