[13/26] python3-urllib3: Add from meta-oe/meta-python

Message ID 20220317115700.993924-14-richard.purdie@linuxfoundation.org
State Accepted, archived
Commit cc339666f2324a68e4e1b131e5bcb442ce72a755
Headers show
Series Add support for sphinx documentation generation | expand

Commit Message

Richard Purdie March 17, 2022, 11:56 a.m. UTC
---
 .../python/python3-urllib3_1.26.8.bb          | 22 +++++++++++++++++++
 1 file changed, 22 insertions(+)
 create mode 100644 meta/recipes-devtools/python/python3-urllib3_1.26.8.bb

Patch

diff --git a/meta/recipes-devtools/python/python3-urllib3_1.26.8.bb b/meta/recipes-devtools/python/python3-urllib3_1.26.8.bb
new file mode 100644
index 00000000000..c2a51b91485
--- /dev/null
+++ b/meta/recipes-devtools/python/python3-urllib3_1.26.8.bb
@@ -0,0 +1,22 @@ 
+SUMMARY = "Python HTTP library with thread-safe connection pooling, file post support, sanity friendly, and more"
+HOMEPAGE = "https://github.com/shazow/urllib3"
+LICENSE = "MIT"
+LIC_FILES_CHKSUM = "file://LICENSE.txt;md5=c2823cb995439c984fd62a973d79815c"
+
+SRC_URI[sha256sum] = "0e7c33d9a63e7ddfcb86780aac87befc2fbddf46c58dbb487e0855f7ceec283c"
+
+inherit pypi setuptools3
+
+RDEPENDS:${PN} += "\
+    ${PYTHON_PN}-certifi \
+    ${PYTHON_PN}-cryptography \
+    ${PYTHON_PN}-email \
+    ${PYTHON_PN}-idna \
+    ${PYTHON_PN}-netclient \
+    ${PYTHON_PN}-pyopenssl \
+    ${PYTHON_PN}-threading \
+"
+
+CVE_PRODUCT = "urllib3"
+
+BBCLASSEXTEND = "native nativesdk"