[12/26] python3-requests: Add from meta-oe/meta-python

Message ID 20220317115700.993924-13-richard.purdie@linuxfoundation.org
State Accepted, archived
Commit 5971e3540763f628918992919315ec49b016c02e
Headers show
Series Add support for sphinx documentation generation | expand

Commit Message

Richard Purdie March 17, 2022, 11:56 a.m. UTC
---
 .../python/python3-requests_2.27.1.bb         | 25 +++++++++++++++++++
 1 file changed, 25 insertions(+)
 create mode 100644 meta/recipes-devtools/python/python3-requests_2.27.1.bb

Patch

diff --git a/meta/recipes-devtools/python/python3-requests_2.27.1.bb b/meta/recipes-devtools/python/python3-requests_2.27.1.bb
new file mode 100644
index 00000000000..af52b7caf5a
--- /dev/null
+++ b/meta/recipes-devtools/python/python3-requests_2.27.1.bb
@@ -0,0 +1,25 @@ 
+DESCRIPTION = "Python HTTP for Humans."
+HOMEPAGE = "http://python-requests.org"
+LICENSE = "Apache-2.0"
+LIC_FILES_CHKSUM = "file://LICENSE;md5=34400b68072d710fecd0a2940a0d1658"
+
+SRC_URI[sha256sum] = "68d7c56fd5a8999887728ef304a6d12edc7be74f1cfa47714fc8b414525c9a61"
+
+inherit pypi setuptools3
+
+RDEPENDS:${PN} += " \
+    ${PYTHON_PN}-email \
+    ${PYTHON_PN}-json \
+    ${PYTHON_PN}-ndg-httpsclient \
+    ${PYTHON_PN}-netserver \
+    ${PYTHON_PN}-pyasn1 \
+    ${PYTHON_PN}-pyopenssl \
+    ${PYTHON_PN}-pysocks \
+    ${PYTHON_PN}-urllib3 \
+    ${PYTHON_PN}-chardet \
+    ${PYTHON_PN}-idna \
+"
+
+CVE_PRODUCT = "requests"
+
+BBCLASSEXTEND = "native nativesdk"