[25/33] poetry_core: Rename to python_poetry_core

Message ID 20220314224837.834776-25-richard.purdie@linuxfoundation.org
State Accepted, archived
Commit 241ebe35afb0ae9cd2713ef19a78746f0ab5ca5d
Headers show
Series [01/33] python3-setuptools-rust-native: from meta-python | expand

Commit Message

Richard Purdie March 14, 2022, 10:48 p.m. UTC
Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
---
 .../{poetry_core.bbclass => python_poetry_core.bbclass}       | 4 ++--
 meta/recipes-devtools/python/python3-iso8601_1.0.2.bb         | 2 +-
 meta/recipes-devtools/python/python3-poetry-core_1.0.8.bb     | 2 +-
 3 files changed, 4 insertions(+), 4 deletions(-)
 rename meta/classes/{poetry_core.bbclass => python_poetry_core.bbclass} (82%)

Patch

diff --git a/meta/classes/poetry_core.bbclass b/meta/classes/python_poetry_core.bbclass
similarity index 82%
rename from meta/classes/poetry_core.bbclass
rename to meta/classes/python_poetry_core.bbclass
index fb37c78c782..a2086b11b6c 100644
--- a/meta/classes/poetry_core.bbclass
+++ b/meta/classes/python_poetry_core.bbclass
@@ -2,12 +2,12 @@  inherit pip_install_wheel python3native setuptools3-base
 
 DEPENDS += "python3-poetry-core-native"
 
-poetry_core_do_configure () {
+python_poetry_core_do_configure () {
     :
 }
 
 # TODO: ideally this uses pypa/build
-poetry_core_do_compile () {
+python_poetry_core_do_compile () {
     nativepython3 -c "from poetry.core.masonry import api; api.build_wheel('${PIP_INSTALL_DIST_PATH}')"
 }
 do_compile[cleandirs] += "${PIP_INSTALL_DIST_PATH}"
diff --git a/meta/recipes-devtools/python/python3-iso8601_1.0.2.bb b/meta/recipes-devtools/python/python3-iso8601_1.0.2.bb
index aabc47d69b9..93af233d296 100644
--- a/meta/recipes-devtools/python/python3-iso8601_1.0.2.bb
+++ b/meta/recipes-devtools/python/python3-iso8601_1.0.2.bb
@@ -5,7 +5,7 @@  LIC_FILES_CHKSUM = "file://LICENSE;md5=b05625f2336fa024e8d57e65c6595844"
 
 SRC_URI[sha256sum] = "27f503220e6845d9db954fb212b95b0362d8b7e6c1b2326a87061c3de93594b1"
 
-inherit pypi poetry_core
+inherit pypi python_poetry_core
 
 RDEPENDS:${PN} += "\
     ${PYTHON_PN}-datetime \
diff --git a/meta/recipes-devtools/python/python3-poetry-core_1.0.8.bb b/meta/recipes-devtools/python/python3-poetry-core_1.0.8.bb
index 22d7076d01b..f3e9b055218 100644
--- a/meta/recipes-devtools/python/python3-poetry-core_1.0.8.bb
+++ b/meta/recipes-devtools/python/python3-poetry-core_1.0.8.bb
@@ -21,7 +21,7 @@  LIC_FILES_CHKSUM = "file://LICENSE;md5=104d5c3c653aeededf4076773aa4c236 \
 
 SRC_URI[sha256sum] = "951fc7c1f8d710a94cb49019ee3742125039fc659675912ea614ac2aa405b118"
 
-inherit poetry_core pypi
+inherit python_poetry_core pypi
 
 RDEPENDS:${PN}:append:class-target = "\
     python3-compression \