[24/33] setuptools3_rust: Rename to python_setuptools3_rust

Message ID 20220314224837.834776-24-richard.purdie@linuxfoundation.org
State Accepted, archived
Commit 57bef31cdcafeef2d1ca5ff3aee7b2e2181a0514
Headers show
Series [01/33] python3-setuptools-rust-native: from meta-python | expand

Commit Message

Richard Purdie March 14, 2022, 10:48 p.m. UTC
Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
---
 ...tuptools3_rust.bbclass => python_setuptools3_rust.bbclass} | 4 ++--
 meta/recipes-devtools/python/python3-cryptography_36.0.1.bb   | 2 +-
 2 files changed, 3 insertions(+), 3 deletions(-)
 rename meta/classes/{setuptools3_rust.bbclass => python_setuptools3_rust.bbclass} (70%)

Patch

diff --git a/meta/classes/setuptools3_rust.bbclass b/meta/classes/python_setuptools3_rust.bbclass
similarity index 70%
rename from meta/classes/setuptools3_rust.bbclass
rename to meta/classes/python_setuptools3_rust.bbclass
index fa8508fbec6..f12e5d0cbd2 100644
--- a/meta/classes/setuptools3_rust.bbclass
+++ b/meta/classes/python_setuptools3_rust.bbclass
@@ -2,8 +2,8 @@  inherit python_pyo3 setuptools3
 
 DEPENDS += "python3-setuptools-rust-native"
 
-setuptools3_rust_do_configure() {
-    pyo3_do_configure
+python_setuptools3_rust_do_configure() {
+    python_pyo3_do_configure
     cargo_common_do_configure
     setuptools3_do_configure
 }
diff --git a/meta/recipes-devtools/python/python3-cryptography_36.0.1.bb b/meta/recipes-devtools/python/python3-cryptography_36.0.1.bb
index 00791dce2de..11466ecece6 100644
--- a/meta/recipes-devtools/python/python3-cryptography_36.0.1.bb
+++ b/meta/recipes-devtools/python/python3-cryptography_36.0.1.bb
@@ -18,7 +18,7 @@  SRC_URI += " \
     file://0002-Cargo.toml-edition-2018-2021.patch \
 "
 
-inherit pypi setuptools3_rust
+inherit pypi python_setuptools3_rust
 
 PIP_INSTALL_DIST_PATH = "${S}/dist"