diff mbox series

[43/48] python3-urllib3: upgrade 2.1.0 -> 2.2.1

Message ID 1709105575-24259-43-git-send-email-wangmy@fujitsu.com
State Accepted, archived
Commit c1968ceeddbad57bc86aaa23a705093c353d3bc9
Headers show
Series [01/48] bash-completion: upgrade 2.11 -> 2.12.0 | expand

Commit Message

Mingyu Wang (Fujitsu) Feb. 28, 2024, 7:32 a.m. UTC
From: Wang Mingyu <wangmy@fujitsu.com>

Changelog:
===========
-Fixed issue where "InsecureRequestWarning" was emitted for HTTPS connections
 when using Emscripten.
-Fixed "HTTPConnectionPool.urlopen" to stop automatically casting non-proxy
 headers to "HTTPHeaderDict".
-Changed "InvalidChunkLength" to "ProtocolError" when response terminates
 before the chunk length is sent.
-Changed "ProtocolError" to be more verbose on incomplete reads with excess
 content.
-Added support for 'Emscripten and Pyodide
-Added support for "HTTPResponse.read1()" method.
-Added rudimentary support for HTTP/2.
-Fixed issue where requests against urls with trailing dots were failing due to
 SSL errors when using proxy.
-Fixed "HTTPConnection.proxy_is_verified" and
 "HTTPSConnection.proxy_is_verified" to be always set to a boolean after
 connecting to a proxy. It could be "None" in some cases previously.
-Fixed an issue where "headers" passed in a request with "json=" would be
 mutated
-Fixed "HTTPSConnection.is_verified" to be set to "False" when connecting
 from a HTTPS proxy to an HTTP target. It was set to "True" previously.
-Fixed handling of new error message from OpenSSL 3.2.0 when configuring an
 HTTP proxy as HTTPS
-Fixed TLS 1.3 post-handshake auth when the server certificate validation is
 disabled
-Note for downstream distributors: To run integration tests, you now need to run
 the tests a second time with the "--integration" pytest flag.

Signed-off-by: Wang Mingyu <wangmy@fujitsu.com>
---
 .../{python3-urllib3_2.1.0.bb => python3-urllib3_2.2.1.bb}      | 2 +-
 1 file changed, 1 insertion(+), 1 deletion(-)
 rename meta/recipes-devtools/python/{python3-urllib3_2.1.0.bb => python3-urllib3_2.2.1.bb} (86%)
diff mbox series

Patch

diff --git a/meta/recipes-devtools/python/python3-urllib3_2.1.0.bb b/meta/recipes-devtools/python/python3-urllib3_2.2.1.bb
similarity index 86%
rename from meta/recipes-devtools/python/python3-urllib3_2.1.0.bb
rename to meta/recipes-devtools/python/python3-urllib3_2.2.1.bb
index ad6dc6d405..fc1828b4ee 100644
--- a/meta/recipes-devtools/python/python3-urllib3_2.1.0.bb
+++ b/meta/recipes-devtools/python/python3-urllib3_2.2.1.bb
@@ -3,7 +3,7 @@  HOMEPAGE = "https://github.com/shazow/urllib3"
 LICENSE = "MIT"
 LIC_FILES_CHKSUM = "file://LICENSE.txt;md5=52d273a3054ced561275d4d15260ecda"
 
-SRC_URI[sha256sum] = "df7aa8afb0148fa78488e7899b2c59b5f4ffcfa82e6c54ccb9dd37c1d7b52d54"
+SRC_URI[sha256sum] = "d0570876c61ab9e520d776c38acbbb5b05a776d3f9ff98a5c8fd5162a444cf19"
 
 inherit pypi python_hatchling