diff mbox series

[24/48] minicom: upgrade 2.8 -> 2.9

Message ID 1709105575-24259-24-git-send-email-wangmy@fujitsu.com
State Accepted, archived
Commit 1fb2aa3f242ef20f8edfb518164b629258a04dd4
Headers show
Series [01/48] bash-completion: upgrade 2.11 -> 2.12.0 | expand

Commit Message

Mingyu Wang (Fujitsu) Feb. 28, 2024, 7:32 a.m. UTC
From: Wang Mingyu <wangmy@fujitsu.com>

0001-fix-minicom-h-v-return-value-is-not-0.patch
allow.to.disable.lockdev.patch
removed since they're included in 2.9.

Changelog:
============
 - Change Hardware Flow Control Default to No.
 - Timestamping mode is now saved and restored.
 - Split "Screen and Keyboard" menu into two menus.
 - Update to gettext-0.21.
 - Change return values of --help and --version to success.
 - Support higher baud rates on MacOS
 - Save character send delay to config file
 - Save newline send delay to config file
 - Update translations: Romanian, German, French, Norwegian/Bookmal, Polish,
                        Serbian, Swedish
 - New translation: Georgian, Korean

Signed-off-by: Wang Mingyu <wangmy@fujitsu.com>
---
 ...ix-minicom-h-v-return-value-is-not-0.patch | 33 -------------------
 .../minicom/allow.to.disable.lockdev.patch    | 30 -----------------
 .../{minicom_2.8.bb => minicom_2.9.bb}        |  7 ++--
 3 files changed, 2 insertions(+), 68 deletions(-)
 delete mode 100644 meta/recipes-extended/minicom/minicom/0001-fix-minicom-h-v-return-value-is-not-0.patch
 delete mode 100644 meta/recipes-extended/minicom/minicom/allow.to.disable.lockdev.patch
 rename meta/recipes-extended/minicom/{minicom_2.8.bb => minicom_2.9.bb} (80%)

Comments

Richard Purdie Feb. 28, 2024, 7:32 p.m. UTC | #1
On Wed, 2024-02-28 at 15:32 +0800, wangmy via lists.openembedded.org wrote:
> From: Wang Mingyu <wangmy@fujitsu.com>
> 
> 0001-fix-minicom-h-v-return-value-is-not-0.patch
> allow.to.disable.lockdev.patch
> removed since they're included in 2.9.
> 
> Changelog:
> ============
>  - Change Hardware Flow Control Default to No.
>  - Timestamping mode is now saved and restored.
>  - Split "Screen and Keyboard" menu into two menus.
>  - Update to gettext-0.21.
>  - Change return values of --help and --version to success.
>  - Support higher baud rates on MacOS
>  - Save character send delay to config file
>  - Save newline send delay to config file
>  - Update translations: Romanian, German, French, Norwegian/Bookmal, Polish,
>                         Serbian, Swedish
>  - New translation: Georgian, Korean
> 
> Signed-off-by: Wang Mingyu <wangmy@fujitsu.com>
> ---
>  ...ix-minicom-h-v-return-value-is-not-0.patch | 33 -------------------
>  .../minicom/allow.to.disable.lockdev.patch    | 30 -----------------
>  .../{minicom_2.8.bb => minicom_2.9.bb}        |  7 ++--
>  3 files changed, 2 insertions(+), 68 deletions(-)
>  delete mode 100644 meta/recipes-extended/minicom/minicom/0001-fix-minicom-h-v-return-value-is-not-0.patch
>  delete mode 100644 meta/recipes-extended/minicom/minicom/allow.to.disable.lockdev.patch
>  rename meta/recipes-extended/minicom/{minicom_2.8.bb => minicom_2.9.bb} (80%)

This breaks selftests in devtool:

https://autobuilder.yoctoproject.org/typhoon/#/builders/86/builds/6478/steps/14/logs/stdio

Cheers,

Richard
diff mbox series

Patch

diff --git a/meta/recipes-extended/minicom/minicom/0001-fix-minicom-h-v-return-value-is-not-0.patch b/meta/recipes-extended/minicom/minicom/0001-fix-minicom-h-v-return-value-is-not-0.patch
deleted file mode 100644
index 9e67126f3e..0000000000
--- a/meta/recipes-extended/minicom/minicom/0001-fix-minicom-h-v-return-value-is-not-0.patch
+++ /dev/null
@@ -1,33 +0,0 @@ 
-Exit normally for help/verison options
-
-If -v or -h is used for the help/version information, it is a normal exit situation,
-not an error condition. Sometimes these are used as a simple operation test of the
-resulting binary so the exit code does matter.
-
-Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
-Upstream-Status: Submitted [https://salsa.debian.org/minicom-team/minicom/-/merge_requests/14]
----
- src/minicom.c |    6 ++----
- 1 file changed, 2 insertions(+), 4 deletions(-)
-
-Index: minicom-2.8/src/minicom.c
-===================================================================
---- minicom-2.8.orig/src/minicom.c
-+++ minicom-2.8/src/minicom.c
-@@ -1257,14 +1257,14 @@ int main(int argc, char **argv)
-                  "modify it under the terms of the GNU General Public License\n"
-                  "as published by the Free Software Foundation; either version\n"
-                  "2 of the License, or (at your option) any later version.\n\n"));
--          exit(1);
-+          exit(0);
-           break;
-         case 's': /* setup mode */
-           dosetup = 1;
-           break;
-         case 'h':
-           helpthem();
--          exit(1);
-+          exit(0);
-           break;
-         case 'p': /* Pseudo terminal to use. */
-           if (strncmp(optarg, "/dev/", 5) == 0)
diff --git a/meta/recipes-extended/minicom/minicom/allow.to.disable.lockdev.patch b/meta/recipes-extended/minicom/minicom/allow.to.disable.lockdev.patch
deleted file mode 100644
index 39dc5c0492..0000000000
--- a/meta/recipes-extended/minicom/minicom/allow.to.disable.lockdev.patch
+++ /dev/null
@@ -1,30 +0,0 @@ 
-configure: Allow lockdev to be disabled
-
-When the pkgconfig dependencies may be present, it is useful to be
-able to explictly disable the lockdev dependency. This adds such an
-option.
-
-Signed-off-by: Martin Jansa <Martin.Jansa@gmail.com>
-Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
-
-Upstream-Status: Submitted [https://salsa.debian.org/minicom-team/minicom/-/merge_requests/14]
-
-Index: minicom-2.8/configure.ac
-===================================================================
---- minicom-2.8.orig/configure.ac
-+++ minicom-2.8/configure.ac
-@@ -43,7 +43,13 @@ if test "x$enable_socket" = xyes; then
- fi
- 
- PKG_PROG_PKG_CONFIG
--if test -n "$PKG_CONFIG"; then
-+
-+AC_ARG_ENABLE([lockdev],
-+        AS_HELP_STRING([--enable-lockdev],
-+                       [Enable lockdev support (def: enabled)]),
-+        [], [enable_lockdev="yes"])
-+
-+if test -n "$PKG_CONFIG" && test "x$enable_lockdev" = xyes; then
- 	PKG_CHECK_MODULES([LOCKDEV], [lockdev], AC_DEFINE([HAVE_LOCKDEV],[1],[Define if you have lockdev]),[:])
- fi
- 
diff --git a/meta/recipes-extended/minicom/minicom_2.8.bb b/meta/recipes-extended/minicom/minicom_2.9.bb
similarity index 80%
rename from meta/recipes-extended/minicom/minicom_2.8.bb
rename to meta/recipes-extended/minicom/minicom_2.9.bb
index 2640c6b057..907d5c79c9 100644
--- a/meta/recipes-extended/minicom/minicom_2.8.bb
+++ b/meta/recipes-extended/minicom/minicom_2.9.bb
@@ -7,12 +7,9 @@  LICENSE = "GPL-2.0-or-later"
 LIC_FILES_CHKSUM = "file://COPYING;md5=420477abc567404debca0a2a1cb6b645 \
                     file://src/minicom.h;beginline=1;endline=12;md5=a58838cb709f0db517f4e42730c49e81"
 
-SRC_URI = "${DEBIAN_MIRROR}/main/m/${BPN}/${BPN}_${PV}.orig.tar.bz2 \
-           file://allow.to.disable.lockdev.patch \
-           file://0001-fix-minicom-h-v-return-value-is-not-0.patch \
-"
+SRC_URI = "${DEBIAN_MIRROR}/main/m/${BPN}/${BPN}_${PV}.orig.tar.bz2"
 
-SRC_URI[sha256sum] = "38cea30913a20349326ff3f1763ee1512b7b41601c24f065f365e18e9db0beba"
+SRC_URI[sha256sum] = "9efbb6458140e5a0de445613f0e76bcf12cbf7a9892b2f53e075c2e7beaba86c"
 
 PACKAGECONFIG ??= ""
 PACKAGECONFIG[lockdev] = "--enable-lockdev,--disable-lockdev,lockdev"