[06/11] perl: update 5.34.0 -> 5.34.1

Message ID 20220319071605.152904-6-alex@linutronix.de
State Accepted, archived
Commit 0e318a46ceae38a33a99f55079c463e90a15944d
Headers show
Series [01/11] python3-semantic-version: fix upstream verison check | expand

Commit Message

Alexander Kanavin March 19, 2022, 7:16 a.m. UTC
Signed-off-by: Alexander Kanavin <alex@linutronix.de>
---
 ...e5fdd87aa205011512cd1e6cc655bcf677fd.patch | 31 --------------
 .../perl/files/CVE-2021-36770.patch           | 40 -------------------
 ...2398e766500cb5d83c4d76b642fcf31d997a.patch | 40 -------------------
 ...297a58b8f10ab885c19eec48ea076116cc1f.patch | 25 ------------
 .../perl/files/perl-configpm-switch.patch     |  4 +-
 .../perl/{perl_5.34.0.bb => perl_5.34.1.bb}   |  6 +--
 6 files changed, 3 insertions(+), 143 deletions(-)
 delete mode 100644 meta/recipes-devtools/perl/files/5bc1e5fdd87aa205011512cd1e6cc655bcf677fd.patch
 delete mode 100644 meta/recipes-devtools/perl/files/CVE-2021-36770.patch
 delete mode 100644 meta/recipes-devtools/perl/files/aacd2398e766500cb5d83c4d76b642fcf31d997a.patch
 delete mode 100644 meta/recipes-devtools/perl/files/ea57297a58b8f10ab885c19eec48ea076116cc1f.patch
 rename meta/recipes-devtools/perl/{perl_5.34.0.bb => perl_5.34.1.bb} (98%)

Patch

diff --git a/meta/recipes-devtools/perl/files/5bc1e5fdd87aa205011512cd1e6cc655bcf677fd.patch b/meta/recipes-devtools/perl/files/5bc1e5fdd87aa205011512cd1e6cc655bcf677fd.patch
deleted file mode 100644
index 1cb65d932c..0000000000
--- a/meta/recipes-devtools/perl/files/5bc1e5fdd87aa205011512cd1e6cc655bcf677fd.patch
+++ /dev/null
@@ -1,31 +0,0 @@ 
-From 5bc1e5fdd87aa205011512cd1e6cc655bcf677fd Mon Sep 17 00:00:00 2001
-From: Sergey Poznyakoff <gray@gnu.org>
-Date: Wed, 23 Jun 2021 15:31:42 +0300
-Subject: [PATCH] Fix definition of ITEM_NOT_FOUND for pre-1.13 versions.
-
-Upstream-Status: Backport
-Signed-off-by: Alexander Kanavin <alex.kanavin@gmail.com>
----
- ext/GDBM_File/GDBM_File.xs | 9 +++++----
- 1 file changed, 5 insertions(+), 4 deletions(-)
-
-diff --git a/ext/GDBM_File/GDBM_File.xs b/ext/GDBM_File/GDBM_File.xs
-index 494c2889ca89..0125b5dcac4d 100644
---- a/ext/GDBM_File/GDBM_File.xs
-+++ b/ext/GDBM_File/GDBM_File.xs
-@@ -145,10 +145,11 @@ output_datum(pTHX_ SV *arg, char *str, int size)
- #define gdbm_setopt(db,optflag,optval,optlen) not_here("gdbm_setopt")
- #endif
- 
--#if GDBM_VERSION_MAJOR == 1 && GDBM_VERSION_MINOR < 13        
--/* Prior to 1.13, gdbm_fetch family functions set gdbm_errno to GDBM_NO_ERROR
--   if the requested key did not exist */
--# define ITEM_NOT_FOUND()  (gdbm_errno == GDBM_NO_ERROR)
-+#if GDBM_VERSION_MAJOR == 1 && GDBM_VERSION_MINOR < 13
-+/* Prior to 1.13, only gdbm_fetch set GDBM_ITEM_NOT_FOUND if the requested
-+   key did not exist.  Other similar function wouls set GDBM_NO_ERROR instead.
-+   The GDBM_ITEM_NOT_FOUND existeds as early as in 1.7.3 */
-+# define ITEM_NOT_FOUND()  (gdbm_errno == GDBM_NO_ERROR || gdbm_errno == GDBM_ITEM_NOT_FOUND)
- #else
- # define ITEM_NOT_FOUND()  (gdbm_errno == GDBM_ITEM_NOT_FOUND)
- #endif
diff --git a/meta/recipes-devtools/perl/files/CVE-2021-36770.patch b/meta/recipes-devtools/perl/files/CVE-2021-36770.patch
deleted file mode 100644
index 1ef548b305..0000000000
--- a/meta/recipes-devtools/perl/files/CVE-2021-36770.patch
+++ /dev/null
@@ -1,40 +0,0 @@ 
-Backport patch to fix CVE-2021-36770. And drop the section of code which
-updates version.
-
-Upstream-Status: Backport [https://github.com/Perl/perl5/commit/c1a937f]
-CVE: CVE-2021-36770
-
-Signed-off-by: Kai Kang <kai.kang@windriver.com>
-
-From c1a937fef07c061600a0078f4cb53fe9c2136bb9 Mon Sep 17 00:00:00 2001
-From: Ricardo Signes <rjbs@semiotic.systems>
-Date: Mon, 9 Aug 2021 08:14:05 -0400
-Subject: [PATCH] Encode.pm: apply a local patch for CVE-2021-36770
-
-I expect Encode to see a new release today.
-
-Without this fix, Encode::ConfigLocal can be loaded from a path relative
-to the current directory, because the || operator will evaluate @INC in
-scalar context, putting an integer as the only value in @INC.
----
- cpan/Encode/Encode.pm | 4 ++--
- 1 file changed, 2 insertions(+), 2 deletions(-)
-
-diff --git a/cpan/Encode/Encode.pm b/cpan/Encode/Encode.pm
-index a56a99947f..b96a850416 100644
---- a/cpan/Encode/Encode.pm
-+++ b/cpan/Encode/Encode.pm
-@@ -65,8 +66,8 @@ require Encode::Config;
- eval {
-     local $SIG{__DIE__};
-     local $SIG{__WARN__};
--    local @INC = @INC || ();
--    pop @INC if $INC[-1] eq '.';
-+    local @INC = @INC;
-+    pop @INC if @INC && $INC[-1] eq '.';
-     require Encode::ConfigLocal;
- };
- 
--- 
-2.33.0
-
diff --git a/meta/recipes-devtools/perl/files/aacd2398e766500cb5d83c4d76b642fcf31d997a.patch b/meta/recipes-devtools/perl/files/aacd2398e766500cb5d83c4d76b642fcf31d997a.patch
deleted file mode 100644
index 628903f41c..0000000000
--- a/meta/recipes-devtools/perl/files/aacd2398e766500cb5d83c4d76b642fcf31d997a.patch
+++ /dev/null
@@ -1,40 +0,0 @@ 
-From aacd2398e766500cb5d83c4d76b642fcf31d997a Mon Sep 17 00:00:00 2001
-From: Sergey Poznyakoff <gray@gnu.org>
-Date: Wed, 23 Jun 2021 10:26:50 +0300
-Subject: [PATCH] Fix GDBM_File to compile with version 1.20 and earlier
-
-* ext/GDBM_File/GDBM_File.xs (ITEM_NOT_FOUND): Define conditionally,
-depending on the GDBM_VERSION_MAJOR and GDBM_VERSION_MINOR.
-Don't assume GDBM_ITEM_NOT_FOUND is a define (it isn't since
-gdbm commit d3e27957).
-
-Upstream-Status: Backport
-Signed-off-by: Alexander Kanavin <alex.kanavin@gmail.com>
----
- ext/GDBM_File/GDBM_File.xs | 11 +++++------
- 1 file changed, 5 insertions(+), 6 deletions(-)
-
-diff --git a/ext/GDBM_File/GDBM_File.xs b/ext/GDBM_File/GDBM_File.xs
-index cd0bb6f26ffa..494c2889ca89 100644
---- a/ext/GDBM_File/GDBM_File.xs
-+++ b/ext/GDBM_File/GDBM_File.xs
-@@ -145,14 +145,13 @@ output_datum(pTHX_ SV *arg, char *str, int size)
- #define gdbm_setopt(db,optflag,optval,optlen) not_here("gdbm_setopt")
- #endif
- 
--#ifndef GDBM_ITEM_NOT_FOUND
--# define GDBM_ITEM_NOT_FOUND GDBM_NO_ERROR
--#endif
--
-+#if GDBM_VERSION_MAJOR == 1 && GDBM_VERSION_MINOR < 13        
- /* Prior to 1.13, gdbm_fetch family functions set gdbm_errno to GDBM_NO_ERROR
-    if the requested key did not exist */
--#define ITEM_NOT_FOUND()                                                \
--    (gdbm_errno == GDBM_ITEM_NOT_FOUND || gdbm_errno == GDBM_NO_ERROR)
-+# define ITEM_NOT_FOUND()  (gdbm_errno == GDBM_NO_ERROR)
-+#else
-+# define ITEM_NOT_FOUND()  (gdbm_errno == GDBM_ITEM_NOT_FOUND)
-+#endif
- 
- #define CHECKDB(db) do {                        \
-     if (!db->dbp) {                             \
diff --git a/meta/recipes-devtools/perl/files/ea57297a58b8f10ab885c19eec48ea076116cc1f.patch b/meta/recipes-devtools/perl/files/ea57297a58b8f10ab885c19eec48ea076116cc1f.patch
deleted file mode 100644
index 3864f1a121..0000000000
--- a/meta/recipes-devtools/perl/files/ea57297a58b8f10ab885c19eec48ea076116cc1f.patch
+++ /dev/null
@@ -1,25 +0,0 @@ 
-From ea57297a58b8f10ab885c19eec48ea076116cc1f Mon Sep 17 00:00:00 2001
-From: Sergey Poznyakoff <gray@gnu.org>
-Date: Wed, 23 Jun 2021 14:24:47 +0300
-Subject: [PATCH] Raise version number in ext/GDBM_File/GDBM_File.pm
-
-Upstream-Status: Backport
-Signed-off-by: Alexander Kanavin <alex.kanavin@gmail.com>
-
----
- ext/GDBM_File/GDBM_File.pm | 2 +-
- 1 file changed, 1 insertion(+), 1 deletion(-)
-
-diff --git a/ext/GDBM_File/GDBM_File.pm b/ext/GDBM_File/GDBM_File.pm
-index d837536f804c..cb08d091b829 100644
---- a/ext/GDBM_File/GDBM_File.pm
-+++ b/ext/GDBM_File/GDBM_File.pm
-@@ -363,7 +363,7 @@ require XSLoader;
- );
- 
- # This module isn't dual life, so no need for dev version numbers.
--$VERSION = '1.19';
-+$VERSION = '1.20';
- 
- XSLoader::load();
- 
diff --git a/meta/recipes-devtools/perl/files/perl-configpm-switch.patch b/meta/recipes-devtools/perl/files/perl-configpm-switch.patch
index 80ce4a6de7..15189a0c04 100644
--- a/meta/recipes-devtools/perl/files/perl-configpm-switch.patch
+++ b/meta/recipes-devtools/perl/files/perl-configpm-switch.patch
@@ -1,4 +1,4 @@ 
-From 5120acaa2be5787d9657f6b91bc8ee3c2d664fbe Mon Sep 17 00:00:00 2001
+From 1f7cc5db2ca549c37c6a7923368e1a0104f31b99 Mon Sep 17 00:00:00 2001
 From: Alexander Kanavin <alex.kanavin@gmail.com>
 Date: Sun, 27 May 2007 21:04:11 +0000
 Subject: [PATCH] perl: 5.8.7 -> 5.8.8 (from OE)
@@ -20,7 +20,7 @@  Signed-off-by: Alexander Kanavin <alex.kanavin@gmail.com>
  1 file changed, 16 insertions(+), 2 deletions(-)
 
 diff --git a/configpm b/configpm
-index c8de8bf..204613c 100755
+index 94a4778..99b20c9 100755
 --- a/configpm
 +++ b/configpm
 @@ -687,7 +687,7 @@ sub FETCH {
diff --git a/meta/recipes-devtools/perl/perl_5.34.0.bb b/meta/recipes-devtools/perl/perl_5.34.1.bb
similarity index 98%
rename from meta/recipes-devtools/perl/perl_5.34.0.bb
rename to meta/recipes-devtools/perl/perl_5.34.1.bb
index 60a7aff906..ccd6ad5a0e 100644
--- a/meta/recipes-devtools/perl/perl_5.34.0.bb
+++ b/meta/recipes-devtools/perl/perl_5.34.1.bb
@@ -16,10 +16,6 @@  SRC_URI = "https://www.cpan.org/src/5.0/perl-${PV}.tar.gz;name=perl \
            file://perl-dynloader.patch \
            file://0002-Constant-Fix-up-shebang.patch \
            file://determinism.patch \
-           file://CVE-2021-36770.patch \
-           file://aacd2398e766500cb5d83c4d76b642fcf31d997a.patch \
-           file://ea57297a58b8f10ab885c19eec48ea076116cc1f.patch \
-           file://5bc1e5fdd87aa205011512cd1e6cc655bcf677fd.patch \
            file://0001-cpan-Sys-Syslog-Makefile.PL-Fix-_PATH_LOG-for-determ.patch \
            "
 SRC_URI:append:class-native = " \
@@ -29,7 +25,7 @@  SRC_URI:append:class-target = " \
            file://encodefix.patch \
 "
 
-SRC_URI[perl.sha256sum] = "551efc818b968b05216024fb0b727ef2ad4c100f8cb6b43fab615fa78ae5be9a"
+SRC_URI[perl.sha256sum] = "357951a491b0ba1ce3611263922feec78ccd581dddc24a446b033e25acf242a1"
 
 S = "${WORKDIR}/perl-${PV}"