diff mbox series

[meta-python,1/5] python3-pillow: Upgrade 10.0.1 -> 10.1.0

Message ID 20231114120944.3741068-1-leon.anavi@konsulko.com
State Accepted
Headers show
Series [meta-python,1/5] python3-pillow: Upgrade 10.0.1 -> 10.1.0 | expand

Commit Message

Leon Anavi Nov. 14, 2023, 12:09 p.m. UTC
Upgrade to release 10.1.0:

- Added TrueType default font to allow for different sizes
- Fixed invalid argument warning
- Added ImageOps cover method
- Catch struct.error from truncated EXIF when reading JPEG DPI
- Consider default image when selecting mode for PNG save_all
- Support BGR;15, BGR;16 and BGR;24 access, unpacking and putdata
- Added CMYK to RGB unpacker
- Improved flexibility of XMP parsing
- Support reading 8-bit YCbCr TIFF images
- Allow saving I;16B images as PNG
- Corrected drawing I;16 points and writing I;16 text
- Set blue channel to 128 for BC5S
- Increase flexibility when reading IPTC fields
- Set C palette to be empty by default
- Added gs_binary to control Ghostscript use on all platforms
- Read bounding box information from the trailer of EPS files if
  specified
- Added reading 8-bit color DDS images
- Added has_transparency_data
- Fixed bug when reading BC5S DDS images
- Prevent TIFF orientation from being applied more than once
- Use previous pixel alpha for QOI_OP_RGB
- Added BC5U reading
- Allow getpixel() to accept a list
- Allow GaussianBlur and BoxBlur to accept a sequence of x and y
  radii
- Expand JPEG buffer size when saving optimized or progressive
- Added session type check for Linux in ImageGrab.grabclipboard()
- Allow "loop=None" when saving GIF images
- Fixed transparency when saving P mode images to PDF
- Added saving LA images as PDFs
- Set SMaskInData to 1 for PDFs with alpha
- Changed Image mode property to be read-only by default
- Silence exceptions in _repr_jpeg_ and _repr_png_
- Do not use transparency when saving GIF if it has been removed
  when normalizing mode
- Fix missing symbols when libtiff depends on libjpeg

This work was sponsored by GOVCERT.LU.

Signed-off-by: Leon Anavi <leon.anavi@konsulko.com>
---
 .../{python3-pillow_10.0.1.bb => python3-pillow_10.1.0.bb}      | 2 +-
 1 file changed, 1 insertion(+), 1 deletion(-)
 rename meta-python/recipes-devtools/python/{python3-pillow_10.0.1.bb => python3-pillow_10.1.0.bb} (96%)

Comments

Khem Raj Nov. 15, 2023, 7:19 a.m. UTC | #1
On Tue, 14 Nov 2023 14:09:40 +0200, Leon Anavi wrote:
> Upgrade to release 10.1.0:
> 
> - Added TrueType default font to allow for different sizes
> - Fixed invalid argument warning
> - Added ImageOps cover method
> - Catch struct.error from truncated EXIF when reading JPEG DPI
> - Consider default image when selecting mode for PNG save_all
> - Support BGR;15, BGR;16 and BGR;24 access, unpacking and putdata
> - Added CMYK to RGB unpacker
> - Improved flexibility of XMP parsing
> - Support reading 8-bit YCbCr TIFF images
> - Allow saving I;16B images as PNG
> - Corrected drawing I;16 points and writing I;16 text
> - Set blue channel to 128 for BC5S
> - Increase flexibility when reading IPTC fields
> - Set C palette to be empty by default
> - Added gs_binary to control Ghostscript use on all platforms
> - Read bounding box information from the trailer of EPS files if
>   specified
> - Added reading 8-bit color DDS images
> - Added has_transparency_data
> - Fixed bug when reading BC5S DDS images
> - Prevent TIFF orientation from being applied more than once
> - Use previous pixel alpha for QOI_OP_RGB
> - Added BC5U reading
> - Allow getpixel() to accept a list
> - Allow GaussianBlur and BoxBlur to accept a sequence of x and y
>   radii
> - Expand JPEG buffer size when saving optimized or progressive
> - Added session type check for Linux in ImageGrab.grabclipboard()
> - Allow "loop=None" when saving GIF images
> - Fixed transparency when saving P mode images to PDF
> - Added saving LA images as PDFs
> - Set SMaskInData to 1 for PDFs with alpha
> - Changed Image mode property to be read-only by default
> - Silence exceptions in _repr_jpeg_ and _repr_png_
> - Do not use transparency when saving GIF if it has been removed
>   when normalizing mode
> - Fix missing symbols when libtiff depends on libjpeg
> 
> [...]

Applied, thanks!

[1/5] python3-pillow: Upgrade 10.0.1 -> 10.1.0
      commit: a0473439e9eb8a928c8d1185426ddea88ea8b064
[2/5] python3-polyline: upgrade 1.4.0 -> 2.0.1
      commit: 5eec5c33289f8035b16af2743321550ae3415d9d
[3/5] python3-py7zr: Upgrade 0.20.7 -> 0.20.8
      commit: b3b68ce89cfb8d014fcd3070ca8dff5623bc5df5
[4/5] python3-zeroconf: upgrade 0.120.0 -> 0.126.0
      commit: 1c43e700f12eefc6819204c921a1c84661594592
[5/5] python3-pystemd: upgrade 0.10.0 -> 0.13.2
      commit: 8d78812fc8cf14e3242533a102a2228c898b445d

Best regards,
diff mbox series

Patch

diff --git a/meta-python/recipes-devtools/python/python3-pillow_10.0.1.bb b/meta-python/recipes-devtools/python/python3-pillow_10.1.0.bb
similarity index 96%
rename from meta-python/recipes-devtools/python/python3-pillow_10.0.1.bb
rename to meta-python/recipes-devtools/python/python3-pillow_10.1.0.bb
index 055b41bfa..322c90eda 100644
--- a/meta-python/recipes-devtools/python/python3-pillow_10.0.1.bb
+++ b/meta-python/recipes-devtools/python/python3-pillow_10.1.0.bb
@@ -10,7 +10,7 @@  SRC_URI = "git://github.com/python-pillow/Pillow.git;branch=10.0.x;protocol=http
            file://0001-explicitly-set-compile-options.patch \
            file://run-ptest \
            "
-SRCREV ?= "82541b6dec8452cb612067fcebba1c5a1a2bfdc8"
+SRCREV ?= "da59ad000d1405eaecd557175e29083a87d19f7c"
 
 inherit setuptools3 ptest