diff mbox series

[meta-python,5/5] python3-pystemd: upgrade 0.10.0 -> 0.13.2

Message ID 20231114120944.3741068-5-leon.anavi@konsulko.com
State Accepted
Headers show
Series [meta-python,1/5] python3-pillow: Upgrade 10.0.1 -> 10.1.0 | expand

Commit Message

Leon Anavi Nov. 14, 2023, 12:09 p.m. UTC
Added runtime dependencies. Upgrade to release 0.13.2:

- adding coverage information
- changes tests to pystes
- adding support for pyproject.toml
- adding extra properties for unit

Signed-off-by: Leon Anavi <leon.anavi@konsulko.com>
---
 ...n3-pystemd_0.10.0.bb => python3-pystemd_0.13.2.bb} | 11 +++++++++--
 1 file changed, 9 insertions(+), 2 deletions(-)
 rename meta-python/recipes-devtools/python/{python3-pystemd_0.10.0.bb => python3-pystemd_0.13.2.bb} (59%)
diff mbox series

Patch

diff --git a/meta-python/recipes-devtools/python/python3-pystemd_0.10.0.bb b/meta-python/recipes-devtools/python/python3-pystemd_0.13.2.bb
similarity index 59%
rename from meta-python/recipes-devtools/python/python3-pystemd_0.10.0.bb
rename to meta-python/recipes-devtools/python/python3-pystemd_0.13.2.bb
index da22a43de..d31f45131 100644
--- a/meta-python/recipes-devtools/python/python3-pystemd_0.10.0.bb
+++ b/meta-python/recipes-devtools/python/python3-pystemd_0.13.2.bb
@@ -2,10 +2,17 @@  SUMMARY = "Python bindings for interacting with systemd over DBus"
 LICENSE = "LGPL-2.1-only"
 LIC_FILES_CHKSUM = "file://LICENSE;md5=4fbd65380cdd255951079008b364516c"
 
-SRC_URI[sha256sum] = "d74a814bfda01085db1a8ad90be3cb27daf23a51ab6b03e7e29ec811fa2ae859"
+SRC_URI[sha256sum] = "4dcfa4b13a55685c49d3d17c10631eca18c33770f66316f8ef2337b8951cc144"
 
 DEPENDS = "systemd python3-cython-native"
-RDEPENDS:${PN} += "python3-xml python3-pprint"
+RDEPENDS:${PN} += "\
+    ${PYTHON_PN}-xml \
+    ${PYTHON_PN}-lxml \
+    ${PYTHON_PN}-pprint \
+    ${PYTHON_PN}-core \
+    ${PYTHON_PN}-shell \
+    ${PYTHON_PN}-io \
+"
 REQUIRED_DISTRO_FEATURES = "systemd"
 
 inherit pypi setuptools3 features_check pkgconfig