diff mbox series

[meta-python,6/9] python3-grpcio: Enable largefile support explicitly

Message ID 20220826061150.3030485-6-raj.khem@gmail.com
State New
Headers show
Series [meta-oe,1/9] fio: Fix additional warnings seen with musl | expand

Commit Message

Khem Raj Aug. 26, 2022, 6:11 a.m. UTC
This ensures that third party packages like zlib can get this in CFLAGS

Signed-off-by: Khem Raj <raj.khem@gmail.com>
---
 meta-python/recipes-devtools/python/python3-grpcio_1.47.0.bb | 2 ++
 1 file changed, 2 insertions(+)
diff mbox series

Patch

diff --git a/meta-python/recipes-devtools/python/python3-grpcio_1.47.0.bb b/meta-python/recipes-devtools/python/python3-grpcio_1.47.0.bb
index 24c6e53447..0950114b02 100644
--- a/meta-python/recipes-devtools/python/python3-grpcio_1.47.0.bb
+++ b/meta-python/recipes-devtools/python/python3-grpcio_1.47.0.bb
@@ -23,6 +23,8 @@  RDEPENDS:${PN} = "${PYTHON_PN}-protobuf \
 inherit setuptools3
 inherit pypi
 
+CFLAGS += "-D_LARGEFILE64_SOURCE"
+
 export GRPC_PYTHON_DISABLE_LIBC_COMPATIBILITY = "1"
 
 BORING_SSL_PLATFORM:arm = "linux-arm"