diff mbox series

[meta-oe,9/9] satyr: Fix build on musl/clang

Message ID 20220826061150.3030485-9-raj.khem@gmail.com
State New
Headers show
Series [meta-oe,1/9] fio: Fix additional warnings seen with musl | expand

Commit Message

Khem Raj Aug. 26, 2022, 6:11 a.m. UTC
Fixes
| py_base_stacktrace.c:301:5: error: call to undeclared function 'g_free'; ISO C99 and later do not support implicit function declarations [-Wimplicit-function-declaration]
|     g_free(text);
|     ^

Signed-off-by: Khem Raj <raj.khem@gmail.com>
---
 ...-py_base_stacktrace.c-include-glib.h.patch | 29 +++++++++++++++++++
 meta-oe/recipes-support/satyr/satyr_0.39.bb   |  1 +
 2 files changed, 30 insertions(+)
 create mode 100644 meta-oe/recipes-support/satyr/files/0001-py_base_stacktrace.c-include-glib.h.patch
diff mbox series

Patch

diff --git a/meta-oe/recipes-support/satyr/files/0001-py_base_stacktrace.c-include-glib.h.patch b/meta-oe/recipes-support/satyr/files/0001-py_base_stacktrace.c-include-glib.h.patch
new file mode 100644
index 0000000000..fe3b1c12d2
--- /dev/null
+++ b/meta-oe/recipes-support/satyr/files/0001-py_base_stacktrace.c-include-glib.h.patch
@@ -0,0 +1,29 @@ 
+From 3b84fe4375292d00ebb605a5917e66129fe5f0cb Mon Sep 17 00:00:00 2001
+From: Khem Raj <raj.khem@gmail.com>
+Date: Wed, 24 Aug 2022 23:26:46 -0700
+Subject: [PATCH] py_base_stacktrace.c: include glib.h
+
+This file has references to g_free from glib-2.0 which needs this header
+
+Upstream-Status: Submitted [https://github.com/abrt/satyr/pull/333]
+Signed-off-by: Khem Raj <raj.khem@gmail.com>
+---
+ python/py_base_stacktrace.c | 2 +-
+ 1 file changed, 1 insertion(+), 1 deletion(-)
+
+diff --git a/python/py_base_stacktrace.c b/python/py_base_stacktrace.c
+index b9bd16c..301db84 100644
+--- a/python/py_base_stacktrace.c
++++ b/python/py_base_stacktrace.c
+@@ -17,7 +17,7 @@
+     with this program; if not, write to the Free Software Foundation, Inc.,
+     51 Franklin Street, Fifth Floor, Boston, MA 02110-1301 USA.
+ */
+-
++#include <glib.h>
+ #include "py_common.h"
+ #include "py_base_thread.h"
+ #include "py_base_stacktrace.h"
+-- 
+2.37.2
+
diff --git a/meta-oe/recipes-support/satyr/satyr_0.39.bb b/meta-oe/recipes-support/satyr/satyr_0.39.bb
index 32f27f5cbd..be1ef3f790 100644
--- a/meta-oe/recipes-support/satyr/satyr_0.39.bb
+++ b/meta-oe/recipes-support/satyr/satyr_0.39.bb
@@ -9,6 +9,7 @@  inherit autotools-brokensep python3native pkgconfig
 
 SRC_URI = "git://github.com/abrt/satyr.git;branch=master;protocol=https \
            file://0002-fix-compile-failure-against-musl-C-library.patch \
+           file://0001-py_base_stacktrace.c-include-glib.h.patch \
 "
 SRCREV = "f8a0dbfe7fcc6e44f03d66ca5c81363aea318380"
 S = "${WORKDIR}/git"