diff mbox series

[meta-security,V2] meta-security: Add recipe for Glome

Message ID 20220808184051.2098828-1-jebr@google.com
State Under Review
Delegated to: Armin Kuster
Headers show
Series [meta-security,V2] meta-security: Add recipe for Glome | expand

Commit Message

John Broadbent Aug. 8, 2022, 6:40 p.m. UTC
From: John Edward Broadbent <jebr@google.com>

Generic Low Overhead Message Exchange (GLOME) is a protocol providing
secure authentication and authorization for low dependency environments.

Signed-off-by: John Edward Broadbent <jebr@google.com>
---
 .../packagegroup-core-security.bb             |  1 +
 recipes-security/glome/glome_git.bb           | 24 +++++++++++++++++++
 2 files changed, 25 insertions(+)
 create mode 100644 recipes-security/glome/glome_git.bb

Comments

akuster808 Aug. 12, 2022, 3:35 p.m. UTC | #1
merged

On 8/8/22 11:40, John Broadbent via lists.yoctoproject.org wrote:
> From: John Edward Broadbent <jebr@google.com>
>
> Generic Low Overhead Message Exchange (GLOME) is a protocol providing
> secure authentication and authorization for low dependency environments.
>
> Signed-off-by: John Edward Broadbent <jebr@google.com>
> ---
>   .../packagegroup-core-security.bb             |  1 +
>   recipes-security/glome/glome_git.bb           | 24 +++++++++++++++++++
>   2 files changed, 25 insertions(+)
>   create mode 100644 recipes-security/glome/glome_git.bb
>
> diff --git a/recipes-core/packagegroup/packagegroup-core-security.bb b/recipes-core/packagegroup/packagegroup-core-security.bb
> index a12a4c2..c028c3d 100644
> --- a/recipes-core/packagegroup/packagegroup-core-security.bb
> +++ b/recipes-core/packagegroup/packagegroup-core-security.bb
> @@ -31,6 +31,7 @@ RDEPENDS:packagegroup-security-utils = "\
>       ding-libs \
>       ecryptfs-utils \
>       fscryptctl \
> +    glome \
>       keyutils \
>       nmap \
>       pinentry \
> diff --git a/recipes-security/glome/glome_git.bb b/recipes-security/glome/glome_git.bb
> new file mode 100644
> index 0000000..12d6d5f
> --- /dev/null
> +++ b/recipes-security/glome/glome_git.bb
> @@ -0,0 +1,24 @@
> +SUMMARY = "GLOME Login Client"
> +HOME_PAGE = "https://github.com/google/glome"
> +DESCRIPTION = "GLOME is used to authorize serial console access to Linux machines"
> +PV = "0.1+git${SRCPV}"
> +
> +LICENSE = "Apache-2.0"
> +LIC_FILES_CHKSUM = "file://LICENSE;md5=3b83ef96387f14655fc854ddc3c6bd57"
> +
> +inherit meson pkgconfig
> +
> +DEPENDS += "openssl"
> +
> +S = "${WORKDIR}/git"
> +SRC_URI = "git://github.com/google/glome.git;branch=master;protocol=https"
> +SRCREV = "978ad9fb165f1e382c875f2ce08a1fc4f2ddcf1b"
> +
> +FILES:${PN} += "${libdir}/security"
> +
> +PACKAGECONFIG ??= ""
> +PACKAGECONFIG[glome-cli] = "-Dglome-cli=true,-Dglome-cli=false"
> +PACKAGECONFIG[pam-glome] = "-Dpam-glome=true,-Dpam-glome=false,libpam"
> +
> +EXTRA_OEMESON = "-Dtests=false"
> +
>
> -=-=-=-=-=-=-=-=-=-=-=-
> Links: You receive all messages sent to this group.
> View/Reply Online (#57808): https://lists.yoctoproject.org/g/yocto/message/57808
> Mute This Topic: https://lists.yoctoproject.org/mt/92899047/3616698
> Group Owner: yocto+owner@lists.yoctoproject.org
> Unsubscribe: https://lists.yoctoproject.org/g/yocto/unsub [akuster808@gmail.com]
> -=-=-=-=-=-=-=-=-=-=-=-
>
diff mbox series

Patch

diff --git a/recipes-core/packagegroup/packagegroup-core-security.bb b/recipes-core/packagegroup/packagegroup-core-security.bb
index a12a4c2..c028c3d 100644
--- a/recipes-core/packagegroup/packagegroup-core-security.bb
+++ b/recipes-core/packagegroup/packagegroup-core-security.bb
@@ -31,6 +31,7 @@  RDEPENDS:packagegroup-security-utils = "\
     ding-libs \
     ecryptfs-utils \
     fscryptctl \
+    glome \
     keyutils \
     nmap \
     pinentry \
diff --git a/recipes-security/glome/glome_git.bb b/recipes-security/glome/glome_git.bb
new file mode 100644
index 0000000..12d6d5f
--- /dev/null
+++ b/recipes-security/glome/glome_git.bb
@@ -0,0 +1,24 @@ 
+SUMMARY = "GLOME Login Client"
+HOME_PAGE = "https://github.com/google/glome"
+DESCRIPTION = "GLOME is used to authorize serial console access to Linux machines"
+PV = "0.1+git${SRCPV}"
+
+LICENSE = "Apache-2.0"
+LIC_FILES_CHKSUM = "file://LICENSE;md5=3b83ef96387f14655fc854ddc3c6bd57"
+
+inherit meson pkgconfig
+
+DEPENDS += "openssl"
+
+S = "${WORKDIR}/git"
+SRC_URI = "git://github.com/google/glome.git;branch=master;protocol=https"
+SRCREV = "978ad9fb165f1e382c875f2ce08a1fc4f2ddcf1b"
+
+FILES:${PN} += "${libdir}/security"
+
+PACKAGECONFIG ??= ""
+PACKAGECONFIG[glome-cli] = "-Dglome-cli=true,-Dglome-cli=false"
+PACKAGECONFIG[pam-glome] = "-Dpam-glome=true,-Dpam-glome=false,libpam"
+
+EXTRA_OEMESON = "-Dtests=false"
+