[meta-security] apparmor: update to 3.0.4

Message ID 20220226190048.3264760-1-akuster808@gmail.com
State New
Headers show
Series [meta-security] apparmor: update to 3.0.4 | expand

Commit Message

akuster808 Feb. 26, 2022, 7 p.m. UTC
drop to patches no longer needed
use setuptools

Signed-off-by: Armin Kuster <akuster808@gmail.com>
---
 .../{apparmor_3.0.1.bb => apparmor_3.0.4.bb}  |  6 +-
 ...Update-make-check-to-select-tools-ba.patch | 91 -------------------
 recipes-mac/AppArmor/files/py3_10_fixup.patch | 35 -------
 3 files changed, 2 insertions(+), 130 deletions(-)
 rename recipes-mac/AppArmor/{apparmor_3.0.1.bb => apparmor_3.0.4.bb} (97%)
 delete mode 100644 recipes-mac/AppArmor/files/0001-Revert-profiles-Update-make-check-to-select-tools-ba.patch
 delete mode 100644 recipes-mac/AppArmor/files/py3_10_fixup.patch

Patch

diff --git a/recipes-mac/AppArmor/apparmor_3.0.1.bb b/recipes-mac/AppArmor/apparmor_3.0.4.bb
similarity index 97%
rename from recipes-mac/AppArmor/apparmor_3.0.1.bb
rename to recipes-mac/AppArmor/apparmor_3.0.4.bb
index 818be15..8ad3c76 100644
--- a/recipes-mac/AppArmor/apparmor_3.0.1.bb
+++ b/recipes-mac/AppArmor/apparmor_3.0.4.bb
@@ -18,20 +18,18 @@  SRC_URI = " \
     file://run-ptest \
     file://crosscompile_perl_bindings.patch \
     file://0001-Makefile.am-suppress-perllocal.pod.patch \
-    file://0001-Revert-profiles-Update-make-check-to-select-tools-ba.patch \
     file://0001-Makefile-fix-hardcoded-installation-directories.patch \
     file://0001-rc.apparmor.debian-add-missing-functions.patch \
-    file://py3_10_fixup.patch \
     "
 
-SRCREV = "b23de501807b8b5793e9654da8688b5fd3281154"
+SRCREV = "9799fbde997820bb12a49e292356f7a6ce12e972"
 S = "${WORKDIR}/git"
 
 PARALLEL_MAKE = ""
 
 COMPATIBLE_MACHINE:mips64 = "(!.*mips64).*"
 
-inherit pkgconfig autotools-brokensep update-rc.d python3native python3targetconfig perlnative cpan systemd features_check bash-completion
+inherit pkgconfig autotools-brokensep update-rc.d python3native python3targetconfig perlnative cpan systemd features_check bash-completion setuptools3
 
 REQUIRED_DISTRO_FEATURES = "apparmor"
 
diff --git a/recipes-mac/AppArmor/files/0001-Revert-profiles-Update-make-check-to-select-tools-ba.patch b/recipes-mac/AppArmor/files/0001-Revert-profiles-Update-make-check-to-select-tools-ba.patch
deleted file mode 100644
index e7abd60..0000000
--- a/recipes-mac/AppArmor/files/0001-Revert-profiles-Update-make-check-to-select-tools-ba.patch
+++ /dev/null
@@ -1,91 +0,0 @@ 
-From 5ed21abbef4d4c2983e70bd2868fb817150e883e Mon Sep 17 00:00:00 2001
-From: Armin Kuster <akuster808@gmail.com>
-Date: Sat, 3 Oct 2020 11:26:46 -0700
-Subject: [PATCH] Revert "profiles: Update 'make check' to select tools based
- on USE_SYSTEM"
-
-This reverts commit 6016f931ebf7b61e1358f19453ef262d9d184a4e.
-
-Upstream-Status: Inappropriate [OE specific]
-These changes cause during packaging with perms changing.
-
-Signed-off-by: Armin Kuster <akuster808@gmail.com>
-
----
- profiles/Makefile | 50 ++++++++++-------------------------------------
- 1 file changed, 10 insertions(+), 40 deletions(-)
-
-diff --git a/profiles/Makefile b/profiles/Makefile
-index ba47fc16..5384cb05 100644
---- a/profiles/Makefile
-+++ b/profiles/Makefile
-@@ -35,49 +35,9 @@ EXTRAS_SOURCE=./apparmor/profiles/extras/
- SUBDIRS=$(shell find ${PROFILES_SOURCE} -type d -print)
- TOPLEVEL_PROFILES=$(filter-out ${SUBDIRS}, $(wildcard ${PROFILES_SOURCE}/*))
- 
--ifdef USE_SYSTEM
--    PYTHONPATH=
--    PARSER?=apparmor_parser
--    LOGPROF?=aa-logprof
--else
--    # PYTHON_DIST_BUILD_PATH based on libapparmor/swig/python/test/Makefile.am
--    PYTHON_DIST_BUILD_PATH = ../libraries/libapparmor/swig/python/build/$$($(PYTHON) -c "import distutils.util; import platform; print(\"lib.%s-%s\" %(distutils.util.get_platform(), platform.python_version()[:3]))")
--    LIBAPPARMOR_PATH=../libraries/libapparmor/src/.libs/
--    LD_LIBRARY_PATH=$(LIBAPPARMOR_PATH):$(PYTHON_DIST_BUILD_PATH)
--    PYTHONPATH=../utils/:$(PYTHON_DIST_BUILD_PATH)
--    PARSER?=../parser/apparmor_parser
--    # use ../utils logprof
--    LOGPROF?=LD_LIBRARY_PATH=$(LD_LIBRARY_PATH) PYTHONPATH=$(PYTHONPATH) $(PYTHON) ../utils/aa-logprof
--endif
--
- # $(PWD) is wrong when using "make -C profiles" - explicitely set it here to get the right value
- PWD=$(shell pwd)
- 
--.PHONY: test-dependencies
--test-dependencies: __parser __libapparmor
--
--
--.PHONY: __parser __libapparmor
--__parser:
--ifndef USE_SYSTEM
--	@if [ ! -f $(PARSER) ]; then \
--		echo "error: $(PARSER) is missing. Pick one of these possible solutions:" 1>&2; \
--		echo "  1) Test using the in-tree parser by building it first and then trying again. See the top-level README for help." 1>&2; \
--		echo "  2) Test using the system parser by adding USE_SYSTEM=1 to your make command." 1>&2; \
--		exit 1; \
--	fi
--endif
--
--__libapparmor:
--ifndef USE_SYSTEM
--	@if [ ! -f $(LIBAPPARMOR_PATH)libapparmor.so ]; then \
--		echo "error: $(LIBAPPARMOR_PATH)libapparmor.so is missing. Pick one of these possible solutions:" 1>&2; \
--		echo "  1) Build against the in-tree libapparmor by building it first and then trying again. See the top-level README for help." 1>&2; \
--		echo "  2) Build against the system libapparmor by adding USE_SYSTEM=1 to your make command." 1>&2; \
--		exit 1; \
--	fi
--endif
--
- local:
- 	for profile in ${TOPLEVEL_PROFILES}; do \
- 		fn=$$(basename $$profile); \
-@@ -109,6 +69,16 @@ else
-   Q=
- endif
- 
-+ifndef PARSER
-+# use system parser
-+PARSER=../parser/apparmor_parser
-+endif
-+
-+ifndef LOGPROF
-+# use ../utils logprof
-+LOGPROF=PYTHONPATH=../utils $(PYTHON) ../utils/aa-logprof
-+endif
-+
- .PHONY: docs
- # docs: should we have some here?
- docs:
--- 
-2.17.1
-
diff --git a/recipes-mac/AppArmor/files/py3_10_fixup.patch b/recipes-mac/AppArmor/files/py3_10_fixup.patch
deleted file mode 100644
index 05f8460..0000000
--- a/recipes-mac/AppArmor/files/py3_10_fixup.patch
+++ /dev/null
@@ -1,35 +0,0 @@ 
-m4/ax_python_devel.m4: do not check for distutils
-
-With py 3.10 this prints a deprecation warning which is
-taken as an error. Upstream should rework the code to not
-use distuils.
-
-Upstream-Status: Inappropriate [needs a proper fix upstream]
-Signed-off-by: Armin Kuster <akuster808@gmail.com>
-
-Index: git/libraries/libapparmor/m4/ac_python_devel.m4
-===================================================================
---- git.orig/libraries/libapparmor/m4/ac_python_devel.m4
-+++ git/libraries/libapparmor/m4/ac_python_devel.m4
-@@ -66,21 +66,6 @@ variable to configure. See ``configure -
-         fi
- 
-         #
--        # Check if you have distutils, else fail
--        #
--        AC_MSG_CHECKING([for the distutils Python package])
--        ac_distutils_result=`$PYTHON -c "import distutils" 2>&1`
--        if test -z "$ac_distutils_result"; then
--                AC_MSG_RESULT([yes])
--        else
--                AC_MSG_RESULT([no])
--                AC_MSG_ERROR([cannot import Python module "distutils".
--Please check your Python installation. The error was:
--$ac_distutils_result])
--                PYTHON_VERSION=""
--        fi
--
--        #
-         # Check for Python include path
-         #
-         AC_MSG_CHECKING([for Python include path])