[1/4] arm/trusted-firmware-m: use relative paths for SRC_URI destsuffix

Message ID 20220124162947.3796440-1-ross.burton@arm.com
State New
Headers show
Series [1/4] arm/trusted-firmware-m: use relative paths for SRC_URI destsuffix | expand

Commit Message

Ross Burton Jan. 24, 2022, 4:29 p.m. UTC
It's not recommended to use ${S} in SRC_URI as S contains references
to the version which results in a circular list of variable lookups.

destsuffix is relative to WORKDIR and defaults to git/, so use relative
paths with the same result.

Signed-off-by: Ross Burton <ross.burton@arm.com>
---
 .../trusted-firmware-m/trusted-firmware-m_1.5.0.bb     | 10 +++++-----
 1 file changed, 5 insertions(+), 5 deletions(-)

Comments

Jon Mason Jan. 24, 2022, 7:53 p.m. UTC | #1
On Mon, 24 Jan 2022 16:29:44 +0000, Ross Burton wrote:
> It's not recommended to use ${S} in SRC_URI as S contains references
> to the version which results in a circular list of variable lookups.
> 
> destsuffix is relative to WORKDIR and defaults to git/, so use relative
> paths with the same result.

Applied, thanks!

[1/4] arm/trusted-firmware-m: use relative paths for SRC_URI destsuffix
      commit: 841179266847669f71cb2ea66d55bd62ec28249b
[2/4] arm-bsp/trusted-firmware-m: use SRCPV in the corstone1000 overrides
      commit: 82d91ee3ac1dce0a314414e5ead8cb898caf0236
[3/4] arm-bsp/optee-os: use SRCPV in the corstone1000 overrides
      commit: 1fbdea98ce2738dda827af070e0156b907f97422
[4/4] arm/psa-arch-tests: set PV correctly
      commit: ed737688f26131a63d67622ed4f8cc21055d7dfc

Best regards,

Patch

diff --git a/meta-arm/recipes-bsp/trusted-firmware-m/trusted-firmware-m_1.5.0.bb b/meta-arm/recipes-bsp/trusted-firmware-m/trusted-firmware-m_1.5.0.bb
index fe3f729c..302fd2cd 100644
--- a/meta-arm/recipes-bsp/trusted-firmware-m/trusted-firmware-m_1.5.0.bb
+++ b/meta-arm/recipes-bsp/trusted-firmware-m/trusted-firmware-m_1.5.0.bb
@@ -15,11 +15,11 @@  LIC_FILES_CHKSUM = "file://license.rst;md5=07f368487da347f3c7bd0fc3085f3afa \
                     file://../mbedtls/LICENSE;md5=3b83ef96387f14655fc854ddc3c6bd57 \
                     file://../mcuboot/LICENSE;md5=b6ee33f1d12a5e6ee3de1e82fb51eeb8"
 
-SRC_URI  = "git://git.trustedfirmware.org/TF-M/trusted-firmware-m.git;protocol=https;branch=${SRCBRANCH_tfm};name=tfm;destsuffix=${S} \
-            git://git.trustedfirmware.org/TF-M/tf-m-tests.git;protocol=https;branch=release/1.5.x;name=tfm-tests;destsuffix=${S}/../tf-m-tests \
-            git://github.com/ARMmbed/mbedtls.git;protocol=https;branch=master;name=mbedtls;destsuffix=${S}/../mbedtls \
-            git://github.com/mcu-tools/mcuboot.git;protocol=https;branch=main;name=mcuboot;destsuffix=${S}/../mcuboot \
-            file://cbor2.patch;patchdir=${S}/../mcuboot \
+SRC_URI  = "git://git.trustedfirmware.org/TF-M/trusted-firmware-m.git;protocol=https;branch=${SRCBRANCH_tfm};name=tfm;destsuffix=git/tfm \
+            git://git.trustedfirmware.org/TF-M/tf-m-tests.git;protocol=https;branch=release/1.5.x;name=tfm-tests;destsuffix=git/tf-m-tests \
+            git://github.com/ARMmbed/mbedtls.git;protocol=https;branch=master;name=mbedtls;destsuffix=git/mbedtls \
+            git://github.com/mcu-tools/mcuboot.git;protocol=https;branch=main;name=mcuboot;destsuffix=git/mcuboot \
+            file://cbor2.patch;patchdir=../mcuboot \
             "
 
 # The required dependencies are documented in tf-m/config/config_default.cmake