[1/3] arm-bsp/optee: add patch to support higher DRAM on TC

Message ID 20220121115643.485616-1-arunachalam.ganapathy@arm.com
State New
Headers show
Series [1/3] arm-bsp/optee: add patch to support higher DRAM on TC | expand

Commit Message

Arunachalam Ganapathy Jan. 21, 2022, 11:56 a.m. UTC
Signed-off-by: Arunachalam Ganapathy <arunachalam.ganapathy@arm.com>
Change-Id: I54831317126b27e8635d941dce321df8471301f1
---
 ...ction-ID-according-to-FFA-v1.1-spec.patch} |  0
 ...e-UUID.patch => 0003-Fix-optee-UUID.patch} |  0
 ...lcompute-add-support-for-higher-DRAM.patch | 60 +++++++++++++++++++
 .../optee/optee-os-generic-tc.inc             |  7 ++-
 4 files changed, 64 insertions(+), 3 deletions(-)
 rename meta-arm-bsp/recipes-security/optee/files/optee-os/tc/{0003-ffa-Update-function-ID-according-to-FFA-v1.1-spec.patch => 0002-ffa-Update-function-ID-according-to-FFA-v1.1-spec.patch} (100%)
 rename meta-arm-bsp/recipes-security/optee/files/optee-os/tc/{0001-Fix-optee-UUID.patch => 0003-Fix-optee-UUID.patch} (100%)
 create mode 100644 meta-arm-bsp/recipes-security/optee/files/optee-os/tc/0004-plat-totalcompute-add-support-for-higher-DRAM.patch

Comments

Jon Mason Jan. 21, 2022, 1:51 p.m. UTC | #1
On Fri, 21 Jan 2022 11:56:41 +0000, Arunachalam Ganapathy wrote:
> 


Applied, thanks!

[1/3] arm-bsp/optee: add patch to support higher DRAM on TC
      commit: 2201fa268d6b2184e60fe8e8f5e1c25b6858ebf0
[2/3] arm-bsp: Set preferred u-boot version to 2021.10 for TC
      commit: 88334e166432e7bc5fd7f857ade8f59aaecabba9
[3/3] arm/u-boot: add patch to support higher DRAM on TC
      commit: 5377fb7e096290d2c05ab69032ae6b436c5f9358

Best regards,

Patch

diff --git a/meta-arm-bsp/recipes-security/optee/files/optee-os/tc/0003-ffa-Update-function-ID-according-to-FFA-v1.1-spec.patch b/meta-arm-bsp/recipes-security/optee/files/optee-os/tc/0002-ffa-Update-function-ID-according-to-FFA-v1.1-spec.patch
similarity index 100%
rename from meta-arm-bsp/recipes-security/optee/files/optee-os/tc/0003-ffa-Update-function-ID-according-to-FFA-v1.1-spec.patch
rename to meta-arm-bsp/recipes-security/optee/files/optee-os/tc/0002-ffa-Update-function-ID-according-to-FFA-v1.1-spec.patch
diff --git a/meta-arm-bsp/recipes-security/optee/files/optee-os/tc/0001-Fix-optee-UUID.patch b/meta-arm-bsp/recipes-security/optee/files/optee-os/tc/0003-Fix-optee-UUID.patch
similarity index 100%
rename from meta-arm-bsp/recipes-security/optee/files/optee-os/tc/0001-Fix-optee-UUID.patch
rename to meta-arm-bsp/recipes-security/optee/files/optee-os/tc/0003-Fix-optee-UUID.patch
diff --git a/meta-arm-bsp/recipes-security/optee/files/optee-os/tc/0004-plat-totalcompute-add-support-for-higher-DRAM.patch b/meta-arm-bsp/recipes-security/optee/files/optee-os/tc/0004-plat-totalcompute-add-support-for-higher-DRAM.patch
new file mode 100644
index 0000000..293ea7d
--- /dev/null
+++ b/meta-arm-bsp/recipes-security/optee/files/optee-os/tc/0004-plat-totalcompute-add-support-for-higher-DRAM.patch
@@ -0,0 +1,60 @@ 
+From 7fb6d720a285b6135a9247b2adde833ea90e2549 Mon Sep 17 00:00:00 2001
+From: Usama Arif <usama.arif@arm.com>
+Date: Mon, 27 Sep 2021 19:58:56 +0100
+Subject: [PATCH] plat-totalcompute: add support for higher DRAM
+
+The new 6GB DRAM bank starts at 0x8080000000.
+
+Signed-off-by: Usama Arif <usama.arif@arm.com>
+Acked-by: Jens Wiklander <jens.wiklander@linaro.org>
+
+Upstream-Status: Backport [https://github.com/OP-TEE/optee_os/commit/6d8430f943e091282849b188fbc0847c159e5de4]
+Signed-off-by: Arunachalam Ganapathy <arunachalam.ganapathy@arm.com>
+---
+ core/arch/arm/plat-totalcompute/conf.mk           | 2 ++
+ core/arch/arm/plat-totalcompute/main.c            | 1 +
+ core/arch/arm/plat-totalcompute/platform_config.h | 3 +++
+ 3 files changed, 6 insertions(+)
+
+diff --git a/core/arch/arm/plat-totalcompute/conf.mk b/core/arch/arm/plat-totalcompute/conf.mk
+index 558b7889..e894b1e1 100644
+--- a/core/arch/arm/plat-totalcompute/conf.mk
++++ b/core/arch/arm/plat-totalcompute/conf.mk
+@@ -24,6 +24,8 @@ platform-cflags-debug-info = -gdwarf-2
+ platform-aflags-debug-info = -gdwarf-2
+ endif
+ 
++$(call force,CFG_CORE_ARM64_PA_BITS,40)
++
+ ifneq (,$(filter ${PLATFORM_FLAVOR},tc0 tc1))
+ CFG_TEE_CORE_NB_CORE = 8
+ 
+diff --git a/core/arch/arm/plat-totalcompute/main.c b/core/arch/arm/plat-totalcompute/main.c
+index 42acf8dd..eab237bf 100644
+--- a/core/arch/arm/plat-totalcompute/main.c
++++ b/core/arch/arm/plat-totalcompute/main.c
+@@ -27,6 +27,7 @@ register_phys_mem_pgdir(MEM_AREA_IO_SEC, GICD_BASE, GIC_DIST_REG_SIZE);
+ #endif
+ 
+ register_ddr(DRAM0_BASE, DRAM0_SIZE);
++register_ddr(DRAM1_BASE, DRAM1_SIZE);
+ 
+ #ifndef CFG_CORE_SEL2_SPMC
+ void main_init_gic(void)
+diff --git a/core/arch/arm/plat-totalcompute/platform_config.h b/core/arch/arm/plat-totalcompute/platform_config.h
+index 4255abca..b474a899 100644
+--- a/core/arch/arm/plat-totalcompute/platform_config.h
++++ b/core/arch/arm/plat-totalcompute/platform_config.h
+@@ -26,6 +26,9 @@
+ #define DRAM0_BASE		0x80000000
+ #define DRAM0_SIZE		0x7d000000
+ 
++#define DRAM1_BASE		0x8080000000ULL
++#define DRAM1_SIZE		0x180000000ULL
++
+ #define TZCDRAM_BASE		0xff000000
+ #define TZCDRAM_SIZE		0x01000000
+ 
+-- 
+2.30.2
+
diff --git a/meta-arm-bsp/recipes-security/optee/optee-os-generic-tc.inc b/meta-arm-bsp/recipes-security/optee/optee-os-generic-tc.inc
index 63abbb1..eeaa59a 100644
--- a/meta-arm-bsp/recipes-security/optee/optee-os-generic-tc.inc
+++ b/meta-arm-bsp/recipes-security/optee/optee-os-generic-tc.inc
@@ -1,7 +1,7 @@ 
 # Total Compute (tc) specific configuration for optee-os and optee-os-tadevkit
 
 # Intermediate SHA with 3.14 baseline version
-# This has TC0 platform support
+# This has TC0 and TC1 platform support
 SRCREV = "e4f34e786135079160697d88212591105a65fbce"
 PV = "3.14.0+git${SRCPV}"
 
@@ -9,8 +9,9 @@  FILESEXTRAPATHS:prepend := "${THISDIR}/files/optee-os/tc:"
 SRC_URI:append:tc = " \
     file://sp_layout.json \
     file://0001-WIP-Enable-managed-exit.patch \
-    file://0003-ffa-Update-function-ID-according-to-FFA-v1.1-spec.patch \
-    file://0001-Fix-optee-UUID.patch \
+    file://0002-ffa-Update-function-ID-according-to-FFA-v1.1-spec.patch \
+    file://0003-Fix-optee-UUID.patch \
+    file://0004-plat-totalcompute-add-support-for-higher-DRAM.patch \
     "
 
 COMPATIBLE_MACHINE = "(tc?)"