[meta-python,1/2] python3-autobahn: Upgrade 22.4.2 -> 22.5.1

Message ID 20220705142359.1010195-1-leon.anavi@konsulko.com
State New
Headers show
Series [meta-python,1/2] python3-autobahn: Upgrade 22.4.2 -> 22.5.1 | expand

Commit Message

Leon Anavi July 5, 2022, 2:23 p.m. UTC
Upgrade to release 22.5.1:

- new: WAMP Flatbuffers IDL and schema processing (experimental)
- new: WAMP-cryptosign trustroot (experimental)
- new: add wrapper type for CryptosignAuthextra
- fix: stricted type checking of Challenge; fix cryposign unit test
- new: more test coverage
- fix: reduce log noise
- fix: forward channel_binding selected in Component client
- new: expand ISigningKey to provide security_module/key_id
- fix: Component cryptosign test
- fix: add type hints; fix channel_binding
- new: work on federated realms and secmods
- new: rename to and work on a.w.CryptosignKey
- new: add bip44 for cryptosign test
- fix: remove all txaio.make_logger refs from generic code
- new: initial support for federated WAMP realms via
  a.x.FederatedRealm/Seeder
- new: moved utility functions and unit tests for WAMP realm name
  checking from Crossbar.io
- new: allow list of URLs for transports in a.t.component.Component
- new: add websocket_options to a.t.wamp.ApplicationRunner
- new: add stop_at_close flag in a.t.component.run
- fix: reduce log noise (regression) on ApplicationRunner Twisted
- new: allow max_retry_delay==0 for always-immediate auto-reconnect
  in ApplicationRunner on Twisted
- new: add websocket_options to WAMP ApplicationRunner on Twisted
- new: more type hints and docs

Signed-off-by: Leon Anavi <leon.anavi@konsulko.com>
---
 .../{python3-autobahn_22.4.2.bb => python3-autobahn_22.5.1.bb}  | 2 +-
 1 file changed, 1 insertion(+), 1 deletion(-)
 rename meta-python/recipes-devtools/python/{python3-autobahn_22.4.2.bb => python3-autobahn_22.5.1.bb} (86%)

Patch

diff --git a/meta-python/recipes-devtools/python/python3-autobahn_22.4.2.bb b/meta-python/recipes-devtools/python/python3-autobahn_22.5.1.bb
similarity index 86%
rename from meta-python/recipes-devtools/python/python3-autobahn_22.4.2.bb
rename to meta-python/recipes-devtools/python/python3-autobahn_22.5.1.bb
index 3dc308385..956399b56 100644
--- a/meta-python/recipes-devtools/python/python3-autobahn_22.4.2.bb
+++ b/meta-python/recipes-devtools/python/python3-autobahn_22.5.1.bb
@@ -3,7 +3,7 @@  HOMEPAGE = "http://crossbar.io/autobahn"
 LICENSE = "MIT"
 LIC_FILES_CHKSUM = "file://LICENSE;md5=97c0bda20ad1d845c6369c0e47a1cd98"
 
-SRC_URI[sha256sum] = "57b7acf228d50d83cf327372b889e2a168a869275b26e17917ed0b4cf4d823a6"
+SRC_URI[sha256sum] = "34aa5569b0b4419f8c277792c600dc2518c4930928c74e2279ef8b88d8b8a3ea"
 
 inherit pypi setuptools3