[meta-ti,dunfell] optee-os: Use software RNG on AM62x and J721s2

Message ID 20220627204042.27706-1-afd@ti.com
State Accepted
Delegated to: Ryan Eatmon
Headers show
Series [meta-ti,dunfell] optee-os: Use software RNG on AM62x and J721s2 | expand

Commit Message

Andrew Davis June 27, 2022, 8:40 p.m. UTC
The TRNG driver is not currently functional for these two platforms.
Disable the TRNG driver until fixed.

Reported-by: Vignesh Raghavendra <vigneshr@ti.com>
Signed-off-by: Andrew Davis <afd@ti.com>
---
 recipes-security/optee/optee-os_%.bbappend | 4 ++++
 1 file changed, 4 insertions(+)

Comments

Bajjuri, Praneeth June 28, 2022, 6:41 a.m. UTC | #1
On 6/28/2022 2:10 AM, Andrew Davis via lists.yoctoproject.org wrote:
> The TRNG driver is not currently functional for these two platforms.
> Disable the TRNG driver until fixed.
> 
> Reported-by: Vignesh Raghavendra <vigneshr@ti.com>
> Signed-off-by: Andrew Davis <afd@ti.com>

Reviewed-by: Praneeth Bajjuri <praneeth@ti.com>


> ---
>   recipes-security/optee/optee-os_%.bbappend | 4 ++++
>   1 file changed, 4 insertions(+)
> 
> diff --git a/recipes-security/optee/optee-os_%.bbappend b/recipes-security/optee/optee-os_%.bbappend
> index 16c10979..7fe5f26e 100644
> --- a/recipes-security/optee/optee-os_%.bbappend
> +++ b/recipes-security/optee/optee-os_%.bbappend
> @@ -6,6 +6,10 @@ DEPENDS_append_ti-soc = " python3-cryptography-native"
>   
>   EXTRA_OEMAKE_append_k3 = "${@ 'CFG_CONSOLE_UART='+ d.getVar('OPTEE_K3_USART') if d.getVar('OPTEE_K3_USART') else ''}"
>   
> +EXTRA_OEMAKE_append_am62xx-evm = " CFG_WITH_SOFTWARE_PRNG=y"
> +EXTRA_OEMAKE_append_j721s2-evm = " CFG_WITH_SOFTWARE_PRNG=y"
> +EXTRA_OEMAKE_append_j721s2-hs-evm = " CFG_WITH_SOFTWARE_PRNG=y"
> +
>   do_compile_prepend_ti-soc() {
>       export TI_SECURE_DEV_PKG=${TI_SECURE_DEV_PKG}
>   }
> 
> 
> 
> -=-=-=-=-=-=-=-=-=-=-=-
> Links: You receive all messages sent to this group.
> View/Reply Online (#14844): https://lists.yoctoproject.org/g/meta-ti/message/14844
> Mute This Topic: https://lists.yoctoproject.org/mt/92030864/2167429
> Group Owner: meta-ti+owner@lists.yoctoproject.org
> Unsubscribe: https://lists.yoctoproject.org/g/meta-ti/unsub [praneeth@ti.com]
> -=-=-=-=-=-=-=-=-=-=-=-
>

Patch

diff --git a/recipes-security/optee/optee-os_%.bbappend b/recipes-security/optee/optee-os_%.bbappend
index 16c10979..7fe5f26e 100644
--- a/recipes-security/optee/optee-os_%.bbappend
+++ b/recipes-security/optee/optee-os_%.bbappend
@@ -6,6 +6,10 @@  DEPENDS_append_ti-soc = " python3-cryptography-native"
 
 EXTRA_OEMAKE_append_k3 = "${@ 'CFG_CONSOLE_UART='+ d.getVar('OPTEE_K3_USART') if d.getVar('OPTEE_K3_USART') else ''}"
 
+EXTRA_OEMAKE_append_am62xx-evm = " CFG_WITH_SOFTWARE_PRNG=y"
+EXTRA_OEMAKE_append_j721s2-evm = " CFG_WITH_SOFTWARE_PRNG=y"
+EXTRA_OEMAKE_append_j721s2-hs-evm = " CFG_WITH_SOFTWARE_PRNG=y"
+
 do_compile_prepend_ti-soc() {
     export TI_SECURE_DEV_PKG=${TI_SECURE_DEV_PKG}
 }