python3-cryptography: Cleanup DEPENDS/RDEPENDS

Message ID 20220626114238.6517-1-alex.kiernan@gmail.com
State Accepted, archived
Commit 4907bf80e6d3e98c005bcfbc690b75fab104c166
Headers show
Series python3-cryptography: Cleanup DEPENDS/RDEPENDS | expand

Commit Message

Alex Kiernan June 26, 2022, 11:42 a.m. UTC
idna was removed in 3.1, asn1crypto in 2.8, six in 3.3.1; setuptools
never appears to have been a runtime requirement. With these removed the
recipe both builds and passes ptest:

  ===== 2824 passed, 52 skipped, 85319 subtests passed in 3932.89s (1:05:32) =====

Also drop redundant ${PYTHON_PN}-setuptools-rust-native DEPENDS as this
comes from python_setuptools3_rust.bbclass.

Signed-off-by: Alex Kiernan <alexk@zuma.ai>
Signed-off-by: Alex Kiernan <alex.kiernan@gmail.com>
---
 .../recipes-devtools/python/python3-cryptography_37.0.2.bb | 7 -------
 1 file changed, 7 deletions(-)

Patch

diff --git a/meta/recipes-devtools/python/python3-cryptography_37.0.2.bb b/meta/recipes-devtools/python/python3-cryptography_37.0.2.bb
index 470cf4388c2e..9ef3a61e9f2e 100644
--- a/meta/recipes-devtools/python/python3-cryptography_37.0.2.bb
+++ b/meta/recipes-devtools/python/python3-cryptography_37.0.2.bb
@@ -66,18 +66,11 @@  SRC_URI += "file://run-ptest \
 inherit pypi python_setuptools3_rust
 
 DEPENDS += " \
-    ${PYTHON_PN}-asn1crypto-native \
     ${PYTHON_PN}-cffi-native \
-    ${PYTHON_PN}-setuptools-rust-native \
-    ${PYTHON_PN}-six-native \
 "
 
 RDEPENDS:${PN} += " \
-    ${PYTHON_PN}-asn1crypto \
     ${PYTHON_PN}-cffi \
-    ${PYTHON_PN}-idna \
-    ${PYTHON_PN}-setuptools \
-    ${PYTHON_PN}-six \
 "
 
 RDEPENDS:${PN}:append:class-target = " \