Remove use of deprecated `lnr` command

Message ID 20211112141414.575974-1-ross.burton@arm.com
State New
Headers show
Series Remove use of deprecated `lnr` command | expand

Commit Message

Ross Burton Nov. 12, 2021, 2:14 p.m. UTC
lnr is deprecated and will be removed soon, so replace it with `ln -rs`

Signed-off-by: Ross Burton <ross.burton@arm.com>
---
 .../external-arm-toolchain/arm-binary-toolchain.inc             | 2 +-
 .../recipes-devtools/external-arm-toolchain/armcompiler_6.16.bb | 2 +-
 meta-arm/recipes-devtools/fvp/fvp-common.inc                    | 2 +-
 3 files changed, 3 insertions(+), 3 deletions(-)

Comments

Jon Mason Nov. 15, 2021, 3:34 p.m. UTC | #1
On Fri, 12 Nov 2021 14:14:14 +0000, Ross Burton wrote:
> lnr is deprecated and will be removed soon, so replace it with `ln -rs`
> 
> 

Applied, thanks!

[1/1] Remove use of deprecated `lnr` command
      commit: 2098ffd84a2c78824045e40067c418b86df7708c

Best regards,

Patch

diff --git a/meta-arm-toolchain/recipes-devtools/external-arm-toolchain/arm-binary-toolchain.inc b/meta-arm-toolchain/recipes-devtools/external-arm-toolchain/arm-binary-toolchain.inc
index f237454c..da12a778 100644
--- a/meta-arm-toolchain/recipes-devtools/external-arm-toolchain/arm-binary-toolchain.inc
+++ b/meta-arm-toolchain/recipes-devtools/external-arm-toolchain/arm-binary-toolchain.inc
@@ -11,7 +11,7 @@  do_install() {
     install -d ${D}${bindir}
     # Symlink all executables into bindir
     for f in ${D}${datadir}/bin/${BINNAME}-*; do
-        lnr $f ${D}${bindir}/$(basename $f)
+        ln -rs $f ${D}${bindir}/$(basename $f)
     done
 }
 
diff --git a/meta-arm-toolchain/recipes-devtools/external-arm-toolchain/armcompiler_6.16.bb b/meta-arm-toolchain/recipes-devtools/external-arm-toolchain/armcompiler_6.16.bb
index b630ebfe..e1d5cc38 100644
--- a/meta-arm-toolchain/recipes-devtools/external-arm-toolchain/armcompiler_6.16.bb
+++ b/meta-arm-toolchain/recipes-devtools/external-arm-toolchain/armcompiler_6.16.bb
@@ -46,6 +46,6 @@  do_install() {
     install -d ${D}${bindir}
     # Symlink all executables into bindir
     for f in ${D}${datadir}/armclang/bin/*; do
-        lnr $f ${D}${bindir}/$(basename $f)
+        ln -rs $f ${D}${bindir}/$(basename $f)
     done
 }
diff --git a/meta-arm/recipes-devtools/fvp/fvp-common.inc b/meta-arm/recipes-devtools/fvp/fvp-common.inc
index 83e03131..43c1b46f 100644
--- a/meta-arm/recipes-devtools/fvp/fvp-common.inc
+++ b/meta-arm/recipes-devtools/fvp/fvp-common.inc
@@ -21,7 +21,7 @@  FVPDIR = "${libdir}/fvp/${BPN}"
 # Used in do_install to create symlinks in $bindir to $FVPDIR
 fvp_link_binaries() {
     for FVP in ${D}${FVPDIR}/models/${FVP_ARCH}/FVP_*; do
-        lnr $FVP ${D}${bindir}/$(basename $FVP)
+        ln -rs $FVP ${D}${bindir}/$(basename $FVP)
     done
     # But not the .so files too
     rm -f ${D}${bindir}/*.so