[meta-mingw] libsdl2: disable gles2 support for class-nativesdk

Message ID 20220604165251.369796-1-f_l_k@t-online.de
State New
Headers show
Series [meta-mingw] libsdl2: disable gles2 support for class-nativesdk | expand

Commit Message

Markus Volk June 4, 2022, 4:52 p.m. UTC
this fixes:
| Has header "sys/select.h" : NO
| Checking whether type "fd_set" has member "fds_bits" : NO
| Checking whether type "fd_set" has member "__fds_bits" : NO
|
| ../xorgproto-2022.1/include/X11/meson.build:19:4: ERROR: Problem encountered: Your fd_set is too weird.
|
| A full log can be found at /home/flk/build/poky/build/tmp/work/x86_64-nativesdk-mingw32-w64-mingw32/nativesdk-xorgproto/2022.1-r0/build/meson-logs/meson-log.txt

Signed-off-by: Markus Volk <f_l_k@t-online.de>
---
 recipes-graphics/libsdl2/libsdl2_%.bbappend | 2 +-
 1 file changed, 1 insertion(+), 1 deletion(-)

Patch

diff --git a/recipes-graphics/libsdl2/libsdl2_%.bbappend b/recipes-graphics/libsdl2/libsdl2_%.bbappend
index 89532d6..4f9cde1 100644
--- a/recipes-graphics/libsdl2/libsdl2_%.bbappend
+++ b/recipes-graphics/libsdl2/libsdl2_%.bbappend
@@ -1,7 +1,7 @@ 
 # Need to disable X11 explictly as nativesdk-libxdmcp fails:
 # .libs/Fill.o:Fill.c:(.text+0x48): undefined reference to `_imp__recvfrom@24'
 # .libs/Flush.o:Flush.c:(.text+0x36): undefined reference to `_imp__sendto@24'
-PACKAGECONFIG:remove:mingw32:class-nativesdk = "x11 opengl"
+PACKAGECONFIG:remove:mingw32:class-nativesdk = "x11 opengl gles2"
 
 # libtool doesn't think it can link windres output (COFF) with libtool objects
 # (COFF) , but it can.  This might be because file misidentifies version.o: